Jump to content
  • 0

Jetson Nano



Good news.  :)

Thanks to the work of many, there is now a real opportunity to run the Armbian system with the main core on Jetson Nano, and more importantly, it is easy to integrate the image build process into the official GIT Armbian. In the near future, I plan to post ready-made images with the latest kernel 5.10.22 on the download site. To run them, you need to update u-boot to Jetson Nano. This is very easy to do, just run the latest official version of Ubuntu for Jetson Nano from the SD card, it will update itself in SPI (?) u-boot to the latest version (2020.04), after that you can run Armbian from any SD card or USB media. The new u-boot supports automatic system startup from both media or over the network. Also, now you can build an Armbian image for Jetson Nano yourself, easily build the latest kernel with the necessary options, etc.  








Link to comment
Share on other sites

Recommended Posts

  • 0
22.01.2023 в 16:52, Nurb432 сказал:

And again, my limited knowledge of how these things work, it sounds like just a partition table issue for me to sort out, and things like the device tree/etc are already good enough?

Replace the DTB name in /boot//grub/grub.cfg with your model (I do not know which one is needed), you can try all the names in a row from the /dtb/nvidia directory. But if you use the wrong DTB, there is a chance of damage (if incorrect supply voltage values are set there).

Link to comment
Share on other sites

  • 0
On 1/13/2023 at 12:48 PM, balbes150 said:

Please check the launch of the latest versions 20230112-current (6.1.4) and 20230112-edge (6.2-rc3) on jetson Nano. I am interested in the general launch of the system from an SD card or USB flash drive.


Tried running 6.1.8 EDGE on Jetson Nano. The O/S boots however dmesg is throwing errors and pwm-fan not available.


6.0.19 CURRENT is working fine.







Link to comment
Share on other sites

  • 0

It's not compatibility with latest bootloader?


[0000.125] [L4T TegraBoot] (version 00.00.2018.01-l4t-c536fca9)
[0000.131] Processing in cold boot mode Bootloader 2
[0000.135] A02 Bootrom Patch rev = 1023
[0000.139] Power-up reason: pmc por
[0000.142] No Battery Present
[0000.145] pmic max77620 reset reason
[0000.148] pmic max77620 NVERC : 0x40
[0000.151] RamCode = 0
[0000.154] Platform has DDR4 type RAM
[0000.157] max77620 disabling SD1 Remote Sense
[0000.161] Setting DDR voltage to 1125mv
[0000.165] Serial Number of Pmic Max77663: 0xf24c9
[0000.173] Entering ramdump check
[0000.176] Get RamDumpCarveOut = 0x0
[0000.179] RamDumpCarveOut=0x0,  RamDumperFlag=0xe59ff3f8
[0000.184] Last reboot was clean, booting normally!                             
[0000.189] Sdram initialization is successful                                   
[0000.193] SecureOs Carveout Base=0x00000000ff800000 Size=0x00800000            
[0000.199] Lp0 Carveout Base=0x00000000ff780000 Size=0x00001000                 
[0000.205] BpmpFw Carveout Base=0x00000000ff700000 Size=0x00080000              
[0000.211] GSC1 Carveout Base=0x00000000ff600000 Size=0x00100000                
[0000.216] GSC2 Carveout Base=0x00000000ff500000 Size=0x00100000                
[0000.222] GSC4 Carveout Base=0x00000000ff400000 Size=0x00100000                
[0000.228] GSC5 Carveout Base=0x00000000ff300000 Size=0x00100000                
[0000.234] GSC3 Carveout Base=0x000000017f300000 Size=0x00d00000                
[0000.250] RamDump Carveout Base=0x00000000ff280000 Size=0x00080000             
[0000.256] Platform-DebugCarveout: 0                                            
[0000.259] Nck Carveout Base=0x00000000ff080000 Size=0x00200000                 
[0000.265] Non secure mode, and RB not enabled.                                 
[0000.269] Read GPT from (4:0)                                                  
[0000.442] Csd NumOfBlocks=124735488                                            
[0000.447] Set High speed to 1                                                  
[0000.450] Error mask set in wait for cmd complete with error 0x3 in HwSdmmcWai
[0000.460] Command complete wait failed with error 0x3 Interrupt 0x18001        
[0000.467] Number of retries left 4                                             
[0000.476] Using GPT Primary to query partitions                                
[0000.480] Read PT from (2:0)                                                   
[0000.496] Using BFS PT to query partitions                                     
[0000.501] Loading Tboot-CPU binary                                             
[0000.530] Verifying TBC in OdmNonSecureSBK mode                                
[0000.540] Bootloader load address is 0xa0000000, entry address is 0xa0000258   
[0000.547] Bootloader downloaded successfully.                                  
[0000.551] Downloaded Tboot-CPU binary to 0xa0000258                            
[0000.556] MAX77620_GPIO5 configured                                            
[0000.559] CPU power rail is up                                                 
[0000.562] CPU clock enabled                                                    
[0000.566] Performing RAM repair                                                
[0000.569] Updating A64 Warmreset Address to 0xa00002e9                         
[0000.574] PT: Partition RP1 NOT found !                                        
[0000.578] Warning: Find Partition via PT Failed                                
[0000.582] Bootloader DTB invalid, fallback to kernel DTB.                      
[0000.588] PT: Partition DTB NOT found !                                        
[0000.592] Warning: Find Partition via PT Failed                                
[0000.596] Error is 1                                                           


Not created DTB partition and partition RP1 not found huh?

Link to comment
Share on other sites

  • 0

Hello everyone.


Rather late to this thread, but I'm currently trying out a Jetson Nano 4GB (Devkit, no eMMC) I had in my closet.


I've already installed the most recent Jetpack (4.6.1), and ran the standard apt update and upgrade commands. From what I could tell after some Google-Fu, I have a 2020.4 version of u-boot.


Unfortunately, when I drop in an SD card (or USB drive, for that matter) with Armbian (tried both bookworm and jammy, and jammy with and without a desktop interface), I only get the NVIDIA POST screen, and then a black screen on my monitor.


Am I doing something wrong?


Any help is appreciated!


Thanks in advance.

Link to comment
Share on other sites

  • 0

I have the same problem like nanianmichaels. I have a jetson nano dev-kit 2GB. I tried Armbian 23.8 Bookworm Cinnamon. I ran official Jetpack 4.6.1 before, since I read it should automatically update u-boot. Running/Booting Armbian 23.8 Bookworm Cinnamon from SD-Card gets stuck at Nvidia Startup Screen. 

Link to comment
Share on other sites

  • 0

I have the same problem as nanianmichaels and sledge33: No output on HDMI after the Nvidia logo.


But otherwise the system is running and can be reached via network.

No desktop version installed as it should be used as a server - but using the command line on a display would be helpful as fallback in case of LAN problem or misconfiguration.


Device: Jetson Nano 4 GB Developer Kit

Arbian version: Armbian_23.8.1_Jetson-nano_jammy_current_6.1.50


Link to comment
Share on other sites

  • 0

For anyone else struggling to boot the Armbian builds on https://www.armbian.com/jetson-nano/


You need to install the newest JetPack packages on your device with the official Nvidia build first (ubuntu 18.04, kernel 4.9), so that the uboot bootloader is upgraded. Especially if you just pulled your Jetson Nano from the closet and you haven't used it in a long time. Here's the upgrade procedure:


You need to open /etc/apt/sources.list.d/nvidia-l4t-apt-source.list and modify the repository to use the lastest version of JetPack. For instance if the file says:


deb https://repo.download.nvidia.com/jetson/common r32.4 main
deb https://repo.download.nvidia.com/jetson/t210 r32.4 main


Then you need to change it into this, as 32.7 is currently the most recent version of jetpack that is still compatible with the old Jetson Nanos:

deb https://repo.download.nvidia.com/jetson/common r32.7 main
deb https://repo.download.nvidia.com/jetson/t210 r32.7 main


You can now do:


sudo apt-get update
sudo apt-get upgrade
sudo apt-get full-upgrade


It will upgrade everything Nvidia related and will also upgrade the bootloader, you should see something like this:


Setting up nvidia-l4t-bootloader (32.7.4-20230608212426) ...
Starting bootloader post-install procedure.
Update bootloader completed.
Reboot the target system for changes to take effect.

Then reboot once into the old SD so that the bootloader gets upgraded on the next reboot. Then you can flash Armbian to an SD card and it should boot. With the uboot upgrade I was able to boot Armbian_community_24.5.0-trunk.19_Jetson-nano_bookworm_current_6.6.16_minimal.img


I don't seem to have HDMI output but LAN and ssh works. Probably best to have another SD card so you can quickly swap back your old one with the official Nvidia build if you need to.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines