Jetson Nano

Recommended Posts

Good news.  :)

Thanks to the work of many, there is now a real opportunity to run the Armbian system with the main core on Jetson Nano, and more importantly, it is easy to integrate the image build process into the official GIT Armbian. In the near future, I plan to post ready-made images with the latest kernel 5.10.22 on the download site. To run them, you need to update u-boot to Jetson Nano. This is very easy to do, just run the latest official version of Ubuntu for Jetson Nano from the SD card, it will update itself in SPI (?) u-boot to the latest version (2020.04), after that you can run Armbian from any SD card or USB media. The new u-boot supports automatic system startup from both media or over the network. Also, now you can build an Armbian image for Jetson Nano yourself, easily build the latest kernel with the necessary options, etc.!j9QSDQSQ!6WpasOlbZYIInfw6yo4phQ

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

ok - false alarm ... looks like something was still wrong with my u-boot ... rerunning the jetpack image once more seems to have fixed it and now the image is booting fine also on the 2gb model :)


gpu acceleration is not working yet (llvmpipe is used instead), but in general it looks quite good: the tegra and nouveau drm drivers are properly loaded without errors ... according to and it looks like maybe some special xorg server and/or mesa needs to be compiled ... will maybe have a look at it over the weekend


btw. have any kernel patches been required to make it work with mainline or is the mainline support that good meanwhile that it just works?


best wishes - hexdump

Link to post
Share on other sites

i did some more research and for sure the nvidia gpu firmware is missing in the armbian-firmware - - it is part of the regular linux-firmware package


but even with that we are not there yet - i tried both xorg and wayland and both times ended up with GL_OUT_OF_MEMORY errors which i do not understand yet, but large parts of the probing looks good ... looks like nouveau.modeset=1 parameter might be required on boot as well ... will have to investigate things further ...

Link to post
Share on other sites

just a little update: i got the open source nouveau gpu driver working with the mainline kernel finally by using a self compiled xorg server from the latest sources (required - see:, a self compiled mesa 21.0.1 (not sure if this is really required) and the "nouveau.modeset=1" kernel cmdline parameter - what is nice is that it is opengl 4.3


so far the good part, the bad part is that it is extremely slow (glmark2 score of 68) as it is clocked at the lowest gpu frequency by default and trying to increase the gpu frequency via /sys/kernel/debug/dri/128/pstate seems to make the system quite unstable or quickly hangs it (maybe my power supply - 5.1v/3a - is not powerful enough?)


i'm also able to run a wayfire wayland session using the nouveau gpu driver, but it shows quite a few graphical artifacts when scrolling in a terminal or doing other activities - glmark2 score here is 83, but its also for lima or panfrost higher in wayland/wayfire than in xorg/xfce


all in all it looks like the quality of the open source nouveau driver on the jetson nano (maybe even in general?) is not really the best and as it looks to me far behind the quality of the lima and panfrost open source drivers for the mali gpus in other socs

Link to post
Share on other sites
02.05.2021 в 20:02, TonyMac32 сказал:

So far my Jetson Nano won't get to desktop using the images on the download site.  I have the original one, is this a device tree issue?

What model do you have and what image do you use ? Have you updated u-boot to the latest version ?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.