Jump to content
  • 0

[Invalid] - Network ports inconsistent behavior with 21.02.1 on a NanoPi R4S 4GB


hive
 Share

Question

I'd like some help please.

 

The ethernet device naming seems inconsistent.  

 

Sometimes one interface comes up as eth0 and sometimes as eth1, and sometimes not at all.  The enp1s0 interface seems to reliably come up, but not with the right config (sometimes it uses the config for enp1s0 and sometimes for eth0).

I am trying to assign status IP addresses (on different networks) to each interface, but because of the unreliable bringup of the network interfaces, I can't get a config that starts up correctly and consistency on reboots or cold boots.

 

As a test I ran the friendly-core-lite-focal from FriendlyCore and it does not have this issue.

 

Is there something I need to do on Arabian to get the network interface bringup to work?

I have static IP configs in /etc/network/interfaces.d called eth0, eth1 (these are the same, call it network A, because the 2nd network seems to sometimes come up as eth0) , and enp1s0 (configured for my second network, call it network B)

 

I'd greatly appreciate any help in making the network bring up consistent.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Your issue report is invalid for one or multiple reasons (non-exhaustive enumeration):

 

  • it has been stated at the wrong place
  • it lacks fundamental requested data
  • it could have been easily solved by a quick search and/or reading documentation
  • unsupported userspace/image/SBC

 

Since you refused to use the bug reporting form carefully and follow the information there as you have been asked for we have no intention to further investigate.

Please add missing information if applicable.

 

https://www.armbian.com/bugs

Link to comment
Share on other sites

Search Before Posting!

  • 0

I'm observing the same problem described by @hive, the 2 eth adapters are named as:

  1. enp1s0
  2. eth0 or eth1, meaning that the second adapter switch the name between eth0 and eth1 every time the nanopi-R4s reboot for instance after a kernel upgrade, creating a bunch of issues with the nat rules, vnstat and other tools that are configured with the name of that adapter.

 

The second problem is that the ethx (0 or 1) very often is losing its ip address and I must run the dhclient manually to get an ip address again, this adapter is connected directly to the Comcast modem.

 

Here the armbianmonitor -u link https://paste.armbian.com/ugewezical

 

Thank you for any help on this regarding.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...