wicd gets erroneous BAD PASSWORD


svkatielee
 Share

1 1

Recommended Posts

I found an old bug report on the same version of wicd that is delivered with the legacy builds.

Try to authenticate WPA for wifi, get bad password error. Repeated attempts to authenticate as many as 10 times before it is successful. It will finally succeed, therefore; the password is not bad.

 

https://bugs.launchpad.net/wicd/+bug/1084380

 

A short summary includes, there seems to be a problem in the wpa_supplicant that causes it to occasionally take too long to return from an authentication request. wicd rev 1.7.2 is set to wait 35 seconds then times out and reports BAD PASSWORD, when it should have reported a timeout. The suggested fix was to allow user config for the timeout, but the test of 250 system startups showed an averaged between 35 and 55 seconds. Their request was to set the default timeout for wpa_supplicant to 120 seconds.

 

The fix was promised for 1.7.3. 

Jessie/Trusty have wicd 1.7.2.4-4.1

Xenial has 1.7.4.xx

 

I believe this is why so many complaints are posted about wifi on the various armbian SBCs. And why there are so many different "solutions" that only work in special cases.

 

But this is a work-around for wpa_supplicant taking too long in some instances.

 

Can we get a newer release of wicd in the build?

I tried just downloading and installing wicd 1.7.4 but without anything else, it no longer connects at all ....

 

 

Link to post
Share on other sites

Donate and support the project!

I am willing to try some. I have only Orange Pis: One, PC, PC +, and PC 2E.

I have a few cheap wifi dongles and a couple really cheap Chinese routers.

 

What I don't have is a good understanding of hostapd/network manager and all the wpa_supplicant pieces.

And I don't' have much network access. I can't run your build tools because the network is too slow and unreliable.

 

So with a little guidance I'll give it a shot.

Link to post
Share on other sites

OK. Do the most obvious scenarios and try to see if there are problems. Use board / wifi adaptor / router combination that is working fine within your hardware, OPi 2e for example. We are not seeking for driver issues here, only all possible network modes that you can try.

 

- use our stock desktop image

- uninstall wicd

- install network-manager and try to break it down.

 

Try: fixed / DHCP for wire and wired connection, booting with cable, without, plug in after you boot, etc. 

 

open network connect, WPA2 network connect, ...

 

Add hostapd

http://docs.armbian.com/User-Guide_Advanced-Features/#how-to-set-wireless-access-point

 

retry some options.

Link to post
Share on other sites

I am not sure you can reduce wifi problems to a single point of failure ...

 

At least wicd is one of those single points of failure (the problem that you somewhere have to switch to 'none' to get WPA to work and that even this is sometimes confusing since the GUI provides 'none' and 'none' as the only two options -- see a google search for 'wicd none site:armbian.com') but at the time we started with GUI and H3 boards (back in march IIRC) we found that wicd could be considered the lesser evil compared to network-manager.

 

I usually avoid WiFi on Linux at all (since it's PITA anyway) and also threads dealing with WiFi but given the many posts claiming "WiFi not working" while it's 'just' a GUI issue since the distros we use ship with a somewhat broken wicd version searching for a replacement seems to be a good idea. I also asked myself (and @Igor) whether wpagui would be an option but won't try it myself since it's better if I waste my time on other subjects :)

Link to post
Share on other sites

It has taken a while but finally I now have Network Manager running instead of wicd.

Here is what I did on my Opi PC 2E installed and booting from nand:

Armbian Jessie desktop 5.14 apt-get upgraded to 5.16  and updated Aug 10, 165.

Connected to cheap CDR-King Wireless-N AP Router (Chinese)

 

apt-get install network-manager network-manager-gnome xfce4-notifyd  xfce4-indicator-plugin gnome-keyring gcr libgck-1-0 libgcr-3-common libgcr-base-3-1 libgcr-ui-3-1 p11-kit p11-kit-modules

apt-get remove --purge wicd python-wicd wicd-daemon wicd-gtk

gpasswd -a USERNAME netdev
 

Comment out eth0 from /etc/network/interfaces, (also wlan0 if you have it)

Change managed= to true in /etc/NetworkManager/NetworkManager.conf

 

Create new file with this content: /etc/polkit-1/localauthority/50-local.d/org.freedesktop.NetworkManager.pkla
[nm-applet]
Identity=unix-group:netdev
Action=org.freedesktop.NetworkManager.*
ResultAny=yes
ResultInactive=no
ResultActive=yes

 

with eht0 connected and on-board WiFi,

reboot

came up with eth0 and WiFi available

click nm-applet in menu bar

select ifupdown (eth0)

    Ethernet comes up

selected my wifi ssid

    Prompt for password

entered password,

    prompted for default keyring password, left blank and click Continue and Continue again for clear text storage of password

 

rebooted, still have both connected, but icon in nm-applet only shows WiFi

but right-click->Connection Info shows both.

 

Now for some testing ....

Link to post
Share on other sites

There is one problem regarding MPV and HDMI audio, perhaps any app and (via pulseaudio) HDMI audio? 

Test subject: Orange Pi PC+ legacy, jessie desktop with Network manager and Pulseaudio (pasystray pavucontrol pulseaudio paman paprefs pavumeter pulseaudio-module-gconf pulseaudio-module-zeroconf).

 

When playing 1080p_H264_AAC_25fps_7200K.MP4 on HDMI audio out playing is stuttered but it's normal when playing via analogue jack.

I just noticed but can't focus any more to find out what is causing this.

 

If anyone can replicate this would be helpful.

 

Add:

This is the exact image which I use.

Link to post
Share on other sites

Nice. I am also testing Network manager and ... Pulse Audio all day and haven't found any serious problems yet.

@Igor I wonder if you had as much trouble getting NM installed as I did? I tried for a combination that did not need gnome-keyring and network-manager-gnome because of all the extra support packages. And I did not want to enter a password at every boot. To avoid the password I had to use the null passphrase in the default keyring which I thought might not be acceptable.

 

I also tried to find a different alternative. I didn't find any that seemed to work headless and in a desktop. Most choices were various subsets of wicd or NM (wpa_supplicant, netctl, etc.). I even tried to compile wicd.1.7.4 but it needs things in newer kernels I think.

Link to post
Share on other sites

@Zador

 

Yes, that helped.

 

@svkatielee

 

Without using gnome-keyring / having one password storage for all users would be fine. It must be doable somehow ... Maybe setting null password non interactive by default? I did briefly seek for how to do this, but haven't got anywhere.

 

Let's stick to network manager and fix possible problems within.

Link to post
Share on other sites

Without using gnome-keyring / having one password storage for all users would be fine. It must be doable somehow ... Maybe setting null password non interactive by default? I did briefly seek for how to do this, but haven't got anywhere.

Looks like this depends on display manager used, and some workarounds are listed here: https://wiki.archlinux.org/index.php/GNOME/Keyring and here: https://wiki.gnome.org/Projects/GnomeKeyring/Pam

 

Using libpam-gnome-keyring should solve this issue if we ensure that "login" keyring password matches user's password.

Link to post
Share on other sites

I've just spent 2 complete days trying to reproduce the above steps for switching from wicd to NM and failing. (with 5.16 Opi 2E eMMC)

 

If I run vncserver as root, nm-applet works just fine: connects to wifi, edit connections. But not as a user.

 

Finally, the difference, I was trying to do it with tightvncserver (VNC) instead of a direct monitor. In frustration this morning I plugged the monitor in and there was the dialog pop-up to unlock the keyring!

 

So these are not the complete instructions for using VNC exclusively.

Link to post
Share on other sites

Thank you. It seems to work fine. I still have not had time to figure out hostapd with NM yet. My other life gets in the way.

 

Where is the additional discussion where you have decided to go ahead with switching these out instead of wicd? I have been having trouble finding the discussions since the big documentation change.

Link to post
Share on other sites

I set static IPs for several Opi's with nn-applet seems to work ok.

However, I had to do it al as root. My user can not edit connections still.

Armbian Jessie 5.18 from above link. No desktop, only nodm.

if  I su - root then nmtui I can edit oK. any other, the edit button is grayed out or the OK button is.

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

1 1