[Invalid] - nodejs 14 under Armbian 21.02.3 Buster installieren


 Share

2 2

Recommended Posts

Hello,

i have to update nodejs to version 14, but wenn i do 

curl -sL https://deb.nodesource.com/setup_14.x | sudo -E bash -sudo apt-get install -y nodejs

i become this error

bash: -d: Ungültige Option
Aufruf: bash [Lange GNU Option] [Option] ...
                bash [Lange GNU Option] [Option] Script-Datei ...
Lange GNU Optionen:
        --debug
        --debugger
        --dump-po-strings
        --dump-strings
        --help
        --init-file
        --login
        --noediting
        --noprofile
        --norc
        --posix
        --pretty-print
        --rcfile
        --restricted
        --verbose
        --version
Shell-Optionen:
        -ilrsD oder -c Kommando oder -O shopt_option            (Nur Aufruf)
        -abefhkmnptuvxBCHP oder Option -o

 

What can i do?

Thank you

Link to post
Share on other sites

Donate and support the project!

Your issue report is not a valid bug report per the Armbian bug reporting instructions (https://www.armbian.com/bugs).  With limited resources the Armbian project is only able to spend time on issues where all the requested information has been provided and for only the boards/images/software that are supported.  Your report is invalid for one or more of the following reasons (non-exhaustive list):

 

  • it is for an unsupported board or image (CSC/EOS/WIP/edge)
  • it is for software that is not supported (such as userspace modules installed on top of the core operating system)
  • it has been logged in the wrong forum (for example requests for help that are not actual bug reports)
  • it lacks requested data (armbianmonitor output)
  • it could have been easily solved by a quick search and/or reading documentation

 

Please review what you have submitted and the bug logging instructions (https://www.armbian.com/bugs) and either add the required information or open a new topic in the correct forum (such as Common issues / peer to peer technical support or General chit chat)

Link to post
Share on other sites

vor 22 Stunden schrieb gounthar:

You could maybe just add a newline, or download https://deb.nodesource.com/setup_14.x then add -x on the first line... or change your command line like that:


curl -sL https://deb.nodesource.com/setup_14.x | sudo -E bash -x

This set of commands does work for me.

When i do this, i become this message:

 

 curl -sL https://deb.nodesource.com/setup_14.x | sudo -E bas                                                                                                                     h -x
+ export DEBIAN_FRONTEND=noninteractive
+ DEBIAN_FRONTEND=noninteractive
+ SCRSUFFIX=_14.x
+ NODENAME='Node.js 14.x'
+ NODEREPO=node_14.x
+ NODEPKG=nodejs
+ test -t 1
++ which tput
++ tput colors
+ ncolors=8
+ test -n 8
+ test 8 -ge 8
++ tput cols
+ termcols=80
++ tput bold
+ bold=''
++ tput smul
+ underline=''
++ tput smso
+ standout=''
++ tput sgr0
+ normal=''
++ tput setaf 0
+ black=''
++ tput setaf 1
+ red=''
++ tput setaf 2
+ green=''
++ tput setaf 3
+ yellow=''
++ tput setaf 4
+ blue=''
++ tput setaf 5
+ magenta=''
++ tput setaf 6
+ cyan=''
++ tput setaf 7
+ white=''
+ setup
+ script_deprecation_warning
+ '[' X_14.x == X ']'
+ node_deprecation_warning
+ [[ XNode.js 14.x == \X\i\o\.\j\s\ \1\.\x ]]
+ [[ XNode.js 14.x == \X\i\o\.\j\s\ \2\.\x ]]
+ [[ XNode.js 14.x == \X\i\o\.\j\s\ \3\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \0\.\1\0 ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \0\.\1\2 ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \4\.\x\ \L\T\S\ \A\r\g\o\n ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \5\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \6\.\x\ \L\T\S\ \B\o\r\o\n ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \7\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \8\.\x\ \L\T\S\ \C\a\r\b\o\n ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \9\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \1\0\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \1\1\.\x ]]
+ [[ XNode.js 14.x == \X\N\o\d\e\.\j\s\ \1\3\.\x ]]
+ print_status 'Installing the NodeSource Node.js 14.x repo...'
+ echo

+ echo '## Installing the NodeSource Node.js 14.x repo...'
## Installing the NodeSource Node.js 14.x repo...
+ echo

++ uname -m
++ grep -Eq '^armv6'
+ PRE_INSTALL_PKGS=
+ '[' '!' -e /usr/lib/apt/methods/https ']'
+ '[' '!' -x /usr/bin/lsb_release ']'
+ PRE_INSTALL_PKGS=' lsb-release'
+ '[' '!' -x /usr/bin/curl ']'
+ '[' '!' -x /usr/bin/gpg ']'
+ print_status 'Populating apt-get cache...'
+ echo

+ echo '## Populating apt-get cache...'
## Populating apt-get cache...
+ echo

+ exec_cmd 'apt-get update'
+ exec_cmd_nobail 'apt-get update'
+ echo '+ apt-get update'
+ apt-get update
+ bash -c 'apt-get update'
Holen:1 http://security.debian.org buster/updates InRelease [65,4 kB]
OK:3 http://httpredir.debian.org/debian buster InRelease
Holen:4 http://httpredir.debian.org/debian buster-updates InRelease [51,9 kB]
Holen:5 http://httpredir.debian.org/debian buster-backports InRelease [46,7 kB]
Holen:2 https://mirrors.netix.net/armbian/apt buster InRelease [18,4 kB]
Holen:6 http://security.debian.org buster/updates/main armhf Packages [351 kB]
Holen:7 http://httpredir.debian.org/debian buster-backports/main armhf Packages.diff/Index [27,8 kB]
Holen:8 http://httpredir.debian.org/debian buster-backports/main armhf Packages 2021-05-11-1400.52.pdiff [677 B]
Holen:8 http://httpredir.debian.org/debian buster-backports/main armhf Packages 2021-05-11-1400.52.pdiff [677 B]
Holen:9 https://mirrors.netix.net/armbian/apt buster/main armhf Packages [867 kB]
Holen:10 https://mirrors.netix.net/armbian/apt buster/main armhf Contents (deb) [24,4 MB]
Holen:11 https://mirrors.netix.net/armbian/apt buster/buster-utils armhf Packages [73,9 kB]
Holen:12 https://mirrors.netix.net/armbian/apt buster/buster-utils armhf Contents (deb) [12,8 kB]
Holen:13 https://mirrors.netix.net/armbian/apt buster/buster-desktop armhf Packages [28,4 kB]
Es wurden 25,9 MB in 3 min 7 s geholt (139 kB/s).
Paketlisten werden gelesen... Fertig
+ '[' 'X lsb-release' '!=' X ']'
+ print_status 'Installing packages required for setup: lsb-release...'
+ echo

+ echo '## Installing packages required for setup: lsb-release...'
## Installing packages required for setup: lsb-release...
+ echo

+ exec_cmd 'apt-get install -y lsb-release > /dev/null 2>&1'
+ exec_cmd_nobail 'apt-get install -y lsb-release > /dev/null 2>&1'
+ echo '+ apt-get install -y lsb-release > /dev/null 2>&1'
+ apt-get install -y lsb-release > /dev/null 2>&1
+ bash -c 'apt-get install -y lsb-release > /dev/null 2>&1'
++ lsb_release -d
++ grep 'Ubuntu .*development'
main: Zeile 206: lsb_release: Kommando nicht gefunden.
++ echo 1
+ IS_PRERELEASE=1
+ [[ 1 -eq 0 ]]
++ lsb_release -c -s
main: Zeile 212: lsb_release: Kommando nicht gefunden.
+ DISTRO=
+ check_alt SolydXK solydxk-9 Debian stretch
+ '[' X == Xsolydxk-9 ']'
+ check_alt Kali sana Debian jessie
+ '[' X == Xsana ']'
+ check_alt Kali kali-rolling Debian bullseye
+ '[' X == Xkali-rolling ']'
+ check_alt 'Sparky Linux' Tyche Debian stretch
+ '[' X == XTyche ']'
+ check_alt 'Sparky Linux' Nibiru Debian buster
+ '[' X == XNibiru ']'
+ check_alt 'MX Linux 17' Horizon Debian stretch
+ '[' X == XHorizon ']'
+ check_alt 'MX Linux 18' Continuum Debian stretch
+ '[' X == XContinuum ']'
+ check_alt 'MX Linux 19' 'patito feo' Debian buster
+ '[' X == 'Xpatito feo' ']'
+ check_alt 'Linux Mint' maya Ubuntu precise
+ '[' X == Xmaya ']'
+ check_alt 'Linux Mint' qiana Ubuntu trusty
+ '[' X == Xqiana ']'
+ check_alt 'Linux Mint' rafaela Ubuntu trusty
+ '[' X == Xrafaela ']'
+ check_alt 'Linux Mint' rebecca Ubuntu trusty
+ '[' X == Xrebecca ']'
+ check_alt 'Linux Mint' rosa Ubuntu trusty
+ '[' X == Xrosa ']'
+ check_alt 'Linux Mint' sarah Ubuntu xenial
+ '[' X == Xsarah ']'
+ check_alt 'Linux Mint' serena Ubuntu xenial
+ '[' X == Xserena ']'
+ check_alt 'Linux Mint' sonya Ubuntu xenial
+ '[' X == Xsonya ']'
+ check_alt 'Linux Mint' sylvia Ubuntu xenial
+ '[' X == Xsylvia ']'
+ check_alt 'Linux Mint' tara Ubuntu bionic
+ '[' X == Xtara ']'
+ check_alt 'Linux Mint' tessa Ubuntu bionic
+ '[' X == Xtessa ']'
+ check_alt 'Linux Mint' tina Ubuntu bionic
+ '[' X == Xtina ']'
+ check_alt 'Linux Mint' tricia Ubuntu bionic
+ '[' X == Xtricia ']'
+ check_alt 'Linux Mint' ulyana Ubuntu focal
+ '[' X == Xulyana ']'
+ check_alt 'Linux Mint' ulyssa Ubuntu focal
+ '[' X == Xulyssa ']'
+ check_alt LMDE betsy Debian jessie
+ '[' X == Xbetsy ']'
+ check_alt LMDE cindy Debian stretch
+ '[' X == Xcindy ']'
+ check_alt LMDE debbie Debian buster
+ '[' X == Xdebbie ']'
+ check_alt elementaryOS luna Ubuntu precise
+ '[' X == Xluna ']'
+ check_alt elementaryOS freya Ubuntu trusty
+ '[' X == Xfreya ']'
+ check_alt elementaryOS loki Ubuntu xenial
+ '[' X == Xloki ']'
+ check_alt elementaryOS juno Ubuntu bionic
+ '[' X == Xjuno ']'
+ check_alt elementaryOS hera Ubuntu bionic
+ '[' X == Xhera ']'
+ check_alt elementaryOS odin Ubuntu focal
+ '[' X == Xodin ']'
+ check_alt Trisquel toutatis Ubuntu precise
+ '[' X == Xtoutatis ']'
+ check_alt Trisquel belenos Ubuntu trusty
+ '[' X == Xbelenos ']'
+ check_alt Trisquel flidas Ubuntu xenial
+ '[' X == Xflidas ']'
+ check_alt Trisquel etiona Ubuntu bionic
+ '[' X == Xetiona ']'
+ check_alt 'Uruk GNU/Linux' lugalbanda Ubuntu xenial
+ '[' X == Xlugalbanda ']'
+ check_alt BOSS anokha Debian wheezy
+ '[' X == Xanokha ']'
+ check_alt BOSS anoop Debian jessie
+ '[' X == Xanoop ']'
+ check_alt BOSS drishti Debian stretch
+ '[' X == Xdrishti ']'
+ check_alt BOSS unnati Debian buster
+ '[' X == Xunnati ']'
+ check_alt bunsenlabs bunsen-hydrogen Debian jessie
+ '[' X == Xbunsen-hydrogen ']'
+ check_alt bunsenlabs helium Debian stretch
+ '[' X == Xhelium ']'
+ check_alt bunsenlabs lithium Debian buster
+ '[' X == Xlithium ']'
+ check_alt Tanglu chromodoris Debian jessie
+ '[' X == Xchromodoris ']'
+ check_alt PureOS green Debian sid
+ '[' X == Xgreen ']'
+ check_alt PureOS amber Debian buster
+ '[' X == Xamber ']'
+ check_alt Devuan jessie Debian jessie
+ '[' X == Xjessie ']'
+ check_alt Devuan ascii Debian stretch
+ '[' X == Xascii ']'
+ check_alt Devuan beowulf Debian buster
+ '[' X == Xbeowulf ']'
+ check_alt Devuan ceres Debian sid
+ '[' X == Xceres ']'
+ check_alt Deepin panda Debian sid
+ '[' X == Xpanda ']'
+ check_alt Deepin unstable Debian sid
+ '[' X == Xunstable ']'
+ check_alt Deepin stable Debian buster
+ '[' X == Xstable ']'
+ check_alt Pardus onyedi Debian stretch
+ '[' X == Xonyedi ']'
+ check_alt 'Liquid Lemur' lemur-3 Debian stretch
+ '[' X == Xlemur-3 ']'
+ check_alt 'Astra Linux' orel Debian stretch
+ '[' X == Xorel ']'
+ check_alt Ubilinux dolcetto Debian stretch
+ '[' X == Xdolcetto ']'
+ '[' X == Xdebian ']'
+ print_status 'Confirming "" is supported...'
+ echo

+ echo '## Confirming "" is supported...'
## Confirming "" is supported...
+ echo

+ '[' -x /usr/bin/curl ']'
+ exec_cmd_nobail 'curl -sLf -o /dev/null '\''https://deb.nodesource.com/node_14.x/dists//Release'\'''
+ echo '+ curl -sLf -o /dev/null '\''https://deb.nodesource.com/node_14.x/dists//Release'\'''
+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_14.x/dists//Release'
+ bash -c 'curl -sLf -o /dev/null '\''https://deb.nodesource.com/node_14.x/dists//Release'\'''
+ RC=22
+ [[ 22 != 0 ]]
+ print_status 'Your distribution, identified as "", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues if you think this is incorrect or would like your distribution to be considered for support'
+ echo

+ echo '## Your distribution, identified as "", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues if you think this is incorrect or would like your distribution to be considered for support'
## Your distribution, identified as "", is not currently supported, please contact NodeSource at https://github.com/nodesource/distributions/issues if you think this is incorrect or would like your distribution to be considered for support
+ echo

+ exit 1

 

Link to post
Share on other sites

vor 15 Stunden schrieb Werner:

Your issue report is not a valid bug report per the Armbian bug reporting instructions (https://www.armbian.com/bugs).  With limited resources the Armbian project is only able to spend time on issues where all the requested information has been provided and for only the boards/images/software that are supported.  Your report is invalid for one or more of the following reasons (non-exhaustive list):

 

 

I'm not sure if is a error or a layer 8 problem.....

when you say its a erorr i will make a bug report 

Link to post
Share on other sites

The software you are trying to install/update is userspace and therefor out of scope from Armbian.

Support is only possible for software that Armbian ships.

 

 

On 5/11/2021 at 5:21 AM, Werner said:

it is for software that is not supported (such as userspace modules installed on top of the core operating system)

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

2 2