Making EspressoBin V7 work in 2022 ...


1 1
Go to solution Solved by fallen_aarch64,

Recommended Posts

Hi eveyone,


I am coming from a a hint off Github here: Igor was so kind and redirected me to this community.


I am struggling since beginning christmas to get my EspressoBin to latest versions out of dusty 2018 images.


EspressoBin v7 DDR4 1G 1000_800Mhz


Baseline - What did I do?

- Update U-Boot according to devel-18.12.3

- Flashed SD-Card with armbian Focal via Balena according

- Updated Boot Environment according



Problem Description

- U-Boot Loads and starts over to boot from SD-Card

- Booting from SD fails with


Marvell>> boot *** ERROR: serverip' not set
*** ERROR: serverip' not set Bad Linux ARM64 Image magic!


I would be very grateful for any hints how to get armbian booted on the EspressoBin in 2022!

Happy Holidays to all. cheers



Full Logs

U-Boot 2018.03-devel-18.12.3-gc9aa92ce70-armbian (Sep 18 2020 - 10:07:21 +0200)

Model: Marvell Armada 3720 Community Board ESPRESSOBin
CPU 1000 [MHz]
L2 800 [MHz]
TClock 200 [MHz]
DDR 800 [MHz]
Comphy chip #0:
Comphy-0: USB3 5 Gbps
Comphy-1: PEX0 2.5 Gbps
Comphy-2: SATA0 6 Gbps
SATA link 0 timeout.
AHCI 0001.0300 32 slots 1 ports 6 Gbps 0x1 impl SATA mode
flags: ncq led only pmp fbss pio slum part sxs
PCIE-0: Link up
MMC: sdhci@d0000: 0
Loading Environment from SPI Flash... SF: Detected mx25u3235f with page size 256 Bytes, erase size 64 KiB, total 4 MiB
Model: Marvell Armada 3720 Community Board ESPRESSOBin
Net: eth0: neta@30000 [PRIME]

Link to post
Share on other sites

Donate and support the project!

  • Solution

Hi Guido,


again thank you very much. Your links were for the Machiatobin which is Armada 8040 - the Espressobin is using 3720. However it gave me enough food for thought to sucessfully compile Ubuntu 14.04. LTS with it.


Just a short write up how it worked out for others and my later me:


1. Compile Kernel Image and DTB - latest supported Kernel is 4.4.8


2. Fix Errors during compilation 

/usr/bin/ld: scripts/dtc/ multiple definition of `yylloc'; scripts/dtc/dtc-lexer.lex.o:(.bss+0x0): first defined here

sed -i 's/^YYLTYPE yylloc;$/extern YYLTYPE yylloc;/' scripts/dtc/dtc-lexer.l sed -i 's/^YYLTYPE yylloc;$/extern YYLTYPE yylloc;/' scripts/dtc/dtc-lexer.lex.c


3. Prepare Ubuntu 14.04.5 LTS to boot from SDCard



Link to post
Share on other sites

Hello! I would suggest you to update U-Boot on Espressobin to modern version from year 2021 (e.g. 2021.10) and not some old version from year 2018. Also update kernel to some recent version from year 2021 (e.g. 5.10) as also kernel contains many and many fixes for Espressobin / A3720 SoC.

Link to post
Share on other sites

Look into the official ARM Trusted-Firmware documentation for Marvell platforms how to build recent version of Firmware + U-Boot for Espressobin:

(search for how to build production release of Marvell firmware image where are all commands which generatate firmware)


Also look into the U-Boot documentation there is important section Permanent ethernet MAC address for updating U-Boot:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


1 1