Jump to content
  • 0

Trouble installing intel 7260 - iwlwifi on clearfog board ( 4.4 kernel )


Valk
 Share

Question

Ok I'm stuck and need some help.

 

Trying to install an intel 7260 wifi + bt mini pcie card in my clearfog (as an access point but that's the next step). I'm using https://github.com/igorpecovnik/lib/ to build and using the dev branch (tried all 3). Installs everything ok Ethernet, 3G modem but the intel 7260 is killing me.

 

Tried installing the ucode from version 13 - 17 from:

 

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi?s%5b%5d=iwlmvm#firmware

http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/tree/?id=c883a6b6186bb2415761d287cbac773062911212

https://github.com/OpenELEC/iwlwifi-firmware/tree/master/firmware

 

Using the Gentoo wiki for a guide on how to setup the kernel: https://wiki.gentoo.org/wiki/Iwlwifi

 

Using the 3.x kernel I managed to get it to load but the 4.x keep giving me errors:

root@armada:~# dmesg | grep iwl
[    5.633998] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
[    5.715908] iwlwifi 0000:02:00.0: loaded firmware version 17.352738.0 op_mode iwlmvm
[    5.859158] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0xFFFFFFFF
[    5.862270] iwlwifi 0000:02:00.0: L1 Disabled - LTR Disabled
[    5.879634] WARNING: CPU: 0 PID: 2636 at drivers/net/wireless/iwlwifi/pcie/trans.c:1552 iwl_trans_pcie_grab_nic_access+0x10c/0x12c [iwlwifi]()
[    5.879645] Modules linked in: iwlmvm(+) mac80211 iwlwifi btusb btrtl btbcm btintel bluetooth cfg80211 rfkill firmware_class rtc_armada38x marvell_cesa mcp3021 ehci_orion des_generic hwmon evbug uio_pdrv_genirq uio mv_cesa fuse ipv6 autofs4
[    5.879800] [<c01271b0>] (warn_slowpath_fmt) from [<bf365410>] (iwl_trans_pcie_grab_nic_access+0x10c/0x12c [iwlwifi])
[    5.879892] [<bf365410>] (iwl_trans_pcie_grab_nic_access [iwlwifi]) from [<bf35767c>] (iwl_read_prph+0x34/0x78 [iwlwifi])
[    5.879957] [<bf35767c>] (iwl_read_prph [iwlwifi]) from [<bf364bbc>] (iwl_pcie_apm_init+0x224/0x2dc [iwlwifi])
[    5.880026] [<bf364bbc>] (iwl_pcie_apm_init [iwlwifi]) from [<bf368450>] (iwl_trans_pcie_start_hw+0xb4/0x164 [iwlwifi])
[    5.880115] [<bf368450>] (iwl_trans_pcie_start_hw [iwlwifi]) from [<bf497708>] (iwl_op_mode_mvm_start+0x638/0x844 [iwlmvm])
[    5.880198] [<bf497708>] (iwl_op_mode_mvm_start [iwlmvm]) from [<bf35936c>] (iwl_opmode_register+0xb8/0xd0 [iwlwifi])
[    5.880280] [<bf35936c>] (iwl_opmode_register [iwlwifi]) from [<bf4d4040>] (iwl_mvm_init+0x40/0x1000 [iwlmvm])
[    5.880334] [<bf4d4040>] (iwl_mvm_init [iwlmvm]) from [<c0101ac4>] (do_one_initcall+0x124/0x1f0)
[    6.002822] iwlwifi 0000:02:00.0: L1 Disabled - LTR Disabled
[   12.034290] iwlwifi 0000:02:00.0: Failed to load firmware chunk!
[   12.034302] iwlwifi 0000:02:00.0: Could not load the [0] uCode section
[   12.034342] iwlwifi 0000:02:00.0: Failed to start INIT ucode: -110
[   13.856728] iwlwifi 0000:02:00.0: Failed to run INIT ucode: -110
[   13.857022] iwlwifi 0000:02:00.0: L1 Disabled - LTR Disabled

That's just one of the errors I've received as I've been building all different kernels trying to solve the problem.

root@armada:~# lspci -k
00:02.0 PCI bridge: Marvell Technology Group Ltd. Device 6828 (rev 04)
00:03.0 PCI bridge: Marvell Technology Group Ltd. Device 6828 (rev 04)
02:00.0 Network controller: Intel Corporation Wireless 7260 (rev bb)
        Subsystem: Intel Corporation Dual Band Wireless-AC 7260
        Kernel driver in use: iwlwifi

Any help would be greatly appreciated (or even a recommendation on an alternate mini pci-e wifi card to use as an access point).

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

DEV branch (as the name indicates) is most problematic and is to avoid. NEXT branch is better but fibre support is not operational. Wireless should work fine here but in both 4.x cases, those are not matured kernels and things can go wrong.

Link to comment
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...