Jump to content

Restoring Orange PI 3 LTS 2GB/8GB EMMC boot partition

Recommended Posts

Hi there, firstly I selected "Orangepi PC" from the Board dropdown since Orange PI 3 wasn't present (although you have Orange PI 3 images so I assume it's supported ... )

I have wound up with an unbootable board,  even though it was initially bootable.


I am connecting with an ethernet cable/eth0 and powered via USB using a power brick/charging cable for a Google Pixel. I don't think this is a power issue, because everything was going well, and was stable for quite some time (hours).


I was connected initially "headlessly" and later connected an HDMI cable when it failed to reboot (details below).


I have tried each of the images listed below with 2 different SanDisk Extreme Pro SD Cards, and have tested both cards booting Armbian_22.02.1_Orangepione_bullseye_current_5.15.25.img successfully in an OPI One board.


All images burned using Etcher.


Here's what happened:


1) I installed this Debian image for Orange PI 3 from the Orange PI website:



2) I went through the setup steps for my application. The most "controversial" of these steps are to disable predictable device names by adding this to /boot/orangepiEnv.txt:

extraargs=net.ifnames=0, and to add a reverse port forward using autossh into systemctl, everything else is just installing various software packages using apt


3) Nothing was behaving funnily, it was all stable at this point. Total elapsed time was 2 - 3 hours with no issues, crashes, random reboots or network problems.


4) During my setup steps, I need to reboot, I did so and the network did not come back up. I connected a monitor and saw it was starting the boot process but failing when adding the console on tty0


5) I thought maybe something to do with the extraargs was causing a problem so I disconnected the ethernet cable from eth0


6) The system failed to boot a couple of more times, and then successfully booted. I tested this multiple times. The system would never boot with ethernet connected, but would boot after a few failed tries with ethernet disconnected, it definitely wasn't a coincidence.


7) I logged in and then connected the ethernet cable. The system didn't crash or anything. I figured maybe updating would sort something out, so I started the upgrade to bullseye


8) At some point during the upgrade process, the system crashed and rebooted.


9) After this point, the system wouldn't successfully boot with or without ethernet disconnected. It would always restart at the same point of connecting the console on tty0


10) At this point I removed the SD card, and powered on the device, it successfully booted into whatever Android is shipped with the EMMC.


11) I also inserted the SD card into a linux VM and noticed that there was no boot partition. I thought that maybe the boot partition for Orange PI 3 is located on the EMMC


12) So I went looking for some instructions to push an install to EMMC, which is when I found the Armbian forums


13) I flashed this Armbian image:



14) When I inserted the SD card and attempted to boot, I now saw the message "Running /scripts/local-block... done" over and over until it eventually gave up trying to find the root file system


15) I searched this error and found instructions for mounting the SD card partition and ensuring that the UUID is correct in armbianEnv.txt:

It was already correct


16) I then discovered that the Android version shipped in the EMMC no longer boots, it just hangs at the Orange PI logo


17) I then tried this Orange PI debian image which has an older kernel:




When I boot using this image on an SD card, I see an Orange PI logo with "Initialising boot loader" but it never gets past that


So the current situation is:


Orangepi3-lts_2.1.6_debian_buster_server_linux4.9.118: boots to a pi logo with "Initializing boot loader"

Orangepi3-lts_2.1.6_debian_buster_server_linux5.10.75: starts booting but then gives up waiting for root file system after "Running /scripts/local-block" repeatedly

Armbian_22.02.1_Orangepi3_bullseye_current_5.15.25.img: starts booting but then gives up waiting for root file system after "Running /scripts/local-block" repeatedly

Booting with no SD card inserted shows an Orange PI logo on the screen with no writing forever


So it seems that the SD card reader definitely works since the behaviour changes depending on which image I insert, and it seems that somehow something I did "broke" the EMMC boot partition, and that even when I'm booting from the SD card, it's still using the EMMC somehow.


NOW ... I dug around for some way to "reset" the EMMC and found out there is a thing called "PhoenixCard" that lets you burn Android images in "Product" mode that allegedly copy themselves automatically to EMMC when you turn the machine on, which I found in the OPI 3 User Manual.


I am downloading a Windows 10 iso for use with VirtualBox so I can run PhoenixCard from my Mac to do so, but since it's a 5.5GB download and that's going to take a couple of hours I thought I'd write out the situation here to see if whether or not anyone has a better idea and/or I'm barking up entirely the wrong tree or something else.



Board: Orangepi PC
Link to comment
Share on other sites

Search Before Posting!

Okay shockingly I actually managed to get PhoenixCard to burn a "Product" Android Image to an SD card, and inserted it into the board. I saw the progress bar go across the screen and it said "CARD OK", but this doesn't appear to have fixed whatever the "boot partition" is on the EMMC :(


I'm awaiting moderator approval to join the Orange Pi forums as this seems more like an OPI question than an Armbian question, but if anyone has any pointers or experience in "repairing" the boot partition on OPI 3 LTS I'd really appreciate any help you're able to provide!


Thanks again.

Link to comment
Share on other sites

Welp, as embarrasing as it is for me to admit this, it was a power problem. I got a different charging brick and cable on a whim to try it out and it all runs fine. So I'll post this here for posterity, even though I'm sure you've probably posted it may times before: try multiple power chords and power bricks if you're using the USB-C port for powering your OPI 3 LTS (and probably other boards)!

Link to comment
Share on other sites

On 3/7/2022 at 12:34 PM, Iain Dooley said:


wrong image. OPi3 and OPi3LTS are different boards. OPi3 images won't work.

LTS is not supported (yet).


Blame the vendor for the confusing naming scheme.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...