Jump to content
  • 0

Not starting after update to 5.20


Guest
 Share

Question

Hello,

 

I have an Orange Pi+ 2 and Orange Pi+ 2e. I use Armbian, updated to 5.20 with these commands:

 

sudo apt-get update
sudo apt-get upgrade

 

so

 

I rebooted and can't start.

 

What can I do? 

 

Thanks

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

Help Armbian team helping you

  • 0

I had the same sort of problem. I have an Orangepi-pc-plus. I did the upgrade and then found it didn't complete the reboot. I connected a serial cable and watched the boot process.  Here's a scrap showing the problem:

...

  Verifying Checksum ... OK
ERROR: Did not find a cmdline Flattened Device Tree
Could not find a valid device tree
SCRIPT FAILED: continuing...
switch to partitions #0, OK
mmc1(part 0) is current device
Scanning mmc 1:1...
Found U-Boot script /boot/boot.scr
2444 bytes read in 173 ms (13.7 KiB/s)
## Executing script at 43100000
gpio: pin PL10 (gpio 298) value is 1
gpio: pin PG11 (gpio 203) value is 1
** File not found /boot/.verbose **
0 bytes read in 137 ms (0 Bytes/s)
** File not found /boot/dtb/sun8i-h3-orangepi-pc-plus.dtb **
** Unrecognized filesystem type **
** File not found /dtb/sun8i-h3-orangepi-pc-plus.dtb **
4012265 bytes read in 410 ms (9.3 MiB/s)
5791992 bytes read in 595 ms (9.3 MiB/s)
## Loading init Ramdisk from Legacy Image at 42000000 ...
   Image Name:   uInitrd

......

 

 

So it looks like in my case the .dtb for that particular board was missing.

I know that the board is very similar to the OrangepiPC  I just copied the /boot/dtb/sun8i-h3-orangepi-pc.dtb to /boot/dtb/sun8i-h3-orangepi-pc-plus.dtb and tried again. This time it booted without problems.

 

Hope this is helpful.
 

Link to comment
Share on other sites

  • 0

I think I found why ...

The commit https://github.com/igorpecovnik/lib/commit/195de287f2fe68baf510ce77b28b4a129aa4d24e now using a more specific names for "fdtfile" but those DTS files don't exist yet in Mainline tree.

As you said, the workaround for now is to copy sun8i-h3-orangepi-pc.dtb into sun8i-h3-orangepi-pc-plus.dtb new file, the same is true with other flavors such "lite" and "plus2e".

Link to comment
Share on other sites

  • 0

Any idea when the 'sudo apt-get upgrade' will be working again?

 

And a big shout-out for all that martinayotte, tkaiser, and other "gurus" do for the benefit of the community.  This world would be Utopia if we all supported each other by contributing like you guys do.  KUDOS^10.  We are all very appreciative of your time, effort, and generosity.

Link to comment
Share on other sites

  • 0

Hello there,

 

New user. Just started getting into those little Computer thingy`s. It seems like im having the same problem. my OP1 is not booting following a apt-get upgrade. I have tried my best deciphering what you have writting for the past 2 hours but i must honestly say, it goes WAAAAAY over my head.

 

I tried to look for the *.dtb files and such but could not find any in /boot/

 

I dont have a Serial interface aswell.

 

Can someone walk me through it? i would hate to have start from scratch.

Link to comment
Share on other sites

  • 0

I was running into the "upgrade" problems with a Orange Pi Lite.  After the upgrade (with error) I could no longer boot the device and would have to start all over again with a fresh SDCard image.  I figured that I could just skip the upgrade but the 'O' in OCD stands for "Obsessive", right?!!!

 

Figured out how to get the /boot/dtb/ directory with the files that were mentioned above:

sudo apt-get install linux-dtb-dev-sunxi

 

Couldn't recall the exact name of the file that it wasn't finding (.dtb) during the "upgrade" process but decided to copy over one that was there and give it "orangepi-lite" as a good guess (needed to?):

sudo cp /boot/dtb/sun8i-h3-orangepi-one.dtb /boot/dtb/sun8i-h3-orangepi-lite.dtb

 

Had already done the sudo apt-get update... so I did the sudo apt-get upgrade and still got an error (unhappy "sigh"):

Unpacking armbian-tools-jessie (5.20) over (5.14) ...

dpkg: error processing archive /var/cache/apt/archives/armbian-tools-jessie_5.20_armhf.deb (--unpack):
 trying to overwrite '/etc/init.d/brcm40183-patch', which is also in package linux-jessie-root-orangepilite 5.14
Preparing to unpack .../automake_1%3a1.14.1-4+deb8u1_all.deb ...
.
.
.
Processing triggers for dbus (1.8.20-0+deb8u1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/armbian-tools-jessie_5.20_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
So I decided to run sudo apt-get upgrade again.  This time it said that there was little to do... and after telling it 'Y' to go ahead, it did so this time without errors. ! :)
 
The following package was automatically installed and is no longer required:
  libnl-route-3-200
The following packages will be upgraded:
  armbian-tools-jessie
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
25 not fully installed or removed.
 
I crossed my fingers (most important step), and did a sudo reboot now.  Hey, it worked!   :D  And after the successful reboot, trying a third sudo apt-get upgrade resulted with "0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded".
 
I hope that this helps others until this is fixed.  If nothing else I learned a lot pulling my hairs out, one by one, in the process.  If I boneheaded some detail, please let me know.  Not sure that I needed to copy the file over with the new name ("-lite").  -p'daddy
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...