Jump to content
  • 0

How to get audio in Gnome for Station M2?


Jeremiah Cornelius
 Share

Question

I get no audio devices in Gnome/Jammy userland on an Armbian 5.18 kernel. From the console, alsamixer has controls for Analog RK809, but no Playback Mux for the speaker (mini jack) and changing the card Default to HDMI reports "This Sound Device Does Not Have Any Controls".

 

The Gnome/Ubuntu audio applet has only a dummy device.

 

Thanks!

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

Check forum guidelines to use maximum potential!

  • 0
10 hours ago, balbes150 said:

It is not supported, so no one checks this environment

I solved this, for anyone experiencing the same. Simple answer is to apt uninstall pipewire-media-session, and allow apt dependencies to replace this automatically with wireplumber.

Gnome Remote Desktop requires pipewire-media-session, but the software is inferior to wireplumber, especially when jackd is present. In any case, Remote Desktop functions remain in the Sharing options under Settings, and the "Legacy VNC Protocol" was tested with Wayland as the Gnome display server, and still works very well.

 

Some of the problems may have arisen with pipewire-media-session and legacy configuration after do-release-upgrade, but switching to wireplumber is a better overall idea, and even endorsed by the pipewire-media-session developer.

Switching audio output to HDMI was now a secondary issue, solved by the Gnome extension Sound Input and Sound Output Device Chooser. The labels for HDMI vs mini-jack are ambiguous, and could probably be fixed by fiddling with asound.conf, but the setup works and I'm not interested in potentially breaking things ahgain, by changing ALSA card order and labels, etc.

I hope this helps others to get a working configuration on Station M2 with the latest Ubuntu LTS.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...