0
aberean

How-to install Asterisk/FreePBX or Elastix Server on Armbian OPiPC+ ?

Recommended Posts

Looking for help on how to install either freepbx or elastix on the OPiPC+ running latest Armbian desktop jessie. I was pointed an article awhile back but it did not work and I am by no means an expert! Any and all help is welcome.

 

Thanks

Share this post


Link to post
Share on other sites
http://forum.armbian.com/index.php/topic/1867-recommendations-please-for-a-noob-opipc-and-asterisk-wgui/ Igor

Administrator

  • photo-1.jpg?_r=1432365025
  • Administrators
  • admin.png
  • 2441 posts

Posted 19 August 2016 - 09:33 PM

Our desktop is already lightweight as possible. There are only few applications, which you might not need: 

libreoffice-writer thunderbird icedove

Uninstall them if you thing it's urgent to do so.

 

I never built Asterix but since Armbian desktop is Debian based, I would check guides like this:

 

https://www.howtofor...risk-on-debian/

 

 

 

Haha, it was you who gave me the article. it seems i cant access it anymore (BEWARE, accessing it now may bring a virus warning page) but in following the steps, I only got a few steps in. basically to the prereqs. I could not get past them as I could not install them all. I am thinking the page was outdated and may not have the best install options now.

Share this post


Link to post
Share on other sites

 

This seems very similar to the article that Igor had pointed me to, for some reason I could not install the prereqs. Just to give a better understanding, I have an OPiPC+ using the latest Armbian. It was a few months ago, but I believe I installed Armbian Server for this. I do not know if that is debian or Ubuntu, I believe it is debian, but i dont think it is 8.1 which is where i beleive the problem may be. 

 

I understand my level of knowledge seems like I am biting of much more than I should, but I am determined, and if I can find some good information to help me understand than I CAN get this figured out. I just need some help to get me started in the right direction and hints along the way.

 

Thanks.

Share this post


Link to post
Share on other sites

Haha, it was you who gave me the article. it seems i cant access it anymore (BEWARE, accessing it now may bring a virus warning page) but in following the steps, I only got a few steps in. basically to the prereqs. I could not get past them as I could not install them all. I am thinking the page was outdated and may not have the best install options now.

Looking at prerequisites, "linux-headers-`uname -r`" will definitely cause an installation error, so you need to remove this package from the list. Other than that, please provide exact steps that you tried and exact error messages that you got, since your task is very specific and it is highly unlikely that someone here can provide a solution to a problem without describing the problem itself.

Share this post


Link to post
Share on other sites

Looking at prerequisites, "linux-headers-`uname -r`" will definitely cause an installation error, so you need to remove this package from the list. Other than that, please provide exact steps that you tried and exact error messages that you got, since your task is very specific and it is highly unlikely that someone here can provide a solution to a problem without describing the problem itself.

Great, That's a good start, I will try this later this evening and post the results after. Thanks. I remember this now as being one of the problems!

Share this post


Link to post
Share on other sites

Is it a MUST to use debian server or can I use the desktop version as I would like to enable remote desktop so I dont have to leave it plugged into a monitor or anything?

Share this post


Link to post
Share on other sites

So I have have some major happenings this week such as my home has had partial power for the last several days. Doesnt look like it will get better for a while yet! But decided to play around with this last night despite the power! ok, I had downloaded Armbian several months ago and installed it (Working) several times, gone through the update/upgrade process, installed rpimonitor and tightvncserver. but last night I did all of this and none of these worked, well, the update/upgrade worked but I am not able to log in via vnc and I am not able to reach the rpi monitor page. I am thinking the latest upgrades have changed some things as I have noticed others having issues mentioned in the forum as well. Is there something I am missing. Or do I need to put this on hold till these bugs get worked out?

Share this post


Link to post
Share on other sites
10 hours ago, twinclouds said:

Is the linux-headers package available so I can get somewhare?

 

You can install headers from armbian-config menu -> software -> install headers 

 

Since you haven't provide logs (armbianmonitor -u) I am not sure this will works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0