Jump to content

X96mini,S905w Stuck on boot time.


Recommended Posts

I'm using,

TV Box Name: X96 mini

CPU (example: amlogic s905w): amlogic s905w

Armbian build file name: Armbian_20.10_Arm-64_focal_current_5.9.0_desktop.img.xz

DTB file used: meson-gxl-s905w-gxl-s905w-p281.dtb


During the boot time stacked(freeze) the screen.


Link to comment
Share on other sites

Dear Stee man,


I'm tried those links with updated image file, but still the problem occurred.

last 2 lines are

Memory Limit : none

[end Kernel panic - not syncing : Asynchronous SError Interrupt ]---


*I'm using device have no boot button. So chose the "aml_autoscript" update method.

Edited by Nandhu
added Mentioned the replay
Link to comment
Share on other sites

On 3/17/2023 at 7:42 AM, Nandhu said:


Your first post says you are using the p281 dtb (which is what I use), but the screen shots show you are using the tx3-mini dtb.  You need to fix your extlinux.conf

Link to comment
Share on other sites

Can you include pictures of the top and bottom of your box and then open the case and take pictures of the top and bottom of the board (with good enough resolution to see the markings on the board as well as on the chips).  My boxes work fine, so I want to see if your box as different hardware.  TV box manufacturers often make hardware changes but still call it by the same name.

Link to comment
Share on other sites

@Nandhu I followed the already known steps that you did earlier, the difference was the image I used, which I found in this link here: https://loksado.com/2020/02/download-armbian-linux-untuk-hg680p-dan-b860h-amlogic-s905-p212/ (I hope it doesn't cause problems to post this link), I used some versions, and for my case the one that worked was "5.91", I used the dtb referring to my TV Box (meson-gxl-s905w-tx3-mini.dtb) and using the versions with and without interface and both worked, at first I tested it on the SD Card, when I saw that it was everything went well, I ran "install.sh" which ran smoothly, and now I'm running my Armbian smoothly.


I hope this helps you and others who have had the same problem as me.

Link to comment
Share on other sites

@andersonpersan Could you do some tests for me?  Since I can't reproduce the problem (the newest images work on my s905x boxes, including multiple TX3 mini's and X96 mini's), i'm not able to solve the problem.

Since you have found that an older build is working for you, I would request that you try a couple of things to see we can figure out what isn't working in your case for the latest builds.

Since you have already installed to emmc, the first test I would ask is to now try to boot a new build from an sd card with the old build in emmc. (The boot logic should boot from SD card first, before emmc)

Link to comment
Share on other sites

Hello @SteeMan, when I managed to run and install the previous version, I was excited and believed that I could run a current version, because I thought I had "unlocked" something in the hardware, but it was not possible to run through the SD Card. I could record a video to show the steps I followed, but I speak Brazilian Portuguese and I don't speak English (I translate the texts via Google Translate), you wouldn't understand me. But basically what I did was trial and error, I tried the "Focal" and "Bullseye" versions, and 6 months ago I talked to you (TX3 Mini without reset button does not boot), and you suggested me to test all available dtb's and that's what I did, were almost 50 attempts on each of these versions, and the common errors I had were: "kernel panic - not syncing: asynchronous serror interrupt armbian", "memory limit none" and finally there was a moment when I managed to access a console, but without success to advance appeared "(initramfs)".


So searching here on the forum I saw this link and decided to try, and by "luck" I managed to run it on my first attempt with an interface, I even installed it on my eMMC, but I needed to install Open Media Vault and I discovered that it does not run on Linux with an interface , so I decided to run it with the same version without interface and once again I managed to install it in eMMC, and now I'm running it without many problems, I have an Open Media Vault installed, an external HD connected and I also installed and configured Emby ( this one I'm still trying to find the best setting, as it crashes with some movies when transcoding because of the modest hardware).


If you have other tests I can run, I'd be happy to help.





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines