Jump to content

Problem with booting BananaPi Pro

Go to solution Solved by Igor,

Recommended Posts

For a long time, for more than three years, I did not use my BananapiPro board. And recently I decided to launch it again.I downloaded new Armbian image distribution. But the system when loading gives out an error. After the initialization of the devices, a message appears:

Device 0: unknown device
ethernet@1c50000 Waiting for PHY auto negotiation to complete......... done
Speed: 100, full duplex
BOOTP broadcast 1
DHCP client bound to address (5ms)
*** Warning: no boot file name: using 'COA802c8.img'
Using ethernet@1c50000 device
TFTP from server; our IP address is
Filename 'COA802C8.img'.
Load address: 0x42000000
Loading: T T T T T T T
Retry count exceeded; strarting again
missing enviroment variable: pxeuuid
Retrieving file: pxelinux.cfg/01-02-89-0b-41-bb-9e
Speed 100, fulduplex



which is postponed and the loading does not happen.

I tried to record the image with different programs and dd from console. Also I use three different sd cards. I also tried the old images from the archive, but the situation is repeated. And the old images from 2019 have not been found.

Does that mean that new images are not supported by my board? Did it be broken?



Link to comment
Share on other sites

  • Solution
2 hours ago, olex0 said:

Does that mean that new images are not supported by my board? Did it be broken?


We are aware software support for Allwinner is slowly but surely collapsing, so this is the plan https://armbian.atlassian.net/browse/AR-1502 There is no support from any side, not from users, not from industry, budget is negative and we already lost lets say hundred hours for preparation and meetings, without counting the work on the code that is already in motion. Just to improve this section. We also purchased some additional devices so we can monitor upgrades better ... To save time answering this question.


If you build image from sources, it will work. I just did it earlier today: https://paste.armbian.com/amufuxisen 

Link to comment
Share on other sites


MMC: no card present


Probably it is a problem in uboot, it cannot detect any SD-Cards. Thats why uboot is searching for a TFTP server to boot from there. You can set up a TFTP Server and check if you can at least boot the kernel and see if your SD-Card is detected in the kernel.


Link to comment
Share on other sites

I just tested Armbian_23.11.1_Bananapipro_bookworm_current_6.1.63.img:


dd bs=8M if=Armbian_23.11.1_Bananapipro_bookworm_current_6.1.63.img of=/dev/sdc


Boots without any problems, opening ssh gives me:


Welcome to Armbian! 

Documentation: https://docs.armbian.com | Community support: https://forum.armbian.com

IP address:

Create root password: *********
Repeat root password: *********

Support status: community support (looking for a dedicated maintainer)

Choose default system command shell:

1) bash
2) zsh

Shell: BASH

Creating a new user account. Press <Ctrl-C> to abort


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines