Jump to content

Unable to upgrade armbian-bsp-cli-odroidhc4-current


Recommended Posts

After last system upgrade I got,

Package armbian-bsp-cli-odroidhc4-current is kept back because a related package is kept back or due to local apt_preferences(5).


and (translate from french)

sudo apt install --only-upgrade armbian-bsp-cli-odroidhc4-current


The following packages contain unmet dependencies:
armbian-bsp-cli-odroidhc4-current : Dépend: base-files (>= 23.11.1)
E: Unable to fix problems, bad packets are in "keep as is" mode.


How to fix this issue?


uname -a
Linux xxxxx.xx 6.1.63-current-meson64 #1 SMP PREEMPT Mon Nov 20 10:52:19 UTC 2023 aarch64 GNU/Linux


apt-cache show base-files
Package: base-files
Essential: yes
Priority: required
Section: admin
Installed-Size: 271
Maintainer: Armbian Linux <info@armbian.com>
Architecture: arm64
Version: 23.8.1-bullseye
Replaces: base, dpkg (<= 1.15.0), miscutils


Package: base-files
Version: 11.1+deb11u8


Link to comment
Share on other sites

Radxa Rock Pi 4b and Banana Pi M2 Zero are running Debian 11.7. Failed to install armbian-bsp-cli-rockpi-4b-current and armbian-bsp-cli-bananapim2zero-current due to "Depends on: base files (>= 23.11.1)". USB drives are gone. Looks like Armbian maintainers screwed up. I apologize if I am wrong.

Edited by ayarovy
addding important
Link to comment
Share on other sites

Easiest way to resolve would be to upgrade to bookworm. If there is no special reason for you to be using bullseye, just upgrade to bookworm. You can find the instructions for the same in the documentation.


We did posted in the announcement section a couple of days ago that we are facing technical issues due to which some images and packages are not getting synced. And as mentioned in the announcement we are working on it. Please be patient. Everything will be resolved momentarily. Still I will raise the topic in our weekly meeting to see if this was intentional (e.g. ending support for bulleye ?) or just a glitch. In the later case it will be resolved soon.

Link to comment
Share on other sites

On 12/2/2023 at 8:53 AM, flatterrich said:

The following packages have unmet dependencies: armbian-bsp-cli-odroidn2-current: Depends on: base-files (>= 23.11.1) E: Unable to fix issues, you have held back broken packages.

Try to purge bsp package and install latest from repository.

Link to comment
Share on other sites

3 hours ago, flatterrich said:

unfortunately OMV still needs bullseye

We can't provide all variants but as we keep build framework in decent state, you can build it at any moment. If hardware features still work well, that is another story - hardware does not have official Armbian maintainer anymore. Hardkernel should take care of this, but they does this job not very well. They never see value in our work even we tried to maintain their software stack for them, their users and our competitors.


I tried to automate OMV image making, but got overwhelmed with more important and critical problems - we are seriously understaff. If someone, that is not already helping on the project, takes this, invest his time and move forward, it would help many.


@houdini_69 I am thankful for every support we get!



Donations are emotional trigger at best. End user financial support via donations never went over 0.5% of our costs - to paraphrase: its like covering 2 out of 365 days and expecting to have service with rights to complain 24/7 for a whole year ... Which means we still do more or less everything for free. Maintaining this fairly complex software stack costs us a lot more most people can imagine - i am tired to explain this as nobody really cares. All we have to care is to not burn out which is again hard when reward is not proportional. Also there is always another and another problem and keeping users happy is impossible. And unhappy user don't donate.

This is a lot more valuable. I know what we need, but can only count on
volunteers. Which in 90% aim at funny jobs avoiding hard and unpleasant tasks. That we need to hire, which is not possible ...



Link to comment
Share on other sites

vor 2 Stunden schrieb Igor:

Try to purge bsp package and install latest from repository.

Does that make sense if there are no base-files in the repository?
I highly appreciate your work 💗, but unfortunately I'm someone who has no real idea and at 69 years old that won't work anymore 😩

Edited by flatterrich
Link to comment
Share on other sites

5 minutes ago, flatterrich said:

Does that make sense if there are no base files in the repo?


sudo apt update
sudo apt purge armbian-bsp-cli-odroidn2-current
sudo apt install armbian-bsp-cli-odroidn2-current


Should not make things worse. If it will uninstall base-files, re-install them too.


But yes I am guessing here a bit as I am just remembering that we discussed this problem once and I think we have fixed it. Files exists:


6 minutes ago, flatterrich said:

I highly appreciate your work 💗, but unfortunately I'm someone who has no real idea and at 69 years old that won't work anymore


Thank you! No worries.

Link to comment
Share on other sites

@IgorI think the problem is caused by the way the packages are published. I think we ran the build for bookworm and jammy, but when publishing we updated the Package list of bullseye as well. Thats how bullseye is now getting armbian-bsp-cli package for 23.11 version. As build was not run for bullseye, the bullseye specific base-files package didn't got updated. I think we need to modify our repo updating job to also take account of what distributions to be updated, instead of updating all of the distributions. That should fix these kind of upgrade issues when we drop support for older OS. Lets disccuss this further in today's meeting 

Link to comment
Share on other sites

I got a warning when doing apt update (translation from french),


Armbian live patch apt
gpg: key block resource “/usr/share/keyrings/armbian.gpg”: No such file or folder


Seems that armbian.gpg was removed during the update. Is it possible to add it again?

cf. https://github.com/armbian/config

    sudo wget https://apt.armbian.com/armbian.key -O key
    sudo gpg --dearmor < key | sudo tee /usr/share/keyrings/armbian.gpg > /dev/null
    sudo chmod go+r /usr/share/keyrings/armbian.gpg
    sudo echo "deb [arch=$(dpkg --print-architecture) signed-by=/usr/share/keyrings/armbian.gpg] http://apt.armbian.com $(lsb_release -cs) main  $(lsb_release -cs)-utils  $(lsb_release -cs)-desktop" | sudo tee /etc/apt/sources.list.d/armbian.list
    apt update



Edited by houdini_69
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines