[OPI PC] Bootloop after upgrade to 5.25


2 2

Recommended Posts

Hi all,


my orange pi pc ran into a bootloop after upgrading to 5.25...


Here is the output of apt-get upgrade (1 package has been kept back, I don't know why):

andy@orangepipc:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
The following packages will be upgraded:
  armbian-firmware armbian-tools-jessie hostapd libgd3 linux-headers-sun8i linux-image-sun8i
  linux-u-boot-orangepipc-default sunxi-tools
8 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 20.7 MB of archives.
After this operation, 3,171 kB of additional disk space will be used.

After performing the upgrade the orange is stuck in a bootloop...

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

Can you provide log of the boot loop from the serial console? I tested at least 2 different upgrade scenarios (jessie 5.20 and xenial 5.24) and they worked fine.


Here is the output of apt-get upgrade (1 package has been kept back, I don't know why):

Board support package can be upgraded using "apt-get dist-upgrade", but it's not essential.

Link to post
Share on other sites

I'm sorry but I have a backup running now because I need my server for different services atm, but I will try again tomorrow or tuesday and can provide log then. Can you tell me how to grab a log? I'm not familiar with that.


I upgraded from jessie 5.23 if that scenario can be tested, too.

andy@orangepipc:~$ sudo dpkg-query -W -f='${Version}\n' linux-jessie-root-orangepipc
[sudo] password for andy:


Link to post
Share on other sites

Hello, this might be related or not, but I'm not quite sure as I am not able to access the device in question to retrieve any logs. My Orange Pi PC appears to have vanished completely from the network after I upgraded it (apt-get update;apt-get upgrade;apt-get dist-upgrade) and rebooted the device. I have other machines on the network, and after running an nmap I can see that it hasn't connected after several minutes. This leads me to conclude that something happened to it, but I can't quite confirm what since I am not able to access the device in months doing some work abroad.


I can, however, see the process itself which contains some suspicious warnings:






It's a pity really, I guess it's stuck in a bootloop right now. Nonetheless it's my mistake and nothing I can do about it. I'll see if I can make some calls and have somebody go unplug the device since it would be dumb to have it reboot for months without doing anything useful.

Link to post
Share on other sites

I have same issue, but without bootloop

here is u-boot log


U-Boot SPL 2017.01-armbian (Feb 02 2017 - 03:02:37)
DRAM: 1024 MiB
Trying to boot from MMC1

U-Boot 2017.01-armbian (Feb 02 2017 - 03:02:37 +0100) Allwinner Technology

CPU: Allwinner H3 (SUN8I 1680)
Model: Xunlong Orange Pi PC
I2C: ready
*** Warning - bad CRC, using default environment

In: serial
Out: serial
Err: serial
Net: phy interface0
eth0: ethernet@1c30000
Hit any key to stop autoboot: 0
6944 bytes read in 155 ms (43 KiB/s)
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
2347 bytes read in 184 ms (11.7 KiB/s)
## Executing script at 43100000
gpio: pin PL10 (gpio 298) value is 1
gpio: pin PG11 (gpio 203) value is 1
0 bytes read in 124 ms (0 Bytes/s)
** File not found /boot/.next **
** Unrecognized filesystem type **
** File not found .next **
16 bytes read in 99 ms (0 Bytes/s)
3812289 bytes read in 480 ms (7.6 MiB/s)
4754648 bytes read in 594 ms (7.6 MiB/s)
## Loading init Ramdisk from Legacy Image at 42000000 ...
Image Name: uInitrd
Image Type: ARM Linux RAMDisk Image (gzip compressed)
Data Size: 3812225 Bytes = 3.6 MiB
Load Address: 00000000
Entry Point: 00000000
Verifying Checksum ... OK
Using machid 0x1029 from environment

Starting kernel ...

[sun8i_fixup]: From boot, get meminfo:
Start: 0x40000000
Size: 1024MB
ion_carveout reserve: 160m@0 256m@0 130m@1 200m@1
ion_reserve_select: ion chipid [0x2c00081!


Link to post
Share on other sites

I'm not sure but i think i also ran into this problem on PC+. I started new system with fresh 5.25 jessie 3.4.113 image. I wasn't able to connect trough SSH after first reboot. After few power-resets it started, and then again, one reboot and no connection. I am running webserver with it right now and i'm afraid to make a reboot, its running constantly from the very first start. 5.20 image with all later updates was starting good each time. Its the 5.25 image.




One more thing. Maybe its not really a bootloop but ethernet problem. I have power button set to run shutdown command. If i remember correctly, when it started without any connectivity, power button still worked, i got green led heartbeat after pressing it. So maybe it starts, but wont connect to the router. Its not the "new MAC each start bug", its was not visible in router clients list at all. No such problems before 5.25.

Link to post
Share on other sites

This topic is now closed to further replies.

2 2