2 2
Bpro-User

LeMaker Banana-Pi-Pro not recognized & WiFi

Recommended Posts

Hi,

 

Thanks for the excellent distribution

 

I noticed that in the hardwareinfo script there is no bananapipro result and when I boot new vanilla 4.5 Kernel the

banana.dtb file is used instead of the bananapro.dtb

 

As a result, no wifi, see also last two replies here for similar issue with M1:

http://forum.armbian.com/index.php/topic/340-banana-pi-m1plus-no-wifi/?p=2138

 

 

Dirty Solution: hardcode loading bananapipro.dtb in boot.cmd.

 

Wifi works :)

 

This is result of  "cat /proc/cpuinfo"

processor       : 0
model name      : ARMv7 Processor rev 4 (v7l)
BogoMIPS        : 27.78
Features        : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xc07
CPU revision    : 4
 
processor       : 1
model name      : ARMv7 Processor rev 4 (v7l)
BogoMIPS        : 27.78
Features        : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xc07
CPU revision    : 4
 
Hardware        : Allwinner sun7i (A20) Family
Revision        : 0000
Serial          : 1651660e0881bb28

 

 

Share this post


Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

Hi,

 

I installed system on new Banana Pro today and I can only confirm this issue. I installed latest image with 3.4.XXX kernel and upgrade all packages to latest versions kernel included but it did not help. Wifi do not works (known issue with 4.5 image).

 

I do not need help I only confirm this issue ;-).

Share this post


Link to post
Share on other sites

Hi to all of U!

 

Igor, I've the same situation! I'm not a linux guru, but this thing drive me crazy, so please consider in the next release the patch for the wifi. We need it!

 

Thank you for your efforts

Share this post


Link to post
Share on other sites

I need very detail information, since I don't have Banana PRO ... based on theory / quick checking it should work :) I have a very similar board (Cubietruck), which is working fine.

 

Support for this chip is build into all kernels.

Share this post


Link to post
Share on other sites

Wifi is working now...

 

I used following commands on my BananaPro board with legacy kernel and Ubuntu Trusty:
( Download link of used system image http://mirror.igorpecovnik.com/Armbian_4.5_Bananapi_Ubuntu_trusty_3.4.109_desktop.zip.
Note: If this link should be different for BananaPi and for BananaPro it is not my fault :-) )

 

# based on previous posts I decided return back old kernel version 3.4.109 for bananapi because wifi driver is not working on latest kernel supplied with system image
apt-get purge linux-firmware-image-sun7i -y
rm /etc/modules -Rv # apt-get cannot remove this folder during uninstall procedure # removed 20.1.

rm /lib/firmware -Rv # apt-get cannot remove this folder during uninstall procedure # added 20.1.
aptitude install linux-image-banana linux-headers-banana linux-firmware-image-banana linux-u-boot-bananapi -y

 

rm -v /boot/script.bin
ln -vs /boot/bin/bananapipro.bin /boot/script.bin

 

echo ap6210 >> /etc/modules && cat /etc/modules

 

# generate encrypted wifi password and copy output to clipboard
wpa_passphrase yourSSID yourpassword

# edit /etc/network/interfaces
# remove "#" symbol like you can see in example below
# replace "yourSSID" and "yourpassword" with your wifi SSID and ecrypted password
nano /etc/network/interfaces

 

EXAMPLE:
# Wired adapter #1
auto eth0
        iface eth0 inet dhcp
#       hwaddress ether # if you want to set MAC manually
#       pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838
#
# Wired adapter #2
#auto eth1
#       iface eth1 inet dhcp
#       hwaddress ether # if you want to set MAC manually
#       pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838
#
# Wireless adapter #1
auto wlan0
        allow-hotplug wlan0
        wpa-ssid yourSSID
        wpa-psk yourpassword
# to generate proper encrypted key: wpa_passphrase yourSSID yourpassword
#
# Local loopback
auto lo
        iface lo inet loopback

 

AND REBOOT and it should work like in my case ;-)

Share this post


Link to post
Share on other sites

tonight I'll try this on my device with "Armbian_4.5_Bananapi_Debian_wheezy_4.2.3" Thank U so much for the "step by step" technik007_cz. 

Share this post


Link to post
Share on other sites

Wifi is working now...

 

I used following commands on my BananaPro board with legacy kernel and Ubuntu Trusty:

( Download link of used system image http://mirror.igorpecovnik.com/Armbian_4.5_Bananapi_Ubuntu_trusty_3.4.109_desktop.zip.

Note: If this link should be different for BananaPi and for BananaPro it is not my fault :-) )

 

# based on previous posts I decided return back old kernel version 3.4.109 for bananapi because wifi driver is not working on latest kernel supplied with system image

apt-get purge linux-firmware-image-sun7i -y

rm /etc/modules -Rv # apt-get cannot remove this folder during uninstall procedure

aptitude install linux-image-banana linux-headers-banana linux-firmware-image-banana linux-u-boot-bananapi -y

 

rm -v /boot/script.bin

ln -vs /boot/bin/bananapipro.bin /boot/script.bin

 

echo ap6210 >> /etc/modules && cat /etc/modules

 

# generate encrypted wifi password and copy output to clipboard

wpa_passphrase yourSSID yourpassword

# edit /etc/network/interfaces

# remove "#" symbol like you can see in example below

# replace "yourSSID" and "yourpassword" with your wifi SSID and ecrypted password

nano /etc/network/interfaces

 

EXAMPLE:

# Wired adapter #1

auto eth0

        iface eth0 inet dhcp

#       hwaddress ether # if you want to set MAC manually

#       pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838

#

# Wired adapter #2

#auto eth1

#       iface eth1 inet dhcp

#       hwaddress ether # if you want to set MAC manually

#       pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838

#

# Wireless adapter #1

auto wlan0

        allow-hotplug wlan0

        wpa-ssid yourSSID

        wpa-psk yourpassword

# to generate proper encrypted key: wpa_passphrase yourSSID yourpassword

#

# Local loopback

auto lo

        iface lo inet loopback

 

AND REBOOT and it should work like in my case ;-)

YEAAAAAAH it works thank U so much technik007_cz w/o your help I would not have ever made even in terms of explanation (I'm referrin' to Igor) thank U again to U too for your efforts

Share this post


Link to post
Share on other sites

I said "Victory" too quickly I mean: yes the wlan0 and the eth0 work, but the distro change to legacy ubuntu trusty starting from debian wheezy vanilla. If I copy and past the command: apt-get install linux-image-banana then the bananapi stops to workin' no boot, no reachable should I give up?... :'(

Share this post


Link to post
Share on other sites

BEFORE I do apt-get install linux-image-banana

 

root@bananapi:/boot# ls -l
total 7396
drwxr-xr-x 2 root root    4096 Oct 11 19:11 bin
-rw-r--r-- 1 root root    6944 Oct 11 19:10 boot.bmp
-rw-r--r-- 1 root root    1901 Oct 11 19:11 boot.cmd
-rw-r--r-- 1 root root    1973 Oct 11 19:11 boot.scr
-rw-r--r-- 1 root root  115484 Oct 11 14:12 config-4.2.3-sunxi
drwxr-xr-x 2 root root    4096 Oct 11 19:10 dtb
lrwxrwxrwx 1 root root      22 Oct 11 19:11 script.bin -> /boot/bin/bananapi.bin
-rw-r--r-- 1 root root 1955569 Oct 11 14:12 System.map-4.2.3-sunxi
-rwxr-xr-x 1 root root 5468416 Oct 11 14:12 vmlinuz-4.2.3-sunxi
lrwxrwxrwx 1 root root      25 Oct 11 19:10 zImage -> /boot/vmlinuz-4.2.3-sunxi

 

AFTER I did apt-get install linux-image-banana

root@bananapi:/boot# ls -l
total 12904
drwxr-xr-x 2 root root    4096 Oct 11 19:11 bin
-rw-r--r-- 1 root root    6944 Oct 11 19:10 boot.bmp
-rw-r--r-- 1 root root    1901 Oct 11 19:11 boot.cmd
-rw-r--r-- 1 root root    1973 Oct 11 19:11 boot.scr
-rw-r--r-- 1 root root   97535 Sep 30 14:21 config-3.4.109-banana
drwxr-xr-x 2 root root    4096 Oct 11 19:10 dtb
lrwxrwxrwx 1 root root      22 Oct 11 19:11 script.bin -> /boot/bin/bananapi.bin
-rw-r--r-- 1 root root 2005221 Sep 30 14:21 System.map-3.4.109-banana
-rwxr-xr-x 1 root root 5607544 Sep 30 14:21 vmlinuz-3.4.109-banana
-rwxr-xr-x 1 root root 5468416 Oct 11 14:12 vmlinuz-4.2.3-sunxi
lrwxrwxrwx 1 root root      28 Jan 20 19:17 zImage -> /boot/vmlinuz-3.4.109-banana

 

I want a headless sys what I can do? someone can help me?

Share this post


Link to post
Share on other sites

1. All kernels support this wireless chip

2. Support come in three different drivers: bcmdhd, ap6210 and brcmfmac

3. Changing kernel doesn't fix that. You need to manually add appropriate module to /etc/modules

4. You need to setup wireless in interfaces conf. It's disabled by default

 

Use general help: 

https://wiki.debian.org/WiFi/HowToUse

and Google.

Share this post


Link to post
Share on other sites

I said "Victory" too quickly I mean: yes the wlan0 and the eth0 work, but the distro change to legacy ubuntu trusty starting from debian wheezy vanilla. If I copy and past the command: apt-get install linux-image-banana then the bananapi stops to workin' no boot, no reachable should I give up?... :'(

I wrote "I used following commands on my BananaPro board with legacy kernel and Ubuntu Trusty:"

You need to read http://www.armbian.com/documentation/ before, "How to upgrade kernel?" paragraph and switch kernel before following my guide.

I do not want to say you cannot test those commands in different environment (board, kernel, system) but do backup first.

Share this post


Link to post
Share on other sites

BEFORE I do apt-get install linux-image-banana

 

root@bananapi:/boot# ls -l

total 7396

drwxr-xr-x 2 root root    4096 Oct 11 19:11 bin

-rw-r--r-- 1 root root    6944 Oct 11 19:10 boot.bmp

-rw-r--r-- 1 root root    1901 Oct 11 19:11 boot.cmd

-rw-r--r-- 1 root root    1973 Oct 11 19:11 boot.scr

-rw-r--r-- 1 root root  115484 Oct 11 14:12 config-4.2.3-sunxi

drwxr-xr-x 2 root root    4096 Oct 11 19:10 dtb

lrwxrwxrwx 1 root root      22 Oct 11 19:11 script.bin -> /boot/bin/bananapi.bin

-rw-r--r-- 1 root root 1955569 Oct 11 14:12 System.map-4.2.3-sunxi

-rwxr-xr-x 1 root root 5468416 Oct 11 14:12 vmlinuz-4.2.3-sunxi

lrwxrwxrwx 1 root root      25 Oct 11 19:10 zImage -> /boot/vmlinuz-4.2.3-sunxi

 

AFTER I did apt-get install linux-image-banana

root@bananapi:/boot# ls -l

total 12904

drwxr-xr-x 2 root root    4096 Oct 11 19:11 bin

-rw-r--r-- 1 root root    6944 Oct 11 19:10 boot.bmp

-rw-r--r-- 1 root root    1901 Oct 11 19:11 boot.cmd

-rw-r--r-- 1 root root    1973 Oct 11 19:11 boot.scr

-rw-r--r-- 1 root root   97535 Sep 30 14:21 config-3.4.109-banana

drwxr-xr-x 2 root root    4096 Oct 11 19:10 dtb

lrwxrwxrwx 1 root root      22 Oct 11 19:11 script.bin -> /boot/bin/bananapi.bin

-rw-r--r-- 1 root root 2005221 Sep 30 14:21 System.map-3.4.109-banana

-rwxr-xr-x 1 root root 5607544 Sep 30 14:21 vmlinuz-3.4.109-banana

-rwxr-xr-x 1 root root 5468416 Oct 11 14:12 vmlinuz-4.2.3-sunxi

lrwxrwxrwx 1 root root      28 Jan 20 19:17 zImage -> /boot/vmlinuz-3.4.109-banana

 

I want a headless sys what I can do? someone can help me?

Try "How to unbrick the system?" http://www.armbian.com/documentation/.

You will probably need relink zImage back to vmlinuz-4.2.3-sunxi - check it after unbricking.

And delete /lib/firmware folder before unbricking.

Or sometimes is better to start from beginning ... ;-) (copy new image to sdcard...)

Share this post


Link to post
Share on other sites

no way armbian is not for me in etc modules I have brcmfmac and bonding wireless setup is ok I can manage it but if I do apt-get install linux-image-banana kernel changes by itself automatically and I lose the connection with the device

 

iwconfig give me this:
lo        no wireless extensions.

eth0      no wireless extensions.

bond0     no wireless extensions.

tunl0     no wireless extensions.
I've already burned a sd card doing always the same thing format&write, format&write, format&write... f&w... etc etc

 

Just for the record I've exactly did what technik007_cz wrote

Share this post


Link to post
Share on other sites

Slow down, read docs and forum and try to understand how things works. It would be better for you and for us to assist in fixing the problem. Armbian is more or less default Debian / Ubuntu install. I added certain things that makes setup easier but the "plug and play" is done only to certain degree. There are example configurations, that you don't need to start from nothing. Further you need to "read and play" or use already owned knowledge.

Share this post


Link to post
Share on other sites

Do not be confused HAZArD...

... because it is not probably your fault ;-).

 

no way armbian is not for me in etc modules I have brcmfmac and bonding wireless setup is ok I can manage it but if I do apt-get install linux-image-banana kernel changes by itself automatically and I lose the connection with the device

 

iwconfig give me this:
lo        no wireless extensions.

eth0      no wireless extensions.

bond0     no wireless extensions.

tunl0     no wireless extensions.
I've already burned a sd card doing always the same thing format&write, format&write, format&write... f&w... etc etc

 

Just for the record I've exactly did what technik007_cz wrote

 

Did you try this image: Armbian_4.5_Bananapi_Ubuntu_trusty_3.4.109_desktop.raw ?

 

Because this is output of /etc/modules in that image after I downloaded it from website:

 

cat /etc/modules

 

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

hci_uart
gpio_sunxi
rfcomm
hidp
sunxi-ir
bonding
spi_sun7i
8021q
a20_tp

 

You need image with legacy kernel. (It is possible to swap between kernels if you downloaded vanilla image but it did not work for me in past and I have no time to test it on latest images now).

If you are not sure which one are you running try next command:

uname -r

 

Output of this command on my bananapro it is now:

3.4.109-banana

 

If you have vanilla kernel number should start with "4" like in this example:

4.2.3...

 

If you see kernel version number 4 it is wrong and download image from link below :

http://mirror.igorpecovnik.com/Armbian_4.5_Bananapi_Ubuntu_trusty_3.4.109_desktop.zip

 

If your kernel number start with 3 try next command to upgrade all system packages to latest on your fresh image:

apt-get update -y && apt-get upgrade

 

...and after successful upgrade follow my guide.

 

If you want run your system on vanilla kernel my guide is not for you because this kernel needs different wifi driver than ap6210 at this moment I think.

Share this post


Link to post
Share on other sites

Thank U so much technik007_cz I appreciate your encouragement U know I'm so frustrated... Yes  with Armbian_4.5_Bananapi_Ubuntu_trusty_3.4.109_desktop.raw everything works but like I said I would have an headless sys 'cause what I need is just a little nas with some plugins. I'll wait the next release hoping that everything is smooth. In the meantime I try&try&try&try until burning the next sd card  :D 

Share this post


Link to post
Share on other sites

Please I'm exhaust... today is the second day w/o sleeping please tell me step by step how activate the wifi I'm totally out

I start writing the image on sd card then update & upgrade and then... I'm stuck here which are the commands to write?... for activate the wifi?

Share this post


Link to post
Share on other sites

Hi,

im getting confused.. whats the point of armbian OS if it doesnt work properly after default install?

I have banan pi m1+ and i did default install as per description... i chosen Xenian ubuntu vanila.

 

After initial boot my log is full of messages as :

[  129.562637] brcmfmac: brcmf_sdiod_regrw_helper: failed to write data F1@0x1000a, err: -16[  129.580018] brcmfmac: brcmf_sdiod_set_sbaddr_window: failed at addr: 0x1000a

Those messages are appearing every second or so... Also im surprised that noone reported that issue.

 

Whats the point of that distro then? I tried bananian and everything worked smoothly...

 

 

Needles to say that i have banana pi m1+ and the board doesnt have yellow PIN ... its black.

Share this post


Link to post
Share on other sites

There is one note at download page. You have to run few commands to change config and than wifi should work fine.

 

Wrote on mobile phone

Share this post


Link to post
Share on other sites

There is one note at download page. You have to run few commands to change config and than wifi should work fine.

 

Wrote on mobile phone

 

Hi... Im new to this site, I follow the quick star guide from the Banana pi pro page and run those command, but still I not get wlan0 interface... Im in the lastes Vanilla Jessie image, freeshly donwloaded this morning... I have the module brcmfmac propertly loaded in /etc/modules and manually... When I look for this mod I get:

 

brcmfmac              144130  0

brcmutil                4189  1 brcmfmac

cfg80211              327843  1 brcmfmac

 

 And when look into the dmesg I get:

 

[    7.742881] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43362-sdio.bin failed with error -2

[    7.742891] brcmfmac mmc1:0001:1: Falling back to user helper

[    9.939296] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50

[   10.950962] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50

 

Can someone help me to bring in up the wifi? Thanks in advance and sorry for my poor english...

Share this post


Link to post
Share on other sites

Firmware is missing. Try this:

apt-get install armbian-firmware 

or 

apt-get install armbian-firmware-full

reboot or reload the module in between.

Share this post


Link to post
Share on other sites

Firmware is missing. Try this:

apt-get install armbian-firmware 

Thanks, that do the trick... Maybe you can add this to the notes in the download page... Thanks again, have a good day...

Share this post


Link to post
Share on other sites

Thanks, that do the trick... Maybe you can add this to the notes in the download page... Thanks again, have a good day...

Wireless suppose to work out of the box, so we will try to fix it on next build.

Share this post


Link to post
Share on other sites

I'm using Kernel 3.4.113-sun7i (ubuntu) at Banana Pi pro and Wifi is working well out of the box.

Unfortunately it isn't switched off, when LAN is connected, so I searched a way to deactivate it manually.

Unfortunately, I tried this:

sudo nmcli r wifi off

That did, what I expected. But after switching back

sudo nmcli r wifi on

It is not longer able to connect to my WPA2-AP.

Syslog shows:

Feb 26 22:44:24 localhost wpa_supplicant[779]: nl80211: Could not re-add multicast membership for vendor events: -2 (No such file or directory)
Feb 26 22:44:24 localhost wpa_supplicant[779]: dbus: wpa_dbus_get_object_properties: failed to get object properties: (none) none
Feb 26 22:44:24 localhost wpa_supplicant[779]: dbus: Failed to construct signal
Feb 26 22:44:27 localhost wpa_supplicant[779]: wlan0: Trying to associate with XX:XX:XX:XX:XX:XX (SSID='XYZ123' freq=2437 MHz)
Feb 26 22:44:27 localhost wpa_supplicant[779]: wlan0: Associated with XX:XX:XX:XX:XX:XX
Feb 26 22:44:27 localhost wpa_supplicant[779]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=DE
Feb 26 22:44:31 localhost wpa_supplicant[779]: wlan0: CTRL-EVENT-DISCONNECTED bssid=XX:XX:XX:XX:XX:XX reason=2
Feb 26 22:44:31 localhost wpa_supplicant[779]: wlan0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
Feb 26 22:44:31 localhost wpa_supplicant[779]: wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="XYZ123" auth_failures=1 duration=10 reason=WRONG_KEY
Feb 26 22:44:31 localhost wpa_supplicant[779]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD

which says more or less, that the PSK is wrong - but it hasn't changed. Maybe it is related to the message in line 2 above?

Any hint is welcome, where I can search to make the link working again without reinstalling the whole system.

BR

GD

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
2 2