4 4
tkaiser

quick review Banana Pi M3

Recommended Posts

3 hours ago, John34 said:

what we must install like .deb ?


There is nothing to install. It has to be developed. Something like this has to be added to the kernel code, recompile, test, adjust, test ...  For you/end user it will just show up one day after a kernel upgrade that this will be fixed.

Share this post


Link to post
Share on other sites

oki guy's, i've already tested like on my ubuntu 18.04 xfce in my laptop, hddtemp which allow to show CPU temperature " hddtemp in terminal " it is available on arm but nothing to show about temperature, i will wait... 

 

I've checked on website archlinux.org and i don't see any images for arm boards ? :o 

 

As you can see in the screenshot i've found a temporary solution to refresh the Octa-core on my Banana i've put a big heatsink in waiting those which are in commands on aliexpress, in all case it allow me to test the banana with success, because actually i don't have any problem since it's refresh by heatsink :)

Share this post


Link to post
Share on other sites
45 minutes ago, John34 said:

oki guy's, i've already tested like on my ubuntu 18.04 xfce in my laptop, hddtemp which allow to show CPU temperature " hddtemp in terminal " it is available on arm but nothing to show about temperature, i will wait... 


Temperature is absent on this particular board because the driver for the sensor for Allwinner A83T, which is on this board, is not developed, ported yet. Kernel does not supply temperature to the application. Any application. Any operating system: Debian, Ubuntu, ArchLinux, WhateverLinuxDistributionOuthere, ...  Edit: perhaps this temp sensor works on Android/stock 3.4.y kernel which you want to avoid on all cost.

 

45 minutes ago, John34 said:

i don't have any problem since it's refresh by heatsink


Great to hear! :thumbup: Now you can play, test, wait for this to be solved or help.

Share this post


Link to post
Share on other sites

Hi All :) Just to say that "wired" is broken because, when i do a fresh install of the last armbian(ubuntu) version, all is working, but when i switch off my BananaPi M3 and after i switch ON, the  wired connection is ok until the OS is completely started, when i'm on desktop on Armbian there is no wired connexion where as the Ethernet cable is plugged. i'm so sad.. :'(

If the Banana is always ON after a fresh install, the Wired connection is OK.

If the Banana needs to be OFF just on time, after put it ON there is no more Wired connection active... :(

 

If someone has a idea or maybe wait a new version of armbian to correct this problem ?

 

Best regards.

Share this post


Link to post
Share on other sites
3 hours ago, John34 said:

No one have suggestion or informations about Wired connection ? It will be ok in a new version of Armbian ?


Try to exchange cables. Wired network works for me (from the last image from download section with kernel 4.19.y), but perhaps some fine tuning is needed since it runs at around 50% with lots of retries.

Share this post


Link to post
Share on other sites

hi :)

 

Ah ok, it since 4.17 now i'm on 4.19 maybe it's already integrated in bionic 18.04, actually wired connection works well, if it doesn't work again i will try this patch, thanks for your informations :)

Share this post


Link to post
Share on other sites

Yes last debian version is very great all is working, but i would like to install x2goserver and it seems more complicated as bionic lol,

 

sudo apt install x2goserver

Les paquets suivants contiennent des dépendances non satisfaites :
 x2goserver : Dépend: x2goserver-x2goagent (< 4.1.0.3-3~bpo9+1.1~) mais ne sera pas installé
              Dépend: x2goserver-x2goagent (>= 4.1.0.3-3~bpo9+1) mais ne sera pas installé

 

sudo apt install x2goserver-x2goagent

Les paquets suivants contiennent des dépendances non satisfaites :
 x2goserver-x2goagent : Dépend: nxagent (>= 2:3.5.99.17~) mais ne sera pas installé

 

sudo apt install nxagent

Les paquets suivants contiennent des dépendances non satisfaites :
 nxagent : Dépend: libnx-x11-6 (= 2:3.5.99.17-1~bpo9+1) mais ne sera pas installé
           Dépend: libxcomp3 (= 2:3.5.99.17-1~bpo9+1) mais 3.5.0.32-1+b2 devra être installé
           Dépend: libxcompshad3 (= 2:3.5.99.17-1~bpo9+1) mais ne sera pas installé

 

sudo apt install libxcomp3
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libxcomp3 is already the newest version (3.5.0.32-1+b2).

 

I'm going to turn around, around and around,

 

I have installed xrdp before it works, but when i'm connecting via remmina in xrdp i arrive on my desktop but it seems to be another session and not the session already open.... :o

 

Share this post


Link to post
Share on other sites

Well, no news, i have tried xrdp doesn't really works, it opens me a new session with others processus from the last session working in background... so i start on a new session each time i would like to have the current desktop working.

X2go dependencies problem, Teamviewer doesn't want to work too :'( Anyone knows something about remote control on this banana which could work on it ? X2go (no) Teamviewer (no) Xrdp (no).... if there is others ?

 

Good day :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
4 4