0
SzLA

Solved No HDMI after "Starting kernel..." -- Banana Pi M1+

Recommended Posts

Hi,

 
I try to run Armbian 4.5 (Bananapi Ubuntu trusty 3.4.109 desktop)
on my Banana Pi M1+, but after the "Starting kernel..." prompt
the monitor show only the "No signal" warning. (I connect the
Banana Pi to my monitor with HDMI - DVI converter, I will be
able to try it with single HDMI cable a few days later.)
However, it boots.
 
I have a lot of tries to change the boot.cmd and the banana.bin,
but I didn't achieve satisfying result. The result of dmesg:
 

[    0.000000] Booting Linux on physical CPU 0
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.4.110-sun7i (root@production) (gcc version 4.8.2 (Ubuntu/Linaro 4.8.2-16ubuntu4) ) #2 SMP PREEMPT Sat Nov 28 19:53:25 CET 2015
[    0.000000] CPU: ARMv7 Processor [410fc074] revision 4 (ARMv7), cr=10c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[    0.000000] Machine: sun7i
[    0.000000] Memory Reserved:
[    0.000000] SYS  : 0x43000000 - 0x4300ffff  (  64 kB)
[    0.000000] VE   : 0x44000000 - 0x48ffffff  (  80 MB)
[    0.000000] G2D  : 0x49000000 - 0x49ffffff  (  16 MB)
[    0.000000] LCD  : 0x4a000000 - 0x4bffffff  (  32 MB)
[    0.000000] Memory policy: ECC disabled, Data cache writealloc
[    0.000000] sunxi: Allwinner A20 (AW1651/sun7i) detected.
[    0.000000] On node 0 totalpages: 262144
[    0.000000] free_area_init_node: node 0, pgdat c0a7b780, node_mem_map d0000000
[    0.000000]   DMA zone: 512 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 65024 pages, LIFO batch:15
[    0.000000]   Normal zone: 1008 pages used for memmap
[    0.000000]   Normal zone: 128016 pages, LIFO batch:31
[    0.000000]   HighMem zone: 528 pages used for memmap
[    0.000000]   HighMem zone: 67056 pages, LIFO batch:15
[    0.000000] PERCPU: Embedded 8 pages/cpu @d0808000 s8256 r8192 d16320 u32768
[    0.000000] pcpu-alloc: s8256 r8192 d16320 u32768 alloc=8*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1 
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 260096
[    0.000000] Kernel command line: console=tty1 root=/dev/mmcblk0p1 rootwait rootfstype=ext4 hdmi.audio=0 disp.screen0_output_mode=1280x1024p60 panic=10 consoleblank=0 enforcing=0 loglevel=1
[    0.000000] PID hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[    0.000000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] allocated 2097152 bytes of page_cgroup
[    0.000000] please try 'cgroup_disable=memory' option if you don't want memory cgroups
[    0.000000] Memory: 1024MB = 1024MB total
[    0.000000] Memory: 893656k/893656k available, 154920k reserved, 270336K highmem
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
[    0.000000]     vmalloc : 0xf0000000 - 0xff000000   ( 240 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xef800000   ( 760 MB)
[    0.000000]     pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
[    0.000000]     modules : 0xbf000000 - 0xbfe00000   (  14 MB)
[    0.000000]       .text : 0xc0008000 - 0xc09d2b30   (10027 kB)
[    0.000000]       .init : 0xc09d3000 - 0xc0a0b040   ( 225 kB)
[    0.000000]       .data : 0xc0a0c000 - 0xc0a83f28   ( 480 kB)
[    0.000000]        .bss : 0xc0a83f4c - 0xc0c592f8   (1877 kB)
[    0.000000] SLUB: Genslabs=11, HWalign=64, Order=0-3, MinObjects=0, CPUs=2, Nodes=1
[    0.000000] Preemptible hierarchical RCU implementation.
[    0.000000] RCU dyntick-idle grace-period acceleration is enabled.
[    0.000000] Additional per-CPU info printed with stalls.
[    0.000000] NR_IRQS:192
[    0.000000] Architected local timer running at 24.00MHz.
[    0.000000] sched_clock: 32 bits at 24MHz, resolution 41ns, wraps every 178956ms
[    0.000000] start_kernel(): bug: interrupts were enabled early
[    0.000000] Console: colour dummy device 80x30
[    0.000000] console [tty1] enabled
[    0.013307] Calibrating delay loop... 1816.98 BogoMIPS (lpj=9084928)
[    0.076003] pid_max: default: 32768 minimum: 301
[    0.079682] Mount-cache hash table entries: 512
[    0.083946] Initializing cgroup subsys cpuacct
[    0.087266] Initializing cgroup subsys memory
[    0.090691] Initializing cgroup subsys devices
[    0.094129] Initializing cgroup subsys freezer
[    0.097354] Initializing cgroup subsys blkio
[    0.101030] Initializing cgroup subsys perf_event
[    0.104610] CPU: Testing write buffer coherency: ok
[    0.109808] CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
[    0.116912] hw perfevents: enabled with ARMv7 Cortex-A7 PMU driver, 5 counters available
[    0.122453] Setting up static identity map for 0x40713450 - 0x407134a8
[    0.238386] CPU1: Booted secondary processor
[    0.297364] CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
[    0.299376] Brought up 2 CPUs
[    0.304687] SMP: Total of 2 processors activated (3640.52 BogoMIPS).
[    0.307961] devtmpfs: initialized
[    0.313460] dummy: 
[    0.317139] NET: Registered protocol family 16
[    0.323411] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.331119] hw-breakpoint: found 5 (+1 reserved) breakpoint and 4 watchpoint registers.
[    0.335987] hw-breakpoint: maximum watchpoint size is 8 bytes.
[    0.339142] [ccu-inf] aw clock manager init
[    0.341414] [ccu-inf] aw_ccu_init
[    0.345388] [ccu-inf] script config pll3 to 297MHz
[    0.349140] [ccu-inf] script config pll4 to 300MHz
[    0.352888] [ccu-inf] script config pll6 to 600MHz
[    0.356653] [ccu-inf] script config pll7 to 297MHz
[    0.360400] [ccu-inf] script config pll8 to 336MHz
[    0.363165] Init eGon pin module V2.0
[    0.372394] bio: create slab <bio-0> at 0
[    0.375992] sunxi_gpio driver init ver 1.3
[    0.382278] gpiochip_add: registered GPIOs 1 to 88 on device: A1X_GPIO
[    0.385504] SCSI subsystem initialized
[    0.388348] libata version 3.00 loaded.
[    0.392996] usbcore: registered new interface driver usbfs
[    0.397349] usbcore: registered new interface driver hub
[    0.401521] usbcore: registered new device driver usb
[    0.404640] Linux media interface: v0.10
[    0.408280] Linux video capture interface: v2.00
[    0.413876] Advanced Linux Sound Architecture Driver Version 1.0.25.
[    0.419188] Switching to clocksource arch_sys_counter
[    0.421306] FS-Cache: Loaded
[    0.423499] CacheFiles: Loaded
[    0.434590] cfg80211: Calling CRDA to update world regulatory domain
[    0.439946] [usb_manager]: CONFIG_USB_SW_SUNXI_USB0_OTG
[    0.443765] [sw_hcd0]: usb host driver initialize........
[    0.447936] [sw_hcd0]: open_usb_clock
[    0.472205] [sw_hcd0]: host_init_state = 0
[    0.473176] [sw_hcd0]: platform is usb host
[    0.476083] [sw_hcd0]: sw_hcd_host0: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO Rx (X), HB-ISO Tx (X), SoftConn)
[    0.487269] [sw_hcd0]: sw_hcd_init_controller: sw_hcd_host0: USB Host mode controller at f1c13000 using PIO, IRQ 70
[    0.499808] sw_hcd_host0 sw_hcd_host0: sw_hcd host driver
[    0.506521] sw_hcd_host0 sw_hcd_host0: new USB bus registered, assigned bus number 1
[    0.509936] hub 1-0:1.0: USB hub found
[    0.512868] hub 1-0:1.0: 1 port detected
[    0.516724] wrn: hcd is not enable, need not start hcd
[    0.518061] [sw_hcd0]: sw_usb_host0_disable start
[    0.524103] -------sw_hcd0_soft_disconnect---------
[    0.527085] is_on = 0, hcd0_set_vbus_cnt = 0
[    0.530136] [sw_hcd_host0]: Set USB Power Off
[    0.533880] wrn: hcd is not enable, need not stop hcd
[    0.534934] [sw_hcd0]: close_usb_clock
[    0.537398] [sw_hcd0]: sw_usb_host0_disable end
[    0.540605] [sw_udc]: udc_init: version 20080411
[    0.546953] NET: Registered protocol family 2
[    0.563851] IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.570793] TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
[    0.578322] TCP bind hash table entries: 65536 (order: 7, 786432 bytes)
[    0.584990] TCP: Hash tables configured (established 131072 bind 65536)
[    0.587177] TCP: reno registered
[    0.592054] UDP hash table entries: 512 (order: 2, 16384 bytes)
[    0.597404] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[    0.601021] NET: Registered protocol family 1
[    0.606278] RPC: Registered named UNIX socket transport module.
[    0.609941] RPC: Registered udp transport module.
[    0.613725] RPC: Registered tcp transport module.
[    0.619117] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    0.624694] audit: initializing netlink socket (disabled)
[    0.628395] type=2000 audit(0.610:1): initialized
[    0.632685] highmem bounce pool size: 64 pages
[    0.644483] VFS: Disk quotas dquot_6.5.2
[    0.649989] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    0.657225] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.662620] NFS: Registering the id_resolver key type
[    0.667185] NTFS driver 2.1.30 [Flags: R/W].
[    0.670497] fuse init (API version 7.18)
[    0.675179] JFS: nTxBlock = 6981, nTxLock = 55853
[    0.692126] SGI XFS with ACLs, security attributes, large block/inode numbers, no debug enabled
[    0.696395] Btrfs loaded
[    0.699216] msgmni has been set to 1217
[    0.706859] alg: No test for stdrng (krng)
[    0.713548] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[    0.716548] io scheduler noop registered
[    0.719775] io scheduler deadline registered
[    0.723529] io scheduler cfq registered (default)
[    0.728420] sunxi disp driver loaded (/dev/disp api 1.0)
[    0.733977] Serial: 8250/16550 driver, 8 ports, IRQ sharing disabled
[    0.738742] [uart]: used uart info.: 0x81
[    0.743431] [uart]: serial probe 0 irq 33 mapbase 0x01c28000
[    0.769729] sunxi-uart.0: ttyS0 at MMIO 0x1c28000 (irq = 33) is a U6_16550A
[    0.774624] [uart]: serial probe 7 irq 52 mapbase 0x01c29c00
[    0.800829] sunxi-uart.7: ttyS1 at MMIO 0x1c29c00 (irq = 52) is a U6_16550A
[    0.803448] G2D: drv_g2d_init
[    0.808151] G2D: g2dmem: g2d_start=49000000, g2d_size=1000000
[    0.811376] G2D: head:c9000000,tail:ca000000
[    0.814748] G2D: Module initialized.major:250
[    0.824218] brd: module loaded
[    0.830308] loop: module loaded
[    0.832642] nand driver is disabled 
[    0.836424] gpio count < =0 ,gpio_count is: 0
[    0.842347] sw_ahci sw_ahci.0: controller can't do PMP, turning off CAP_PMP
[    0.846847] ahci: SSS flag set, parallel bus scan disabled
[    0.854258] sw_ahci sw_ahci.0: AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl platform mode
[    0.861149] sw_ahci sw_ahci.0: flags: ncq sntf stag pm led clo only pio slum part ccc 
[    0.864559] scsi0 : sw_ahci_platform
[    0.871777] ata1: SATA max UDMA/133 mmio [mem 0x01c18000-0x01c18fff] port 0x100 irq 88
[    0.876322] [spi-inf] Found 1 spi devices in config files
[    0.883164] [spi-inf] boards num modalias         max_spd_hz       bus_num  cs   mode
[    0.886953] [spi-inf] spi_board0 irq gpio not used
[    0.893908] [spi-inf] 0          spidev           12000000         0        0    0x3   
[    0.898005] [spi-inf] sun7i_spi_probe: sun7i spi probe
[    0.902625] [spi-inf] sun7i_spi_probe: spi0 dma type: normal
[    0.906227] [spi-inf] bus num = 0, spi used = 3 
[    0.910666] [spi-inf] sun7i_spi_probe: spi0 cs bitmap: 0x3
[    0.919231] [spi-inf] sun7i_spi_set_mclk: spi0 source = sdram_pll_p, src_clk = 432000000, mclk 86400000
[    0.925156] sun7i-spi sun7i-spi.0: master is unqueued, this is deprecated
[    0.931259] [spi-inf] sun7i_spi_setup: enter, bpw: 8, mshz: 12000000, mode: 3
[    0.940071] [spi-inf] sun7i_spi_probe: reuuimlla's SoC SPI Driver loaded for Bus SPI0 with 2 Slaves at most
[    0.949474] [spi-inf] sun7i_spi_probe: spi0 driver probe succeed, base f0518000, irq 42, dma_id_rx 24, dma_id_tx 24
[    0.955608] bonding: Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
[    0.960358] Fixed MDIO Bus: probed
[    0.964951] emac_init fetch emac using configuration failed
[    0.967398] emac driver is disabled
[    0.970934] gmac: use mac address from chipid
[    0.975058] gmac: device MAC address 02:19:06:03:54:f8
[    0.980747] [gmac]: sun6i_gmac platform driver registration completed
[    0.984057] PPP generic driver version 2.4.2
[    0.987993] PPP BSD Compression module registered
[    0.992000] PPP Deflate Compression module registered
[    0.996905] PPP MPPE Compression module registered
[    1.000311] NET: Registered protocol family 24
[    1.006371] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.011568] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    1.014040] [sw-ehci1]: open clock
[    1.036721] [sw-ehci1]: Set USB Power ON
[    1.043159] sw-ehci sw-ehci.1: SW USB2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.049399] sw-ehci sw-ehci.1: new USB bus registered, assigned bus number 2
[    1.053809] sw-ehci sw-ehci.1: irq 71, io mem 0x01c14000
[    1.073623] sw-ehci sw-ehci.1: USB 2.0 started, EHCI 1.00
[    1.076989] hub 2-0:1.0: USB hub found
[    1.079885] hub 2-0:1.0: 1 port detected
[    1.082550] [sw-ohci1]: open clock
[    1.108698] sw-ohci sw-ohci.1: SW USB2.0 'Open' Host Controller (OHCI) Driver
[    1.114918] sw-ohci sw-ohci.1: new USB bus registered, assigned bus number 3
[    1.119257] sw-ohci sw-ohci.1: irq 96, io mem 0x01c14400
[    1.186673] hub 3-0:1.0: USB hub found
[    1.189568] hub 3-0:1.0: 1 port detected
[    1.192226] [sw-ehci2]: open clock
[    1.214916] [sw-ehci2]: Set USB Power ON
[    1.221352] sw-ehci sw-ehci.2: SW USB2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.225708] ata1: SATA link down (SStatus 0 SControl 300)
[    1.231990] sw-ehci sw-ehci.2: new USB bus registered, assigned bus number 4
[    1.236403] sw-ehci sw-ehci.2: irq 72, io mem 0x01c1c000
[    1.253619] sw-ehci sw-ehci.2: USB 2.0 started, EHCI 1.00
[    1.256960] hub 4-0:1.0: USB hub found
[    1.259854] hub 4-0:1.0: 1 port detected
[    1.262515] [sw-ohci2]: open clock
[    1.288666] sw-ohci sw-ohci.2: SW USB2.0 'Open' Host Controller (OHCI) Driver
[    1.294912] sw-ohci sw-ohci.2: new USB bus registered, assigned bus number 5
[    1.299301] sw-ohci sw-ohci.2: irq 97, io mem 0x01c1c400
[    1.366652] hub 5-0:1.0: USB hub found
[    1.369545] hub 5-0:1.0: 1 port detected
[    1.373825] Initializing USB Mass Storage driver...
[    1.378946] usbcore: registered new interface driver usb-storage
[    1.382520] USB Mass Storage support registered.
[    1.387475] usbcore: registered new interface driver ums-alauda
[    1.392475] usbcore: registered new interface driver ums-cypress
[    1.397495] usbcore: registered new interface driver ums-datafab
[    1.402667] usbcore: registered new interface driver ums_eneub6250
[    1.407693] usbcore: registered new interface driver ums-freecom
[    1.412604] usbcore: registered new interface driver ums-isd200
[    1.417708] usbcore: registered new interface driver ums-jumpshot
[    1.422533] usbcore: registered new interface driver ums-karma
[    1.427635] usbcore: registered new interface driver ums-onetouch
[    1.432652] usbcore: registered new interface driver ums-realtek
[    1.437581] usbcore: registered new interface driver ums-sddr09
[    1.442492] usbcore: registered new interface driver ums-sddr55
[    1.447333] usbcore: registered new interface driver ums-usbat
[    1.452104] mousedev: PS/2 mouse device common for all mice
[    1.457786] ===========================hv_keypad_init=====================
[    1.461185] ========HV Inital ===================
[    1.465129] tkey_fetch_sysconfig_para: tkey_unused. 
[    1.472342] hv_keypad_init: after fetch_sysconfig_para:  normal_i2c: 0x0. normal_i2c[1]: 0x0 
[    1.478146] sunxi-rtc sunxi-rtc: rtc core: registered rtc as rtc0
[    1.480643] i2c /dev entries driver
[    1.484581] config i2c gpio with gpio_config api
[    1.490203] axp_mfd 0-0034: AXP (CHIP ID: 0x41) detected
[    1.496050] axp_mfd 0-0034: AXP internal temperature monitoring enabled
[    1.501286] [AXP]axp driver uning configuration failed(342)
[    1.503253] [AXP]power_start = 0
[    1.506928] i2c i2c-0: Invalid probe address 0x00
[    1.509982] I2C: i2c-0: AW16XX I2C adapter
[    1.513379] config i2c gpio with gpio_config api
[    1.517355] i2c i2c-1: Invalid probe address 0x00
[    1.520409] I2C: i2c-1: AW16XX I2C adapter
[    1.523810] config i2c gpio with gpio_config api
[    1.527777] i2c i2c-2: Invalid probe address 0x00
[    1.530832] I2C: i2c-2: AW16XX I2C adapter
[    1.534224] config i2c gpio with gpio_config api
[    1.538153] i2c i2c-3: Invalid probe address 0x00
[    1.541207] I2C: i2c-3: AW16XX I2C adapter
[    1.543973] [cedar dev]: install start!!!
[    1.546942] [cedar dev]: install end!!!
[    1.550342] [tt]----- avs_dev driver load... ----
[    1.553939] [tt]-----      register iomem      ----
[    1.556733] Cannot reserve region for ccmu
[    1.560369] [tt]--- avs_dev driver load ok!! -----
[    1.562141] [ace_drv] start!!!
[    1.564507] [ace_drv] init end!!!
[    1.566172] [pa_drv] start!!!
[    1.568414] [pa_drv] init end!!!
[    1.570794] axp20_ldo1: 1300 mV 
[    1.576054] axp20_ldo2: 1800 <--> 3300 mV at 3000 mV 
[    1.581160] axp20_ldo3: 700 <--> 3500 mV at 2800 mV 
[    1.586355] axp20_ldo4: 1250 <--> 3300 mV at 2800 mV 
[    1.591716] axp20_buck2: 700 <--> 2275 mV at 1450 mV 
[    1.598236] somebody is trying to set dcdc3 range to (1300000, 1300000) uV
[    1.603263] but we keep dcdc3 = 1250000 uV from the bootloader
[    1.607532] axp20_buck3: 700 <--> 3500 mV at 1250 mV 
[    1.612397] axp20_ldoio0: 1800 <--> 3300 mV at 2800 mV 
[    1.621976] input: axp20-supplyer as /devices/platform/sunxi-i2c.0/i2c-0/0-0034/axp20-supplyer.28/input/input0
[    1.640496] axp20_ldo2: Failed to create debugfs directory
[    1.643758] incomplete xfer (0x20)
[    1.646023] incomplete xfer (0x20)
[    1.648276] incomplete xfer (0x20)
[    1.650526] incomplete xfer (0x20)
[    1.652809] incomplete xfer (0x20)
[    1.655062] incomplete xfer (0x20)
[    1.657313] incomplete xfer (0x20)
[    1.659563] incomplete xfer (0x20)
[    1.661831] incomplete xfer (0x20)
[    1.664170] incomplete xfer (0x20)
[    1.666504] incomplete xfer (0x20)
[    1.668838] incomplete xfer (0x20)
[    1.671172] incomplete xfer (0x20)
[    1.673523] incomplete xfer (0x20)
[    1.675857] incomplete xfer (0x20)
[    1.678191] incomplete xfer (0x20)
[    1.680525] incomplete xfer (0x20)
[    1.682872] incomplete xfer (0x20)
[    1.685210] incomplete xfer (0x20)
[    1.687544] incomplete xfer (0x20)
[    1.689878] incomplete xfer (0x20)
[    1.692226] incomplete xfer (0x20)
[    1.694561] incomplete xfer (0x20)
[    1.696895] incomplete xfer (0x20)
[    1.699230] incomplete xfer (0x20)
[    1.701595] incomplete xfer (0x20)
[    1.703930] incomplete xfer (0x20)
[    1.706268] incomplete xfer (0x20)
[    1.708604] incomplete xfer (0x20)
[    1.710938] incomplete xfer (0x20)
[    1.713287] incomplete xfer (0x20)
[    1.715621] incomplete xfer (0x20)
[    1.717956] incomplete xfer (0x20)
[    1.720290] incomplete xfer (0x20)
[    1.722638] incomplete xfer (0x20)
[    1.724973] incomplete xfer (0x20)
[    1.728964] device-mapper: uevent: version 1.0.3
[    1.736810] device-mapper: ioctl: 4.22.0-ioctl (2011-10-19) initialised: dm-devel@redhat.com
[    1.741660] device-mapper: multipath: version 1.3.2 loaded
[    1.747176] device-mapper: multipath round-robin: version 1.0.0 loaded
[    1.752743] device-mapper: multipath queue-length: version 0.1.0 loaded
[    1.758323] device-mapper: multipath service-time: version 0.2.0 loaded
[    1.761763] cpuidle: using governor ladder
[    1.764674] cpuidle: using governor menu
[    1.766994] [mmc-msg] sw_mci_init
[    1.772714] [mmc-msg] MMC host used card: 0x1, boot card: 0x0, io_card 0
[    1.777978] [mmc-msg] sdc0 set round clock 400000, src 24000000
[    1.786238] [mmc-msg] sdc0 set ios: clk 0Hz bm OD pm OFF vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    1.794458] [mmc-msg] sdc0 Probe: base:0xf0570000 irq:64 sg_cpu:f0572000(4fc00000) ret 0.
[    1.799056] [mmc_pm]: failed to fetch sdio card configuration!
[    1.801493] sunxi_leds driver init
[    1.805608] Registered led device: green:ph24:led1
[    1.810614] ledtrig-cpu: registered to indicate activity on CPUs
[    1.815824] usbcore: registered new interface driver usbhid
[    1.818615] usbhid: USB HID core driver
[    1.821308] ashmem: initialized
[    1.824981] logger: created 256K log 'log_main'
[    1.828784] logger: created 256K log 'log_events'
[    1.832480] logger: created 256K log 'log_radio'
[    1.836300] logger: created 256K log 'log_system'
[    1.843119] [sPDIF] [spdif_para] isn't defined or spdif_used=0
[    1.845977] [i2S-0] Entered sunxi_i2s_init
[    1.853711] [i2S-0] sunxi-i2s cannot find any using configuration for controllers, return directly!
[    1.861434] [i2S-0] sndi2s cannot find any using configuration for controllers, return directly!
[    1.864510] [i2S-0] Entered sunxi_sndi2s_init
[    1.867947] IPv4 over IPv4 tunneling driver
[    1.870771] TCP: bic registered
[    1.873111] TCP: cubic registered
[    1.875643] TCP: westwood registered
[    1.878259] TCP: highspeed registered
[    1.880528] TCP: hybla registered
[    1.882728] TCP: htcp registered
[    1.884998] TCP: vegas registered
[    1.887181] TCP: veno registered
[    1.889710] TCP: scalable registered
[    1.891733] TCP: lp registered
[    1.893916] TCP: yeah registered
[    1.896445] TCP: illinois registered
[    1.899667] Initializing XFRM netlink socket
[    1.903792] NET: Registered protocol family 10
[    1.908453] NET: Registered protocol family 17
[    1.911889] NET: Registered protocol family 15
[    1.916606] [mmc_pm]: No sdio card, please check your config !!
[    1.920278] Registering the dns_resolver key type
[    1.922377] VFP support v0.3: implementor 41 architecture 2 part 30 variant 7 rev 4
[    1.930930] Registering SWP/SWPB emulation handler
[    1.935580] axp20_buck2: Failed to create debugfs directory
[    1.941749] [cpu_freq] INF:-------------------V-F Table-------------------
[    1.946828] [cpu_freq] INF: voltage = 1450mv frequency = 1008MHz
[    1.951873] [cpu_freq] INF: voltage = 1425mv frequency =  912MHz
[    1.956931] [cpu_freq] INF: voltage = 1350mv frequency =  864MHz
[    1.961976] [cpu_freq] INF: voltage = 1250mv frequency =  720MHz
[    1.967032] [cpu_freq] INF: voltage = 1150mv frequency =  528MHz
[    1.972077] [cpu_freq] INF: voltage = 1100mv frequency =  312MHz
[    1.977132] [cpu_freq] INF: voltage = 1050mv frequency =  144MHz
[    1.982177] [cpu_freq] INF: voltage = 1000mv frequency =    0MHz
[    1.988011] [cpu_freq] INF:-----------------------------------------------
[    1.997747] [cpu_freq] INF:sunxi_cpufreq_initcall, get cpu frequency from sysconfig, max freq: 912MHz, min freq: 720MHz
[    2.001809] registered taskstats version 1
[    2.006426] I2C: i2c-4: HDMI I2C adapter
[    2.035927] disp clks: lcd 148500000 pre_scale 1 hdmi 148500000 pll 297000000 2x 0
[    2.778155] [mmc-msg] mmc 0 detect change, present 1
[    3.277226] [mmc-msg] sdc0 set ios: clk 0Hz bm PP pm UP vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    3.279688] [mmc-msg] sdc0 power on
[    3.307615] [mmc-msg] sdc0 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    3.312538] [mmc-msg] sdc0 set round clock 400000, src 24000000
[    3.314463] Console: switching to colour frame buffer device 240x67
[    3.365744] axp20_buck3: incomplete constraints, leaving on
[    3.370551] axp20_buck2: incomplete constraints, leaving on
[    3.375305] axp20_ldo4: incomplete constraints, leaving on
[    3.380023] axp20_ldo3: incomplete constraints, leaving on
[    3.384762] axp20_ldo2: incomplete constraints, leaving on
[    3.389479] axp20_ldo1: incomplete constraints, leaving on
[    3.392528] console [netcon0] enabled
[    3.396036] netconsole: network logging started
[    3.399353] [mmc-err] smc 0 err, cmd 52,  RTO
[    3.403568] otg_wakelock_init: No USB transceiver found
[    3.406883] [mmc-err] smc 0 err, cmd 52,  RTO
[    3.415265] [mmc-msg] sdc0 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    3.422747] sunxi-rtc sunxi-rtc: setting system clock to 2015-12-22 14:19:35 UTC (1450793975)
[    3.424825] ALSA device list:
[    3.427879]   #0: sunxi-CODEC  Audio Codec
[    3.436223] [mmc-msg] sdc0 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    3.440826] Waiting for root device /dev/mmcblk0p1...
[    3.444059] [mmc-err] smc 0 err, cmd 5,  RTO
[    3.448118] [mmc-err] smc 0 err, cmd 5,  RTO
[    3.452176] [mmc-err] smc 0 err, cmd 5,  RTO
[    3.456237] [mmc-err] smc 0 err, cmd 5,  RTO
[    3.465265] [mmc-msg] sdc0 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    3.473632] [mmc-msg] sdc0 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    3.484929] [mmc-msg] sdc0 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    3.520331] [mmc-msg] sdc0 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing SD-HS(SDR25) dt B
[    3.528792] [mmc-msg] sdc0 set ios: clk 50000000Hz bm PP pm ON vdd 3.3V width 1 timing SD-HS(SDR25) dt B
[    3.533961] [mmc-msg] sdc0 set round clock 42857143, src 600000000
[    3.597495] [mmc-msg] sdc0 set ios: clk 50000000Hz bm PP pm ON vdd 3.3V width 4 timing SD-HS(SDR25) dt B
[    3.601981] mmc0: new high speed SDHC card at address 59b4
[    3.606060] mmcblk0: mmc0:59b4 00000 7.35 GiB 
[    3.609036]  mmcblk0: p1
[    3.703083] EXT4-fs (mmcblk0p1): mounted filesystem with writeback data mode. Opts: (null)
[    3.708169] VFS: Mounted root (ext4 filesystem) on device 179:1.
[    3.714526] devtmpfs: mounted
[    3.717518] Freeing init memory: 224K
[    6.072977] Adding 131068k swap on /var/swap.  Priority:-1 extents:1 across:131068k SS
[    6.995548] systemd-udevd[191]: starting version 204
[    7.327344] Bluetooth: Core ver 2.16
[    7.331238] NET: Registered protocol family 31
[    7.338741] Bluetooth: HCI device and connection manager initialized
[    7.344663] Bluetooth: HCI socket layer initialized
[    7.348706] Bluetooth: L2CAP socket layer initialized
[    7.352633] Bluetooth: SCO socket layer initialized
[    7.390067] Bluetooth: HCI UART driver ver 2.2
[    7.393886] Bluetooth: HCI H4 protocol initialized
[    7.398480] Bluetooth: HCI BCSP protocol initialized
[    7.402163] Bluetooth: HCILL protocol initialized
[    7.424626] Bluetooth: HCIATH3K protocol initialized
[    7.636997] Bluetooth: RFCOMM TTY layer initialized
[    7.641657] Bluetooth: RFCOMM socket layer initialized
[    7.664712] Bluetooth: RFCOMM ver 1.11
[    7.738435] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    7.747152] Bluetooth: BNEP filters: protocol multicast
[    7.799345] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[    8.026025] input: sunxi-ir as /devices/virtual/input/input1
[    8.032606] IR Initial OK
[    8.393926] 8021q: 802.1Q VLAN Support v1.8
[    8.466964] a20-tp-hwmon a20-tp-hwmon: TP initialization success
[    9.907672] sunxi_gmac: probed
[    9.913096] eth0: PHY ID 001cc915 at 0 IRQ 0 (sunxi_gmac-0:00) active
[    9.926405] eth0: PHY ID 001cc915 at 1 IRQ 0 (sunxi_gmac-0:01)
[   11.932465] PHY: sunxi_gmac-0:00 - Link is Up - 100/Full
[   15.182314] init: failsafe main process (514) killed by TERM signal
[   20.782273] eth0: no IPv6 routers present
[   21.453958] Warning: this sunxi disp driver will see significant redesign.
[   21.459310] Applications using /dev/disp directly will break.
[   21.466034] For more information visit: http://linux-sunxi.org/Sunxi_disp_driver
[   21.469124] [DISP] layer allocated: 0,101

 
What can I try to solve it?
Thank you very much for the help!
 
Andrew
 

Share this post


Link to post
Share on other sites

Thank you Igor your quick answer!

 
I apologize for my inattention, I didn't suspect, that "Documentation" button
have another function, than open the drop-down menu. So I changed the display
settings in boot.cmd and banana.bin too and tried some supported resolutions
(720p 60Hz, 720p 50Hz, 480p), but these didn't work for me.
 
I guess, my monitor hates fruits...
 
Andrew

Share this post


Link to post
Share on other sites

I have the Banana Pi M1+ too. I was able to change the boot.cmd using a ssh session (with putty). I changed the boot.cmd as follow

disp.screen0_output_mode=1280x1024p60

and then I recreate the boot.scr

mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr

After a reboot I can see the output on my monitor using a hdmi-dvi cable (my monitor doesn't have a hdmi port) at 1280x1024.

Share this post


Link to post
Share on other sites

Cheers for that matteopb, I'll give that a go tomorrow, as I'd almost given up on ever seeing output from the HDMI port.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
0