Jump to content

nand-sata-install script


zonegrise
 Share

Recommended Posts

I also tested this, while it worked for me also on K5.4.y ... USB3 key. Clean image (build from trunk), nand-sata-install, ext4 ... reboot and it boots from USB key normally. SD card has to remain ofc since it carries boot loader, rootfs is on USB3 key.

 

28 minutes ago, vzoltan said:

we are looking for a Linux issue here

 

More or less yes.

Link to comment
Share on other sites

Armbian Linux community supported weekly builds download

21 hours ago, Igor said:

I also tested this, while it worked for me also on K5.4.y ... USB3 key. Clean image (build from trunk), nand-sata-install, ext4 ... reboot and it boots from USB key normally.

 

Yes, it works perfectly with a UFD with the 5.4.x kernel, therefore this is in fact some weird USB hub handling issue.

 

I do follow a few forums / reddit on similar issues, not sure where I read, but somebody mentioned they was facing the same USB-SATA issue, but the same USB-SATA adapter worked with an active (!) USB3 hub in-between the odroid and the disk. As I don't have any at home, I wasn't able to test that part.

 

Quote

SD card has to remain ofc since it carries boot loader, rootfs is on USB3 key.

 

BTW, can you point me please to any guide how to completely move the boot files too to the SATA disk? Actually I don't need the SD at all, but I'm also quite novice with Linux / SBCs to make this work. Thanks.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...