Questions on Ayufan's Rock64 Images.

Recommended Posts

I have some questions about the Linux images that Ayufan built for the Rock64 board.  Not really technical issues so I did not think they should go on the Github page.  If this is not the appropriate place for these, let me now and I'll remove this post.  Also, if this is not the place, where should I be asking these types of questions?


I just downloaded the new PRE-RELEASE version of Debian Stretch from the Github page (Yes, I know it's bleeding edge, but just experimenting for now).  Specifically the stretch-minimal-rock64-0.6.5-152-arm64 image. I just burned it to my eMMC board.  Will boot and see how it all works tomorrow.


There are a number of other .deb packages that are on the download list.  Do I need any of them?  I am specifically talking about these:




linux-image-4.4.103-rockchip-ayufan-152_0.6.5_arm64.deb or linux-image-4.15.0-rockchip-ayufan-152-ga69162eb_arm63.deb

linux-headers-4.4.103-rockchip-ayufan-152_0.6.5_arm64.deb or  linux-headers-4.15.0-rockchip-ayufan-152-ga69162eb_arm63.deb



Thank you.


Link to post
Share on other sites
Donate and support the project!

I run these Rock64 images on a Scishion V88 Piano which has eth1 (100 Mbps) but no eth0 (1000 Mbps).

Unfortunately the 0.6.27 image disables eth1 and therefore I no longer have Ethernet on my box.

(It worked fine on earlier releases.)

How do I re-enable eth1 on my box?

And, less importantly, how do I disable eth0?


Thanks in advance.

Link to post
Share on other sites

What Igor said :-), you can also use an overlay to enable it at run-time. Ayufan just added a script to toggle existing nodes without creating an overlay for each.


The eth1 interface was disabled by default since it creates issues when there is no magjack mounted on the Rock64 for it, e.g. when you don't have the top-board with the audio DAC, this is also the usual Linux convention for boards with headers.

Link to post
Share on other sites

Thank you Igor: how stupid of me not to look in the commit messages and find that eth1 had simply been disabled in the DT.

Thank you also Xalius for the DT overlay tip: it is neat to be able to patch the DT in the running kernel.


For other users the following command re-enables eth1 at run time:

sudo enable_dtoverlay eth1 ethernet@ff550000 okay

Link to post
Share on other sites

Just curious if you got your eth1 working. Are you using the DAC board w/ ethernet jack that pine64 sells?


I tried wiring up a magjack breakout board from Sparkfun but I'm not having any luck yet. I was able to use the command you gave for enabling eth1 and it sees the device, but it is constantly resetting and doesn't show a link on my switch. I'd just like to know if it works for anybody else before I get too much further.

Link to post
Share on other sites
On 14/04/2018 at 6:34 AM, psychedup74 said:

Just curious if you got your eth1 working. Are you using the DAC board w/ ethernet jack that pine64 sells?


I don't have a real ROCK64, just a Scishion V88 Piano so the ROCK64 DAC board isn't relevant for me.


To enable eth1 during each reboot add the following command to /etc/rc.local

enable_dtoverlay eth1 ethernet@ff550000 okay


Alternatively you can do this manually each time from a shell with sudo.


In both cases you will first need to install the device-tree-compiler package.


You may also have to configure DHCP on eth1 by executing the following commands in a shell as root (sudo -s):-

# cd /etc/network/interfaces.d

# sed s/eth0/eth1/ eth0 > eth1

# reboot

(For some unknown reason "service networking restart" wasn't always sufficient for me.)

Edited by segv
Add DHCP information and clarifications
Link to post
Share on other sites
This topic is now closed to further replies.