1 1
Superkoning

Cubox-i: Ethernet not working

Recommended Posts

I installed Armbian_5.59_Cubox-i_Debian_stretch_next_4.14.66 on my Cubox-i.

 

Boots nicely, but ethernet is not working. The ethernet cable/connection is working, because the cable does work via and ethernet-to-usb connector to the same cubox. EDIT: Oh, I must say that ethernet-to-usb is fast etnernet, not GigE /EDIT

 

Dmesg included. Plus dmesg | grep network stuff.

 

Tips how to proceed?

 

root@cubox:~# cat dmesg.cubox.no-eth.txt | grep -i -e eth -e netw
[    0.793426] fec 2188000.ethernet: 2188000.ethernet supply phy not found, using dummy regulator
[    0.806213] fec 2188000.ethernet eth0: registered PHC device 0
[   10.900568] Atheros 8035 ethernet 2188000.ethernet-1:00: attached PHY driver [Atheros 8035 ethernet] (mii_bus:phy_addr=2188000.ethernet-1:00, irq=POLL)
[   10.900651] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   13.984996] fec 2188000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   13.985019] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready


 

 

dmesg.cubox.no-eth.txt

Share this post


Link to post
Share on other sites

Ah, I found a workaround:

 

root@cubox:~# ethtool -s eth0 speed 100 duplex full
root@cubox:~# 

 

... and now I have (Fast) Ethernet.

 

I yet have to find a way to make this permanent.

 

EDIT:

 

I made it permanent based on this instruction: https://www.cyberciti.biz/tips/howto-linux-add-ethtool-duplex-settings-permanent.html

... changing 

ETHTOOL="/usr/sbin/ethtool"

to

ETHTOOL="sbin/ethtool"

 

History shows:

sudo nano /etc/init.d/100Mbs
sudo chmod +x /etc/init.d/100Mbs
sudo update-rc.d 100Mbs defaults
sudo /etc/init.d/100Mbs start

with in /etc/init.d/100Mbs :

 

#!/bin/sh
ETHTOOL="/sbin/ethtool"
DEV="eth0"
SPEED="100 duplex full"
case "$1" in
start)
echo -n "Setting eth0 speed 100 duplex full...";
$ETHTOOL -s $DEV speed $SPEED;
echo " done.";;
stop)
;;
esac
exit 0

 

 

Share this post


Link to post
Share on other sites

This is weird: after a few reboots, I get above 100 Mbps speeds on my Cubox, and ethtool says the interface is at 1000 Mbps.

 

Weird,

 

$ sudo ethtool eth0
Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Supported pause frame use: Symmetric
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Full 
    Advertised pause frame use: Symmetric
    Advertised auto-negotiation: Yes
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
                                         1000baseT/Full 
    Link partner advertised pause frame use: Symmetric
    Link partner advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: d
    Wake-on: d
    Link detected: yes


 

Share this post


Link to post
Share on other sites
18 minutes ago, Igor said:

Check your network equipment. Never experienced or heard for such troubles on Cubox.

 

OK ... I've now connected the Cubox directly to my Genexis fiber router (instead of the Chinese GigE switch).

Share this post


Link to post
Share on other sites

I've a similar problem with my Cubox-i after updating to 5.60 (ARMBIAN 5.60 stable Ubuntu 18.04.1 LTS 4.14.70-cubox). The eth0 interface comes up with an ipv6 address only:

uli@cubox:~$ ifconfig eth0
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::d263:b4ff:fe00:8330  prefixlen 64  scopeid 0x20<link>
        inet6 fd97:40e:e79f:0:d263:b4ff:fe00:8330  prefixlen 64  scopeid 0x0<gl>
        ether d0:63:b4:00:83:30  txqueuelen 1000  (Ethernet)
        RX packets 22  bytes 3230 (3.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 24  bytes 3427 (3.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

Share this post


Link to post
Share on other sites
10 minutes ago, umiddelb said:

I've a similar problem with my Cubox-i after updating to 5.60 (ARMBIAN 5.60 stable Ubuntu 18.04.1 LTS 4.14.70-cubox). The eth0 interface comes up with an ipv6 address only:


uli@cubox:~$ ifconfig eth0
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::d263:b4ff:fe00:8330  prefixlen 64  scopeid 0x20<link>
        inet6 fd97:40e:e79f:0:d263:b4ff:fe00:8330  prefixlen 64  scopeid 0x0<gl>
        ether d0:63:b4:00:83:30  txqueuelen 1000  (Ethernet)
        RX packets 22  bytes 3230 (3.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 24  bytes 3427 (3.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

 

What if you issue

 

ethtool -s eth0 speed 100 duplex full

 

 

 

Share this post


Link to post
Share on other sites

 

1 hour ago, umiddelb said:

I've a similar problem with my Cubox-i after updating to 5.60 (ARMBIAN 5.60 stable Ubuntu 18.04.1 LTS 4.14.70-cubox). The eth0 interface comes up with an ipv6 address only:


Huh, than we might have some regression here. I can check this in 1-2 weeks fastest.

Share this post


Link to post
Share on other sites

I'm very new to Network Manager (which seems to be less confusing than Netplan)  ... nmtui shows two connections (which aren't present at /etc/NetworkManager/system-connections)


   ┌───────────────────────────┤ Edit Connection ├───────────────────────────┐
   │                                                                        ↑│
   │         Profile name eth0____________________________________          ▮│
   │               Device eth0 (D0:63:B4:00:83:30)________________          ▒│
   │                                                                        ▒│
   │ ═ ETHERNET                                                    <Show>   ▒│
   │                                                                        ▒│
   │ ═ IPv4 CONFIGURATION <Disabled>                               <Show>   ▒│
   │ ╤ IPv6 CONFIGURATION <Manual>                                 <Hide>   ▒│
   │ │          Addresses 0:d263:b4ff:fe00:8330/64_ <Remove>                ▒│
   │ │                    <Add...>                                          ▒│
   │ │            Gateway _________________________                         ▒│
   │ │        DNS servers <Add...>                                          ▒│
   │ │     Search domains <Add...>                                          ▒│
   │ │            Routing (No custom routes) <Edit...>                      ▒│
   │ │ [ ] Never use this network for default route                         ▒│
   │ │ [ ] Ignore automatically obtained routes                             ▒│
   │ │ [ ] Ignore automatically obtained DNS parameters                     ▒│
   │ │                                                                      ▒│
   │ │ [ ] Require IPv6 addressing for this connection                      ▒│
   │ └                                                                      ▒│
   │                                                                        ↓│
   └─────────────────────────────────────────────────────────────────────────┘

   ┌───────────────────────────┤ Edit Connection ├───────────────────────────┐
   │                                                                         │
   │         Profile name Wired connection 1______________________           │
   │               Device D0:63:B4:00:83:30 (eth0)________________           │
   │                                                                         │
   │ ═ ETHERNET                                                    <Show>    │
   │                                                                         │
   │ ═ IPv4 CONFIGURATION <Automatic>                              <Show>    │
   │ ═ IPv6 CONFIGURATION <Automatic>                              <Show>    │
   │                                                                         │
   │ [X] Automatically connect                                               │
   │ [X] Available to all users                                              │
   │                                                                         │
   │                                                           <Cancel> <OK> │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   │                                                                         │
   └─────────────────────────────────────────────────────────────────────────┘

What is supposed to be the Armbian default, where are the configuration files located? 

Share this post


Link to post
Share on other sites

Hi,

 

I've seen the same behavior on my cubox.

 

You may try this (a really ugly workaround):

   1.) create with nmtui a config ( e.g. MyNetCfg)

   2.) add this line to your crontab:

 @reboot /bin/sleep 60 && /usr/bin/nmcli connection up MyNetCfg

 A litte bit better would be a one-shot service wich starts after network.target. 

 

If anyone has a better solution: Please post it!

 

Best wishes

Paul Baumann

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1