1 1
krachlatte

Beelink GS1 Allwinner H6

Recommended Posts

Hi Guys,

 

i am owner of this box and i wanted to ask you if anyone is intressted in getting armbian running on it. Dissasambly does not look to be a big problem.

 

and here are som pictures:

 

https://forum.freaktab.com/forum/tv-player-support/allwinner-tv-players/679476-beelink-gs1-6k-tv-box-allwinner-h6-android-7-1-bt4-1-1000m-lan-usb-3-0-media-player-2gb-ram-16gb-rom

 

from the pictures i cannot tell were the uart pins are, anyone can ?

 

from user froezus post

Hi,


I have tried to boot the OrangePi One Plus image on my Beelink GS1, but either the UART is bad configured or I have damaged the TXD pin :'(.

I can't stop the U-boot nor enter a login.

 

bootlog : https://pastebin.com/Rd2EEduZ

 

I try to get some information from the 

sys_config.fex (from gs1_rv106N0.img): https://pastebin.com/TdnfRMJL

reverse dts: https://pastebin.com/jK2zhGAe

 

Everything seems correct so maybe I have damaged the TXD pin.

Do you think there is lot of work to make ethernet/ssh works one my board ?

 

Thanks,

Clement

 

he found a way to get uart output but no anwser yet were this uart pins are, it looks like we already have some device treefiels her and a bootlog.

 

anyone can help, i am here for test

 

many thanks

 

Krachlatte

 

Share this post


Link to post
Share on other sites

Hi,

 

Sorry for the delay, didn't see this post and I was quite busy with my other boards.

 

There has been many improvement on the upstream for the H6 and Cedrus is comming in 5.2. I will give it another try soon.

 

For the UART you can spot it quite easily on the corner of the board.

 

Regards,

Clement

 

 

IMG_20190319_001809.jpg

Share this post


Link to post
Share on other sites
On 11/26/2018 at 6:54 PM, krachlatte said:

Everything seems correct so maybe I have damaged the TXD pin.

Do you think there is lot of work to make ethernet/ssh works one my board ?

In Android u-boot, some providers block the ability to stop startup.

It would be interesting to see the UART log when trying to run Armbian from SD card. I am interested in whether the u-boot from eMMC is interrupted and control is transferred to u-boot from SD card or not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1