Jump to content

How to get a verbose startup with Armbian


op1tjaap
 Share

Recommended Posts

Somehow I don't get it. 

If I boot Armbian it never has a verbose startup.

I I check the script it looks like at startup there should be a /boot/.verbose file. There is....

I don't see a env variable to get this done... So I need some help.

 

Could anyone tell me how to get this done?

Link to comment
Share on other sites

Armbian Linux community supported weekly builds download

This .verbose method is present on latest builds. If you use some older images, this will not work and this part is also not upgrading - we don't upgrade boot scripts. They are fixed at image creating process.

 

Check if your boot scripts looks like this and adjust acordingly. Than .verbose method will start to work.

https://github.com/igorpecovnik/lib/blob/master/config/boot.cmd

Link to comment
Share on other sites

Both Darko and Igor reactions made me think how to solve this issue. 

Darko advised me to use a serail connection. But... I'm using one from my Ubuntu laptop! 

screen /dev/ttyUSB0 115200

So I checked boot.cmd Igor advised me. I'm using that one!

 

I thought I was clever and changed env   console=tty1 to console=ttyUSB0,115200 in boot.cmd and did a mkimage

Now my boot.scr will have this on board:

root@orangepione:/boot# diff boot.cmd boot.igor
7c7
< setenv bootargs "console=ttyUSB0,115200 root=/dev/mmcblk0p1 rootwait rootfstype=ext4 cgroup_enable=memory swapaccount=1 sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_mali_mem_reserve sunxi_fb_mem_reserve=16 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=${verbosity}"
---
> setenv bootargs "console=tty1 root=/dev/mmcblk0p1 rootwait rootfstype=ext4 cgroup_enable=memory swapaccount=1 sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_mali_mem_reserve sunxi_fb_mem_reserve=16 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 enforcing=0 loglevel=${verbosity}"

reboot again and....nothing cahnged.

 

Again no print out from my linux boot to my serail connection. see my boot:

Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
2435 bytes read in 212 ms (10.7 KiB/s)
## Executing script at 43100000
222 bytes read in 146 ms (1000 Bytes/s)
0 bytes read in 151 ms (0 Bytes/s)
15798 bytes read in 1193 ms (12.7 KiB/s)
5718032 bytes read in 722 ms (7.6 MiB/s)
Kernel image @ 0x46000000 [ 0x000000 - 0x574010 ]
## Flattened Device Tree blob at 49000000
   Booting using the fdt blob at 0x49000000
   Using Device Tree in place at 49000000, end 49006db5

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

Debian GNU/Linux stretch/sid orangepione ttyS0

orangepione login:

Special if I have an error in my kernel I won't see anything.

Any ideas? 

 

Link to comment
Share on other sites

@zador.blood.stained

 

YES!!!! That does the trick!

console=ttyS0,115200

I made a mistake by not thing from the perspective from the Orange Pi One. On my laptop is is ttyUSB0. On my Orange Pi One it is ttyS0.

 

Thank you very much. I have no monitor so I'm stuck to serail. I love this output!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...