1 1
Oscar_P

USB doesnt work with Strecht or Bionic, but fine with Wheezy

Recommended Posts

(edited)

hello everyone

 

my Orange Pi A20 does not detect any USB device with the current versions of Stretch or Bionic, but works fine with Wheezy


I had try with  a printer,  a scanner, or USB stick. When something is connected, nothing appears in dmesg or lsusb.

 

Yes...yes...I've been reading the troubleshooting FAQs and Google it for an answer.
Change power supply and SD card, etc.

But a printer or scanner doesn't consume too much power from the USB, does it?

 

in a last effort I went back to the old Debian Wheezy (downloaded from orangepi.org) and everything works fine.
 
 Any help with that?
Could it be a kernel parameter or module?

 

Edited by Oscar_P

Share this post


Link to post
Share on other sites

armbianmonitor -u   tells the reader all the details about your Installation, like Kernel-Version and much more

Share this post


Link to post
Share on other sites
18 hours ago, Oscar_P said:

Orange Pi A20 does not detect any USB device with the current versions of Stretch or Bionic


We don't support this board any more ... IIRC you only need to change DT file. Edit /boot/armbianEnv.txt and add:
 

fdtfile=sun7i-a20-orangepi.dtb

+ reboot.

18 hours ago, Oscar_P said:

I went back to the old Debian Wheezy


Rather don't use this board at all if this is your only option.

Share this post


Link to post
Share on other sites

USB ports won't work, but if I restart the computer, the light on the flash drive starts blinking and I can mount the flash drive.

I don't know how to get it working, that's where the help is needed. I can't turn the computer off and on again every time I plug a drive in

Bluestacks Kodi Lucky Patcher

Share this post


Link to post
Share on other sites
1 hour ago, Bï Ĺý said:

USB ports won't work, but if I restart the computer, the light on the flash drive starts blinking and I can mount the flash drive.

Some people faced similar behavior several months ago, but they figured that either doing "lssub -vvv" and/or plugging another USB devices first would workaround the issue, USB doing some kind of waking up.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1