Armbian build fails

Recommended Posts



I used armbian build many times to create my custom orangepipcplus images without any problem until now. It was working perfect. But, it started to fail today and couldn't build the image. To prevent any mistake, I created a new Oracle VirtualBox VM by using Bionic minimal iso and follow the steps on https://github.com/armbian/build but still no luck. It still gives same error and fails. I try to build by options "Full OS image for flashing", "Do not change the kernel configuration",  "next Mainline (@kernel.org),  "xenial Ubuntu Xenial 16.04 LTS", "Image with consol interface (server)", "Standard image with console interface" for orangepipcplus and without any userpatch. End of build log shows these errors :


  CLEAN   scripts/basic
  CLEAN   scripts/dtc
  CLEAN   scripts/kconfig
  CLEAN   scripts/mod
  CLEAN   scripts/selinux/genheaders
  CLEAN   scripts/selinux/mdp
  CLEAN   scripts
dpkg-deb: building package 'linux-headers-next-sunxi' in '../linux-headers-next-sunxi_5.97_armhf.deb'.
dpkg-deb: building package 'linux-dtb-next-sunxi' in '../linux-dtb-next-sunxi_5.97_armhf.deb'.
dpkg-deb: building package 'linux-image-next-sunxi' in '../linux-image-next-sunxi_5.97_armhf.deb'.
dpkg-buildpackage: info: binary-only upload (no source included)
dpkg-deb: building package 'linux-source-4.19.73-next-sunxi' in '/root/build/.tmp/linux-source-next-sunxi_5.97_all.deb'.
[ o.k. ] Building deb [ armbian-config ]
[ o.k. ] Checking git sources [ armbian-config master ]
[ .... ] Up to date
[ o.k. ] Merging and packaging linux firmware [ @host ]
[ o.k. ] Checking git sources [ armbian-firmware-git master ]
[ .... ] Up to date
[ o.k. ] Merging and packaging linux firmware [ @host ]
[ o.k. ] Checking git sources [ armbian-firmware-git master ]
[ .... ] Up to date
[ o.k. ] Checking git sources [ linux-firmware-git master ]
[ .... ] Up to date
[ o.k. ] Creating board support package [ orangepipcplus next ]
[ .... ] Fingerprinting
[ o.k. ] Building package [ linux-xenial-root-next-orangepipcplus ]
[ o.k. ] Building desktop package [ armbian-xenial-desktop_5.97_all ]
[ o.k. ] Starting rootfs and image building process for [ orangepipcplus xenial ]
[ o.k. ] Checking for local cache [ xenial-cli-armhf.d9c...0bf.tar.lz4 ]
[ .... ] searching on servers
[ o.k. ] ... remote not found [ Creating new rootfs cache for xenial ]
[ o.k. ] Installing base system [ Stage 1/2 ]
I: Retrieving InRelease
I: Checking Release signature
I: Valid Release signature (key id 790BC7277767219C42C86F933B4FE6ACC0B21F32)
I: Retrieving Packages
I: Validating Packages
I: Found packages in base already in required: init locales systemd tzdata
I: Resolving dependencies of required packages...
I: Resolving dependencies of base packages...
I: Found additional base dependencies: busybox-initramfs cgmanager console-setup-linux gcc-5-base gpgv initramfs-tools-bin initramfs-tools-core iproute2 iw kbd keyboard-configuration klibc-utils libapt-inst2.0 libapt-pkg5.0 libasn1-8-heimdal libbsd0 libcap-ng0 libcgmanager0 libcurl3-gnutls libdbus-1-3 libdns-export162 libestr0 libexpat1 libffi6 libglib2.0-0 libgmp10 libgnutls30 libgnutls-openssl27 libgssapi3-heimdal libgssapi-krb5-2 libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhogweed4 libhx509-5-heimdal libidn11 libisc-export160 libjson-c2 libk5crypto3 libkeyutils1 libklibc libkrb5-26-heimdal libkrb5-3 libkrb5support0 libldap-2.4-2 liblocale-gettext-perl liblz4-1 libmnl0 libnettle6 libnewt0.52 libnih1 libnih-dbus1 libnl-3-200 libnl-genl-3-200 libp11-kit0 libpopt0 libreadline6 libroken18-heimdal librtmp1 libsasl2-2 libsasl2-modules-db libslang2 libsqlite3-0 libssl1.0.0 libstdc++6 libtasn1-6 libusb-0.1-4 libwind0-heimdal openssl readline-common systemd-shim ubuntu-keyring xkb-data
I: Checking component main on http://localhost:3142/ports.ubuntu.com...
E: Couldn't find these debs: rng-tools
[ error ] ERROR in function create_rootfs_cache [ debootstrap.sh:147 ]
[ error ] Debootstrap base system first stage failed
[ o.k. ] Process terminated
[ o.k. ] Unmounting [ /root/build/.tmp/rootfs-next-orangepipcplus-xenial-no-no/ ]
[ error ] ERROR in function unmount_on_exit [ image-helpers.sh:66 ]
[ error ] debootstrap-ng was interrupted
[ o.k. ] Process terminated



It seems like about rng-tools. Can you please give some information about possible solution(s) or ideas or comments?



Share this post

Link to post
Share on other sites

Hi Igor,


Now it works like a charm as before,  after the fix. Thank you for your fast response and support.



Share this post

Link to post
Share on other sites
1 hour ago, guidol said:

I didnt know that rng-tools arent available in Xenial :(

But why buidl Xeninal, when Bionic 18.04 is also LTS? Are there any old drivers that not in Bionic?

Its my mistake. I should check that before merge ... and when you check it quickly its always something which is manifested only on some :) Like https://github.com/armbian/build/commit/ddb2202706df0bc1857888d5eecde3d64fa15b5e


Xenial is next to go out, but today. It's related to building video accelerated sunxi legacy kernel images. Almost only for that.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.