0
Colink

micro USB to UART broken

Recommended Posts

Hi all,

 

I've pre-ordered my helios4 and was so excited to finally receive my new NAS after a few months of waiting. I love this project and want to see this project to grow and maybe inspire others to create similar projects as this one.

 

That said, I was really disappointed when I finally started my board and realized that the UART to micro usb was broken when I plugged it in my computer. No USB device is at all recognized(on linux nor on my mac). At first, to eliminate any potential problems, I tried at least 6 different micro usb to usb cables thinking that a cable could be broken... it happens some time. With all 6 cables tried, never did I get my computer to detect a USB device plugged in.

 

To continue my great adventure, I soldered a 3 pin header on the UART ports of the board since I have a UART to USB cable at home. Once the pins were soldered on the board, with great excitement I booted the puppy to see if it fixed my issue. It fixed only half the issue. I now detect the USB device andI can now see all tx leaving the arm board however the rx seems to be broken. I get to the login page but can't type anything. Well that sucks. I was hoping the issue was between the UART and micro USB controller but I was wrong. Maybe the issue was with the rx all along and the UART to USB controller just don't work when either rx or tx is not working(this is just a guess). The issue is now more uphill than I thought and I won't be able to troubleshoot this on my own since I am no electronic engineer.

 

So now, I have a brand new board but with only tx working but not rx so basically I am at a loss here.

 

This looks like a manufacturing issue. Am I the only one who has this problem? This is part of batch 3 helio4.

 

Please let me know if you ever went through something similar or if you have an idea how I can fix this.

 

Any help would be appreciated and if others from the same batch has this issue, it would be great to report it rather to leave it at a loss.

 

Thanks

Edited by Colink
typo

Share this post


Link to post
Share on other sites
5 hours ago, Colink said:

This looks like a manufacturing issue.


... and have nothing to do with Armbian. Not really a common problem otherwise you would see more topics describing this problem. If UART was DOA I would suggest to work this out privately with the seller. Such things are IMO rare, but do happens.

Share this post


Link to post
Share on other sites

@Colink I think it's the first time we hear such issue. FYI the FTDI chip (USB-to-UART) is supplied through the microUSB and actually doesn't require that both RX / TX works. It's quite strange that connecting to the unpopulated UART header (J13) makes then the FTDI kinda works afterward. Each board goes through a Factory Acceptance Test (FAT) which is actually controlled by the serial console, so I'm quite surprise you have such issue, 

 

Could be a faulty connection between the SoM and the carrier board. Even though we don't recommend it because it's easy to make a mistake you could unscrew the heatsink then unplug / plug the SoM from the carrier and put back the heatsink in place.

 

Would have been easier you contact us directly by email for such issue, not very helpful to post here if it's a confirmed manufacturing issue.  Anyhow please PM me and we will see what we can do do to fix / replace your board.

Share this post


Link to post
Share on other sites

Yes thanks a lot for your quick response!!

 

I made this post public just in case anyone else from the same batch had the same issue. I guest I’m the only one at this point.

 

I will dm you :)

 

We’ll figure it out together!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0