Single Armbian image for RK + AML + AW (aarch64 ARMv8)


Recommended Posts

Armbian is a community driven open source project. Do you like to contribute your code?

balbes150 help me

 

I use Ubuntu 18.04 under VirtualBox.

I want to compile your version myself, downloaded

git clone https://github.com/150balbes/Build-Armbian

run:

/compile.sh BOARD=arm-64 BRANCH=current KERNEL_ONLY=no KERNEL_CONFIGURE=no RELEASE=focal BUILD_DESKTOP=yes

got an error

[ o.k. ] Building deb [ linux-u-boot-current-arm-64_20.09_arm64.deb ]
[ error ] ERROR in function compile_uboot [ compilation.sh:291 ]
[ error ] Building u-boot package failed
[ o.k. ] Process terminated
 

looked at /output/debug/output.log

...

Displaying message: Building deb linux-u-boot-current-arm-64_20.09_arm64.deb info
dpkg-deb: error: control directory has bad permissions 2775 (must be >=0755 and <=0775)
Displaying message: ERROR in function compile_uboot compilation.sh:291 err
Displaying message: Building u-boot package failed  err
Displaying message: Process terminated  info

 

All folders and subfolders Build-Armbian did 0755 did not help

sudo chmod -R 0755 Build-Armbian/

 

What control directory are we talking about?

 

 

Edited by iKPYT
Link to post
Share on other sites

Kindly assist with the following. 

I have a kingbox K1 plus android tv box and I would like to get linux on it. Can some help me with the correct files to use. Also do i need a sd card? If yes, what type is recommended or can i use a flash drive?

 

Please see box information below. 

 

King Box K1 Plus
Android
TV Box Chipset: Amlogic S905X Quad Core Cortex A53 - 2.0GHz - CPU: S905X Quad Core Cortex A53 Frequency: 2.0g
GPU: Mali-450 5 core GPU
Storage: 1GB DDR3 - 8GB eMMC

Power supply: DC 5 V/2 A
Power indicator (LED Power on: Blue
Main Features

Casing: Plastic (Special model with LED indicator)
OS: Android 6.0
2.4 GHz/1GB DDR3
USB Host: 2 High Speed USB 2.0, support U disk and USB HDD
OSD type of languages: German/French/Spanish/Italian/etc Multilateralen languages
LAN: Gigabit 10/100 M, Standard RJ-45

Link to post
Share on other sites
1 hour ago, InTheWings said:

I've spent more than half a day trying to boot "H96 Max X3" from sdcard. :angry:

 

I really think the Amlogic instructions section lacks a big fat warning about this. 

 

 

Sorry, the thread starter by the author has a disclaimer:
"For all. I don't support s905x3".
There are specific forums for this box and AML chip.

Link to post
Share on other sites
4 hours ago, iKPYT said:

balbes150 help me

   ...

In the last post, to build, I downloaded toolchains, in a brazen way, from dl.armbian.com like this:

cd cache/toolchains
wget -r --no-parent https://dl.armbian.com/_toolchain/*

 

Maybe that's why there was a mistake in the future.
To make sure that my xUbuntu 18.04 LTS computer is working, I have compiled an image for Odroid C2 from the main repository.

 git clone --depth 1 https://github.com/armbian/build
./compile.sh

...

[ o.k. ] Free space: [ SD card ]
Filesystem      Size  Used Avail Use% Mounted on
udev            7.8G     0  7.8G   0% /dev
tmpfs           1.6G  2.5M  1.6G   1% /run
/dev/sda4       747G  315G  394G  45% /
tmpfs           7.9G     0  7.9G   0% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           7.9G     0  7.9G   0% /sys/fs/cgroup
tmpfs           1.6G     0  1.6G   0% /run/user/1000
tmpfs            11G  2.7G  7.8G  26% /home/ikpyt/tvbox/build/.tmp/rootfs-current-odroidc2-focal-yes-no
/dev/loop0p1    3.4G  2.7G  563M  83% /home/ikpyt/tvbox/build/.tmp/mount-current-odroidc2-focal-yes-no
[ o.k. ] Writing U-boot bootloader [ /dev/loop0 ]
[ o.k. ] SHA256 calculating [ Armbian_20.11.0-trunk_Odroidc2_focal_current_5.8.8_desktop.img ]
[ warn ] GPG signing skipped - no GPG_PASS [ Armbian_20.11.0-trunk_Odroidc2_focal_current_5.8.8_desktop.img ]
[ .... ] Fingerprinting
[ o.k. ] Done building [ /home/ikpyt/tvbox/build/output/images/Armbian_20.11.0-trunk_Odroidc2_focal_current_5.8.8_desktop.img ]
[ o.k. ] Runtime [ 35 min ]
[ o.k. ] Repeat Build Options [ ./compile.sh  BOARD=odroidc2 BRANCH=current RELEASE=focal BUILD_MINIMAL=no BUILD_DESKTOP=yes KERNEL_ONLY=no KERNEL_CONFIGURE=no COMPRESS_OUTPUTIMAGE=sha,gpg,img  ]
ikpyt@xUbuntu-18:~/tvbox/build$ 

 

However, an attempt to build a version for TV-box ends in failure.

git clone https://github.com/150balbes/Build-Armbian
./compile.sh

...

[ o.k. ] Preparing [ host ]
[ o.k. ] Build host OS release [ bionic ]
[ o.k. ] Syncing clock [ host ]
[ o.k. ] Checking for external GCC compilers
[ .... ] downloading using torrent network [ gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz ]
[ error ] ERROR in function download_and_verify [ general.sh:1338 ]
[ error ] verification failed
[ o.k. ] Process terminated
 

Why doesn't this work, what am I doing wrong?

 

Link to post
Share on other sites
On 9/10/2020 at 9:48 AM, balbes150 said:

No one has tested this model, so the result is not known.

Is btrfs needed in your release? If no, could you please remove it from initramfs? I have a nasty issue, the system hangs on boot on "Scanning for Btrfs filesystems" and just dies there.

Link to post
Share on other sites
21 hours ago, iKPYT said:

I want to compile your version myself,

What for?

 

3 hours ago, Vasy said:

Is btrfs needed in your release? If no, could you please remove it from initramfs? I have a nasty issue, the system hangs on boot on "Scanning for Btrfs filesystems" and just dies there.

BTRF has nothing to do with it, this is a problem of your media (support for your hardware).

Link to post
Share on other sites
1 hour ago, balbes150 said:

What for?

To try to get the peripherals I need to work on my X92 smart TV-box:

- analog audio on 3.5mm jack in Android and LibreELEC 8.2.2.3 works
- Bluetooth + BLE it works in Android 7.1.2. In Armbian 20.02.0, it works halfway, does not catch BLE tonometer data. In Armbian 20.09.11 does not work at all.
- fix Ethernet RJ45 in Android works but not in Armbian
- try to make double clicks on the external USB tachscreen screen work while only moving the mouse pointer works, checked in Armbian 20.02.0.


I use meson-gxm-q201.dts, WiFi + Bluetooth module AP6255

Edited by iKPYT
Link to post
Share on other sites
18 hours ago, iKPYT said:

However, an attempt to build a version for TV-box ends in failure.

git clone https://github.com/150balbes/Build-Armbian
./compile.sh

 

Why doesn't this work, what am I doing wrong?

 

At the same time these post appeared, I was able to natively compile balbes150 Armbian under Focal arm-64/aarch64.  Haven't tried recently.

Top tip, make sure CCACHE isn't using slow sdcard storage. I used a H96 max x3 and pointed it to a folder in /tmp as it boots with RAM Memory: 2429544K/3535872K available.

Link to post
Share on other sites
5 minutes ago, dbsharpe said:

Top tip, make sure CCACHE isn't using slow sdcard storage. I used a H96 max x3 and pointed it to a folder in /tmp as it boots with RAM Memory: 2429544K/3535872K available.

Thank you for the information.
But I didn't get it, are you building on a TV box? I think using flash devices for multiple rewriting is not a good idea in terms of flash resource limitations.
I am building on a computer with an HDD drive

Link to post
Share on other sites
11 minutes ago, iKPYT said:

Thank you for the information.
But I didn't get it, are you building on a TV box? I think using flash devices for multiple rewriting is not a good idea in terms of flash resource limitations.
I am building on a computer with an HDD drive

Yes, I am building on a H96 max x3 TV box (AML S905X3) running Focal arm64.
You can build on a tv box running Armbian booted from sdcard but the location for storage before issuing the command git clone https://github.com/150balbes/Build-Armbian should be internal flash/EMMC/NAND, high speed external wired storage or network storage (ie from your 'computer').
About 10Gb needed. Might take half a day.

Link to post
Share on other sites

I'm running Armbian_20.09_Arm-64_focal_current_5.8.5_desktop  on a Mini M8S, wifi works fine and connecte to internet. Now, I want to share the internet connection with a STB over wired internet. I have tried the simple method by setting the properties of eth0 to "shared with other..." but that does not work. The STB needs to get an ip-address so I guess I need a dhcp server as well. I have installed it and tried to configure it according to the method described here: https://linuxconfig.org/what-is-dhcp-and-how-to-configure-dhcp-server-in-linux but I get an error when I try to start it, and I can't figure out exactly what is wrong. Can someone help?

Link to post
Share on other sites
2 hours ago, iKPYT said:

To try to get the peripherals I need to work on my X92 smart TV-box:

- analog audio on 3.5mm jack in Android and LibreELEC 8.2.2.3 works
- Bluetooth + BLE it works in Android 7.1.2. In Armbian 20.02.0, it works halfway, does not catch BLE tonometer data. In Armbian 20.09.11 does not work at all.
- fix Ethernet RJ45 in Android works but not in Armbian
- try to make double clicks on the external USB tachscreen screen work while only moving the mouse pointer works, checked in Armbian 20.02.0.


I use meson-gxm-q201.dts, WiFi + Bluetooth module AP6255

You don't have to waste time using the build environment for Armbian images.all your problems need to be solved only by modifying the kernel source code (be able to work with modifying drivers for Linux).

 

 

Link to post
Share on other sites
12 minutes ago, balbes150 said:
2 hours ago, iKPYT said:

To try to get the peripherals I need to work on my X92 smart TV-box:

- analog audio on 3.5mm jack in Android and LibreELEC 8.2.2.3 works
- Bluetooth + BLE it works in Android 7.1.2. In Armbian 20.02.0, it works halfway, does not catch BLE tonometer data. In Armbian 20.09.11 does not work at all.
- fix Ethernet RJ45 in Android works but not in Armbian
- try to make double clicks on the external USB tachscreen screen work while only moving the mouse pointer works, checked in Armbian 20.02.0.


I use meson-gxm-q201.dts, WiFi + Bluetooth module AP6255

You don't have to waste time using the build environment for Armbian images.all your problems need to be solved only by modifying the kernel source code (be able to work with modifying drivers for Linux).

 

I first need to get the source codes that are most suitable for my case, and these are the ones that you have, and only then poke around in them, look for the sources of suitable drivers, etc. I wonder why you don’t share?
By the way, I just checked the work with the touch screen in the version from 20.09.11 (Armbian_20.09_Arm-64_focal_current_5.8.5_desktop.img) so it works there the way I need it, what a pity that Bluetooth does not work!

 

 

Link to post
Share on other sites
4 hours ago, balbes150 said:

 

BTRF has nothing to do with it, this is a problem of your media (support for your hardware).

Interesting, the mmcblk devices are being detected, so there should be no reason for linux not to boot up :(

Is there a parameter I can pass in extlinux.conf to make the bootup scripts more verbose?

 

Link to post
Share on other sites
29 minutes ago, Vasy said:

Is there a parameter I can pass in extlinux.conf to make the bootup scripts more verbose?

 

Put debug at the end of the APPEND string might make initrd become more verbose.
Also the word single to use single user mode in APPEND with root=LABEL=ROOTFS  removed my be of some use.

Link to post
Share on other sites
43 minutes ago, dbsharpe said:

Put debug at the end of the APPEND string might make initrd become more verbose.
Also the word single to use single user mode in APPEND with root=LABEL=ROOTFS  removed my be of some use.

 

Thanks! Plot twist: I flashed the 1109 version and now it automagically boots past that point. balbes150 has definitely done some magic that now works :) Only 3 gigs of RAM out of 4 are detected, but will fiddle with the kernel parameters.

 

Link to post
Share on other sites
13 hours ago, iKPYT said:

To try to get the peripherals I need to work on my X92 smart TV-box:

- analog audio on 3.5mm jack in Android and LibreELEC 8.2.2.3 works
- Bluetooth + BLE it works in Android 7.1.2. In Armbian 20.02.0, it works halfway, does not catch BLE tonometer data. In Armbian 20.09.11 does not work at all.
- fix Ethernet RJ45 in Android works but not in Armbian
- try to make double clicks on the external USB tachscreen screen work while only moving the mouse pointer works, checked in Armbian 20.02.0.


I use meson-gxm-q201.dts, WiFi + Bluetooth module AP6255

I too have a X92 box. Currently using Armbian_20.08.0_Arm-64_bionic_current_5.7.0-rc7_desktop_20200531.img with meson-gxm-q201.dtb.  The focal builds since then do not support bluetooth and Glmark2 scores for focal Panfrost drivers from oibaf are wayy to low than the bionic. I guess not fully supported. I am a complete noob so in case you are able to successfully build can you please help / guide me since we have the same box.

Link to post
Share on other sites
12 hours ago, iKPYT said:

I first need to get the source codes that are most suitable for my case, and these are the ones that you have, and only then poke around in them, look for the sources of suitable drivers, etc. I wonder why you don’t share?

The kernel source codes are not related to the build system. If you don't want to read the documentation carefully, this is your personal problem. All messages with incorrect advice, after which hidden problems will start and you will start writing a bunch of other questions and problems, I delete.

Link to post
Share on other sites
16 hours ago, Reddwarf said:

I'm running Armbian_20.09_Arm-64_focal_current_5.8.5_desktop  on a Mini M8S, wifi works fine and connecte to internet. Now, I want to share the internet connection with a STB over wired internet. I have tried the simple method by setting the properties of eth0 to "shared with other..." but that does not work. The STB needs to get an ip-address so I guess I need a dhcp server as well. I have installed it and tried to configure it according to the method described here: https://linuxconfig.org/what-is-dhcp-and-how-to-configure-dhcp-server-in-linux but I get an error when I try to start it, and I can't figure out exactly what is wrong. Can someone help?

bump...

Link to post
Share on other sites

Booted up my X92 TV box with Armbian_20.09_Arm-64_bionic_current_5.8.7.img and meson-gxm-q201.dtb. Installed desktop through the armbian-config. However no sound present on HDMI. However when booting up desktop builds the sound is  activated automatically. In the instructions provided by @balbes150 in pg 1 it is mentioned 

 

For gxbb\GXL\GXM models (S905\S905X\S912), if there is no sound, you need to try running the script (gx_sound.sh)

 

sudo /root/gx_sound.sh

 

But there is no gx_sound.sh script in root. Please help.

Link to post
Share on other sites
On 9/13/2020 at 8:30 AM, AGD said:

I too have a X92 box. Currently using Armbian_20.08.0_Arm-64_bionic_current_5.7.0-rc7_desktop_20200531.img with meson-gxm-q201.dtb.  The focal builds since then do not support bluetooth and Glmark2 scores for focal Panfrost drivers from oibaf are wayy to low than the bionic. I guess not fully supported. I am a complete noob so in case you are able to successfully build can you please help / guide me since we have the same box.

Thank you very much for the hint that bluetooth works in Armbian_20.08.0_Arm-64_bionic_current_5.7.0-rc7_desktop_20200531.img with meson-gxm-q201.dtb.
I checked this version and it really works bluetooth and external USB tachscreen.
So far, this is the most suitable version for me.
does not work:
- analog audio on 3.5mm jack, you have to use the external USB sound
- Ethernet RJ45, does it work for anyone on the X92 box? Maybe I couldn't figure it out?

Link to post
Share on other sites
3 hours ago, balbes150 said:

ver 20200915 and 20200915-dev kernel 5.9.0-rc5

does work fine (console-edition) on my Sunvell T95K Pro (S912) ;)
 

    _    ____  __  __        __   _  _
   / \  |  _ \|  \/  |      / /_ | || |
  / _ \ | |_) | |\/| |_____| '_ \| || |_
 / ___ \|  _ <| |  | |_____| (_) |__   _|
/_/   \_\_| \_\_|  |_|      \___/   |_|

Welcome to Armbian 20.09 Buster with Linux 5.9.0-rc5-arm-64

No end-user support: built from trunk

package bsp-kernel[20.09] u-boot[20.09] dtb   [KhadasVim2]
firmware          [20.09] config[20.09] branch[dev]

System load:   1%               Up time:       7 min            Local users:   2
Memory usage:  8% of 1.85G      IP:            192.168.6.62
CPU temp:      57°C             Usage of /:    21% of 6.6G
                
Last login: Tue Sep 15 16:53:56 2020 from 192.168.6.17
root@sunvell-t95kpro-arm-64(192.168.6.62):~#
                

 

Link to post
Share on other sites

Armbian_20.09_Arm-64_bionic_current_5.8.7.img does not have bluetooth,

I add:

sudo apt install bluez
...
run:
sudo bluetoothctl
[bluetooth] # scan on
No default controller available
[bluetooth] # show
No default controller available

Tested on X92 (S912) with FDT = / dtb / amlogic / meson-gxm-q201.dtb


In the version Armbian_20.08.0_Arm-64_bionic_current_5.7.0-rc7_desktop_20200531.img bluetooth works!

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.