0
droid001

eSata SSD not found

Recommended Posts

I've got a CuBox i4P with an external SSD connected via eSata and has an external power supply. The 960GB SSD isn't recognised on the system:

df -aTh
Filesystem     Type         Size  Used Avail Use% Mounted on
sysfs          sysfs           0     0     0    - /sys
proc           proc            0     0     0    - /proc
udev           devtmpfs     869M     0  869M   0% /dev
devpts         devpts          0     0     0    - /dev/pts
tmpfs          tmpfs        202M  8.1M  194M   5% /run
/dev/mmcblk1p1 ext4          15G  1.2G   14G   8% /
securityfs     securityfs      0     0     0    - /sys/kernel/security
selinuxfs      selinuxfs       0     0     0    - /sys/fs/selinux
tmpfs          tmpfs       1007M     0 1007M   0% /dev/shm
tmpfs          tmpfs        5.0M  4.0K  5.0M   1% /run/lock
tmpfs          tmpfs       1007M     0 1007M   0% /sys/fs/cgroup
cgroup2        cgroup2         0     0     0    - /sys/fs/cgroup/unified
cgroup         cgroup          0     0     0    - /sys/fs/cgroup/systemd
pstore         pstore          0     0     0    - /sys/fs/pstore
bpf            bpf             0     0     0    - /sys/fs/bpf
cgroup         cgroup          0     0     0    - /sys/fs/cgroup/pids
cgroup         cgroup          0     0     0    - /sys/fs/cgroup/perf_event
cgroup         cgroup          0     0     0    - /sys/fs/cgroup/net_cls,net_prio
cgroup         cgroup          0     0     0    - /sys/fs/cgroup/cpu,cpuacct
cgroup         cgroup          0     0     0    - /sys/fs/cgroup/freezer
cgroup         cgroup          0     0     0    - /sys/fs/cgroup/memory
cgroup         cgroup          0     0     0    - /sys/fs/cgroup/cpuset
cgroup         cgroup          0     0     0    - /sys/fs/cgroup/devices
cgroup         cgroup          0     0     0    - /sys/fs/cgroup/blkio
systemd-1      -               -     -     -    - /proc/sys/fs/binfmt_misc
debugfs        debugfs         0     0     0    - /sys/kernel/debug
mqueue         mqueue          0     0     0    - /dev/mqueue
configfs       configfs        0     0     0    - /sys/kernel/config
tmpfs          tmpfs       1007M   12K 1007M   1% /tmp
/dev/mmcblk1p1 ext4          15G  1.2G   14G   8% /var/log.hdd
/dev/zram0     ext4          49M   12M   34M  26% /var/log
tracefs        -               -     -     -    - /sys/kernel/debug/tracing
tmpfs          tmpfs        202M     0  202M   0% /run/user/1000
binfmt_misc    binfmt_misc     0     0     0    - /proc/sys/fs/binfmt_misc

...and I get the following error in dmesg error:

 

   43.261482] ata1: hard resetting link
[   43.728472] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[   43.728946] ata1.00: supports DRM functions and may not be fully accessible
[   43.729942] ata1.00: Trusted Computing capability qword not valid!
[   43.730657] ata1.00: supports DRM functions and may not be fully accessible
[   43.731534] ata1.00: Trusted Computing capability qword not valid!
[   43.731571] ata1.00: configured for UDMA/133
[   43.731696] sd 0:0:0:0: [sda] tag#22 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[   43.731724] sd 0:0:0:0: [sda] tag#22 Sense Key : Illegal Request [current] 
[   43.731754] sd 0:0:0:0: [sda] tag#22 Add. Sense: Unaligned write command
[   43.731781] sd 0:0:0:0: [sda] tag#22 CDB: Read(10) 28 00 6f c8 17 20 00 00 08 00
[   43.731808] blk_update_request: I/O error, dev sda, sector 1875384096 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 0
[   43.731972] ata1: EH complete
[   74.226892] ata1.00: exception Emask 0x0 SAct 0x80000010 SErr 0x0 action 0x6 frozen
[   74.226918] ata1.00: failed command: READ FPDMA QUEUED
[   74.226956] ata1.00: cmd 60/08:20:80:17:4b/00:00:6f:00:00/40 tag 4 ncq dma 4096 in
                        res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[   74.226970] ata1.00: status: { DRDY }
[   74.226991] ata1.00: failed command: READ FPDMA QUEUED
[   74.227025] ata1.00: cmd 60/08:f8:80:17:c8/00:00:6f:00:00/40 tag 31 ncq dma 4096 in
                        res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[   74.227037] ata1.00: status: { DRDY }
[   74.227058] ata1: hard resetting link
[   84.261316] ata1: softreset failed (device not ready)
[   84.261336] ata1: hard resetting link
[   84.729328] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)

The SSD mounts with no problem on my Ubuntu laptop. The disk is formatted with GParted to ext4.

 

Futhermore I got the following error when running smartctl:
 

Pending Defects log (GP Log 0x0c) not supported

SATA Phy Event Counters (GP Log 0x11)
ID      Size     Value  Description
0x0001  4            0  Command failed due to ICRC error
0x000a  4           10  Device-to-host register FISes sent due to a COMRESET

smartctl_log

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0