Jump to content

Reboot results in poweroff on Olimex Lime2-emmc and Olimex Micro


Recommended Posts

I have had similar issues what somebody had on this forum but I cannot post reply because the topic is closed.
But I found solution. You need to downgrade u-boot with following commands.

For Olimex Micro:

apt-get install linux-u-boot-next-micro=5.60

Tested on ARMBIAN 5.60 stable Ubuntu 18.04.3 LTS 4.19.84-sunxi

For Olimex Lime2:

apt-get install linux-u-boot-lime2-emmc-next=5.30

Tested on Ubuntu Bionic with Armbian Linux 4.19.81-sunxi

Link to comment
Share on other sites

45 minutes ago, technik007_cz said:

Firstly htop show 1 cpu only with linux-u-boot-micro-default versions 5.60 and 5.38. Secondly it causes the reboot problem.

Version linux-u-boot-micro-next=5.60 which is the latest now is OK and finishes reboot completely.


I will test lime2 soon...

That is expected/known.


Download latest image and use that (old versions are not supported) unless you know exactly what you are doing. Which kernel / u-boot goes where ...

Link to comment
Share on other sites

Test of Lime2

Ubuntu Bionic with Armbian Linux 4.19.81-sunxi

linux-u-boot-lime2-next=5.90 (latest) NOK

linux-u-boot-lime2-next=5.85 NOK

linux-u-boot-lime2-default=5.90 (latest) NOK

linux-u-boot-lime2-default=5.85 NOK

linux-u-boot-lime2-current=19.11.3 NOK

linux-u-boot-lime2-emmc-next=5.31 NOK

linux-u-boot-lime2-emmc-next=5.30 NOK

linux-u-boot-lime2-emmc-next=5.25 NOK

NOK - cannot finish reboot and reset of board is necessary


Interesting results, I could not find for my setup where I am using root on nfs and custom image working u-boot.
I will do more tests but with boot image on emmc and not on microsd like in this test.
Note: the first test where linux-u-boot-lime2-emmc-next=5.30 I found working for my setup is boot image placed on emmc.

Link to comment
Share on other sites

I found working u-boot for Lime2 running on Bionic, microsdcard and kernel 4.19.81
It is:



I tried to retest u-boot for emmc board and it did not work. I did it differently than last time when I had an microsd inserted and after reinstalling of u-boot was whole microsd copied to mmc.

In this test microsd was removed and booted from emmc. After few tries, reinstalls and reboots I found message from installer saying it wrote u-boot to /dev/mmclk0. Problem is this device does not exist. Emmc module is under /dev/mmcblk1.

So I need to extract binary file from *.deb package and write it manually or return back to previous method.

Link to comment
Share on other sites

Hi I seem to have the same issue with my Olimex micro board on the latest ARMBIAN Buster build 5.4.20-sunxi.


I recently upgraded from ARMBIAN Stretch which rebooted fine. I don't know how to downgrade the u-boot version within Buster and whether this is a good fix.


Please let me know if you want me to run any tests.



Link to comment
Share on other sites

Hi, you can display installed package via command:

aptitude search u-boot | grep micro


Then you can display version of selected package:

(ending could be -current or -dev, select one from output of previous command starting with "i" - like "installed")

apt-cache policy linux-u-boot-micro-next


Then you can test different version of u-boot via command like this:

apt-get install linux-u-boot-micro-next=5.90


You testing u-boot, so always shutdown your device completely between tests and remove power cable from it.


Link to comment
Share on other sites

In my case on my Olimex micro when I run those commands it is output like this:


aptitude search u-boot | grep micro
p  linux-u-boot-micro-current - Uboot loader 2019.10
ih linux-u-boot-micro-next - Uboot loader 2018.05


apt-cache policy linux-u-boot-micro-next
  Installed: 5.60
  Candidate: 5.60
  Version table:
 *** 5.60 100
        100 /var/lib/dpkg/status


So there is the only one version available, but you can still experiment with "current" version of kernel and u-boot or you can try "current" u-boot on "next" kernel if you want experiment. For changing kernel version it is good to do it via armbian-config tool.



Link to comment
Share on other sites

Ou, great I found old script to download u-boot for my micro board. It does download, install and the u-boot version will be prevented (holded) from upgrades. So @Artenverho you are welcome to test this first before experimenting.


#  linux-u-boot-micro-next=5.60 #
apt remove linux-u-boot-micro-current -y; \
cd /tmp && wget --no-check-certificate \
&& dpkg -i linux-u-boot-next-micro_5.60_armhf.deb && \
for PACKAGE in linux-u-boot-micro-next; \
do apt-mark hold $PACKAGE; aptitude hold $PACKAGE; done

Link to comment
Share on other sites

1 hour ago, sgufa said:

Hi, did you try o attach a LiPo Battery to a Lime2 with latest uboot 2020.04 and kernel 5.4 and see if it shuts down correctly or it reboots?

With or without.

Link to comment
Share on other sites

14 hours ago, Igor said:

I made another test and for me it works properly. http://ix.io/2ocx

Hello Igor, thanks for the reply. Could you please share "/etc/modules" content and your dts if they're different from the standard build? Do you use any additional overlay file?

Link to comment
Share on other sites

4 minutes ago, Igor said:

I don't use this board - its in the automated test rig running unchanged stock Armbian. I also only have one revision of this board. We need to wait for someone else's test.

ok, thank you for the reply. Hope to get other tests. Cheers:beer:

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines