Jump to content
  • 0

Network Armbian repo inconsistencies (OPi PC)


laurentppol
 Share

Question

Hi,

I have recently installed latest (20) Armbian Desktop for OPi PC(+), have problems installing software from network repo (synaptic).

1). Small version problem with one of Qt5 libraries (dependency for Kadu - Polish communicator GG client), synaptic wants version 1u1, on the net there is version 1u3. Installed using wget + dpkg, now Kadu starts (at least) OK.

2). PostgreSQL problem: there is version 11 of PgSQL provided, OK, it's current production. BUT there is PgAdmin3(!) in repo, which works with at most version 9.6 of PgSQL (from PgAdmin site). Now there is PgAdmin4, but (I) cannot make it work (compile from source OK, but doesn't start)., there is NO PgAdmin4 in repo!

3). systemctl start postgresql.service doest NOT work, returns "Service entered failed state", "su - postgres -c 'pg_ctl_start" WORKS. I have same problem on Fedora 24 i386 on laptop, so it is not platform / system version dependent :(

 

laurent

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

Armbian is a community driven open source project. Do you like to contribute your code?

  • 0
On 2/16/2020 at 3:37 AM, lanefu said:

Armbian doens't manage those packages.. that would be upstream debian or ubuntu, dependin on what you're using.

 

try running a `sudo apt clean`  and then try again

 

 

After a small problem (manual install of http://security-cdn.debian.org/pool/updates/main/q/qtbase-opensource-src/libqt5opengl5_5.11.3+dfsg1-1+deb10u3_armhf.deb

downloaded synaptic, but then search "pgadmin" reveals ONLY pgadmin3, which is NOT compatible with PGSQL11. Please add PgAdmin4 to the repo.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...