How to fix broke boot partition on internam memory?


Recommended Posts

528/5000

Hello

Tv box: mxqpor 4k s905x 2/16 p212

I used the script to install armbian on internal memory an and works partially because tv box boot from internal memory but without sd card the system does not start

I deleted all files from the boot partition from desktop environment and now my tv box freez on amilogic logo.

i have tried to rum armbian from android recovery using ext> sdcard> aml_autostart script but i get error

cant find / misc!
sd/block/mmcblk0 to /sdcard  read only

is there a way to fix it or do i need flash firmware?

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

On 11/5/2020 at 1:42 PM, Werner said:

 

 

hello

 

now I definitely broke the box :)

 

I used gpatred from os on sd card to clean internal memory
but now i get only red light and tvbox doesn't want boot: /
I assume that it was not the best idea and I just started to get to know that the world of arm works a bit differently than a normal PC

I tried to use amilogic burning tool
after connecting the usb, I see: connected success.
but i stop on 1-2% and it throw error:
0x10103005 romcode / initialized ddr / download bufer read data item failed

I read that it may be the fault of a weak cable (I will check if I have a different cabel)

on linux I tried aml-flash-tool but when i start ./aml-flash i get Board is in secure mode

I also saw that i can short pins to bypass nand / emmc memory but I don't know which pins.
my nand / emmc chip is: samsung klmag2geac-b002

on other threads I read that after the nand memory format and need to use external programator to flash uboot?

is there a chance to do something about it?

Link to post
Share on other sites

I tried :
-many different img
-aml burning tool (1% always)
-sd card burner

 

this is output from uart to usb:

GXL:BL1:9ac50e:a1974b;FEAT:BDFC31BC;POC:3;RCY:0;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;
LOOP:1;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;
LOOP:2;EMMC:0;READ:0;CHK:AA;SD:800;USB:8;


mayby someone have img for this device?
and can tell my how to fix this?

 

board img:

https://postimg.cc/zVPmdJ8G

https://postimg.cc/142cMTbZ

 

someone use librelec forum i cant add thread or ask anybody there? 

Link to post
Share on other sites

Hi 

 

How to burn this on sdcard?

 

ok i found :) 

 

the boot-xyz.dd file should be written (after a gunzip of course) via "dd if=boot-xyz.dd of=/dev/target-disk bs=512 seek=1 skip=1 status=progress"

 

https://github.com/hexdump0815/u-boot-misc/releases/

 

 

i tried but noting hapend.

 

uart output

GXL:BL1:9ac50e:a1974b;FEAT:BDFC31BC;POC:3;RCY:0;EMMC:0;READ:0;CHK:AA;SD:0;READ:0;CHK:AA;USB:8;

LOOP:1

 

 

 

Link to post
Share on other sites

this should work actually as your boot block sees and reads from the sd card (SD:0;READ:0) ... there is one thing which might explain it: encrypted boot loader - very few boxes have it (for gxl for instance the mi box, s905x2 the a95xf2 for instance - or was it a95xf3 maybe ...) - in that case the only chance you have is trying to find some original firmware for the box with the proper signing and encryption - everything else will not work ... i think the reason why it ended up in this state is that someone installed another unsigned/not encrypted image on it ...

Link to post
Share on other sites