Jump to content

LaFrite not booting after update to 20.11

Go to solution Solved by Werner,

Recommended Posts



I fixed the following issue for my own system for now, but wanted to let you know:


After upgrading the LaFrite from Armbian Buster 20.08 to 20.11 using "apt upgrade" it didn't boot anymore. It showed a message "Ramdisk image is corrupt or invalid", so I checked /boot/uInitrd and it linked to uInitrd-5.9.6-meson64, which didn't exist.


I fixed it by downloading the latest image and replacing everything in /boot except armbianEnv.txt with what was inside the image. Afterwards it booted again. I replaced everything, because the image apperently still is on linux 5.9.6, while vmlinuz and other files on my system showed 5.9.10.


I also realized that initrd.img was missing, too.

Link to comment
Share on other sites

Hi, I just had the same issue again after updating linux-image-current-meson64 to 20.11.3 and also a while ago, when I updated to 20.11.1 (I guess I missed 20.11.2 or I'd have tried that, too). uInitrd was still linked to an old uInitrd-5.9.12-meson64, while it should have been uInitrd-5.9.14-meson64.


Both times I fixed the issue by running "update-initramfs -c -k 5.9.14-meson64" (or 5.9.12 for 20.11.1 of course).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines