OrangePi Zero2 - Allwinner H616


Werner
 Share

19 19

Recommended Posts

Donate and support the project!

Why did you break the DT then cause USB is lost? 

 

yaofei@wgz2:~$ dmesg | grep vcc
[    1.409536] sun50i-h616-pinctrl 300b000.pinctrl: supply vcc-ph not found, using dummy regulator
[    1.427370] sun50i-h616-pinctrl 300b000.pinctrl: supply vcc-pc not found, using dummy regulator
[    2.685538] usb1-vbus: supplied by vcc-5v
[    2.685953] sun50i-h616-r-pinctrl 7022000.pinctrl: supply vcc-pl not found, using dummy regulator
[    2.687760] vdd-cpu: supplied by vcc-5v
[    2.688515] dcdcb: supplied by vcc-5v
[    2.688763] vdd-gpu-sys: supplied by vcc-5v
[    2.689253] vdd-dram: supplied by vcc-5v
[    2.689798] vcc-eth-mmc: supplied by vcc-5v
[    2.690290] vcc-pl: supplied by vcc-5v
[    2.690747] vcc3v3-ext: supplied by vcc-5v
[    2.691288] vcc3v3-ext2: supplied by vcc-5v
[    2.691744] vcc1v8: supplied by vcc-5v
[    2.692482] bldo2: supplied by vcc-5v
[    2.692899] bldo3: supplied by vcc-5v
[    2.693335] bldo4: supplied by vcc-5v
[    2.693817] cldo1: supplied by vcc-5v
[    2.694325] cldo2: supplied by vcc-5v
[    2.694774] cldo3: supplied by vcc-5v
[    2.781685] usb_phy_generic usb_phy_generic.1.auto: supply vcc not found, using dummy regulator
[    2.788334] sun50i-h616-pinctrl 300b000.pinctrl: supply vcc-pf not found, using dummy regulator
[    3.524820] sun50i-h616-pinctrl 300b000.pinctrl: supply vcc-pi not found, using dummy regulator

 

Link to post
Share on other sites

On 11/18/2021 at 8:10 PM, mantouboji said:

Why did you break the DT then cause USB is lost? 

 

yaofei@wgz2:~$ dmesg | grep vcc
[    1.409536] sun50i-h616-pinctrl 300b000.pinctrl: supply vcc-ph not found, using dummy regulator
[    1.427370] sun50i-h616-pinctrl 300b000.pinctrl: supply vcc-pc not found, using dummy regulator
[    2.685538] usb1-vbus: supplied by vcc-5v
[    2.685953] sun50i-h616-r-pinctrl 7022000.pinctrl: supply vcc-pl not found, using dummy regulator
[    2.687760] vdd-cpu: supplied by vcc-5v
[    2.688515] dcdcb: supplied by vcc-5v
[    2.688763] vdd-gpu-sys: supplied by vcc-5v
[    2.689253] vdd-dram: supplied by vcc-5v
[    2.689798] vcc-eth-mmc: supplied by vcc-5v
[    2.690290] vcc-pl: supplied by vcc-5v
[    2.690747] vcc3v3-ext: supplied by vcc-5v
[    2.691288] vcc3v3-ext2: supplied by vcc-5v
[    2.691744] vcc1v8: supplied by vcc-5v
[    2.692482] bldo2: supplied by vcc-5v
[    2.692899] bldo3: supplied by vcc-5v
[    2.693335] bldo4: supplied by vcc-5v
[    2.693817] cldo1: supplied by vcc-5v
[    2.694325] cldo2: supplied by vcc-5v
[    2.694774] cldo3: supplied by vcc-5v
[    2.781685] usb_phy_generic usb_phy_generic.1.auto: supply vcc not found, using dummy regulator
[    2.788334] sun50i-h616-pinctrl 300b000.pinctrl: supply vcc-pf not found, using dummy regulator
[    3.524820] sun50i-h616-pinctrl 300b000.pinctrl: supply vcc-pi not found, using dummy regulator

 

not DTB, there are must some errors in USB driver. 

Link to post
Share on other sites

Hello! 

I know this is for H616 and things are on early stages... But I read somewhere that the H313 is the same chip as H616, so I am wondering: would the images and procedure for H616 work on a H313 board? I don't have one yet to test, but I am planning on getting and trying. Just wondering if someone else has done it.

 

Thanks and best!

Link to post
Share on other sites

@ArkhanLK - i played around with an h313 x96q box - it was working as well as a h616 box, but maybe the h313 are the lower quality ones as i was not able to reach as high cpu clocks with it like with h616 and it also got hotter - so maybe h313 are the lower quality binned versions of the h616 (similar to rk3318 vs rk3328 for rockchip)

 

best wishes - hexdump

Link to post
Share on other sites

On 12/3/2021 at 7:04 PM, hexdump said:

so maybe h313 are the lower quality binned versions of the h616 (similar to rk3318 vs rk3328 for rockchip)

Yeah, that's exactly what I have learned. But like, I have a rk3229 which can run things but it is very slow. Best performance "fix" is to have a 800x600 resolution. I am struggling to navigate on web, watch youtube at 480p is FAR from great... The mediaframework stuff is mostly to have the accelaration for Kodi, it doesn't helped that much with regular usage. On top of it, most of google stuff won't work (no google meet and google drive is pretty slow). Nor will any video chat platform really work, even if audio only. I am trying to make it into a cheap basic computer, mostly for productivity. 

Anyways, I'm hoping the H313 will be better just enough that these things won't be terrible. It can be bad, but hopefully work and it's not a trash performance. But I'm prepared for the same possible outcome, lol

 

On 12/3/2021 at 7:04 PM, hexdump said:

best wishes - hexdump

Thanks <3 

Link to post
Share on other sites

On 11/4/2021 at 4:53 PM, Jelmer said:

Hi Guys,

 

The orangepi zero2 is an amazing powerfull sbc, I'm glad everything works as expected for me on this board (docker, domoticz, deconz, pihole etc).

 

But, I have 1 strange entry (every second) in the syslog, it logs this usually about 10 to 60 times an hour.

kernel: [69795.396748] sdiohal:sdiohal_cp_sleep_wakeup entry

 

Does anyobody know what to do, I researched it but found 0 results, I do know it has something to do with my sd-card i/o ?

I'm running Armbian 21.08.3 Buster with Linux 4.9.280-sun50iw9

 

I noticed some u-boot failing to upgrade after a apt-get upgrade before it happened, probably a reinstall removes the error but i'm just curious how to handle this.

hi Jelmer,

 

Would you please tell me how you got docker working on the orangepi zero2 i cant get it to work with armbian buster. it fails at install something to do with network issues iptables im not an expert.

i tried everything i could think off but dont get it working even after fresh install armbian it wont correctly install docker.

 

thanks for helping.

 

Pim

Link to post
Share on other sites

hi guys, 

 

this morning after upgrading the uboot image to (22.02.0-trunk.0005)

 

=> boot
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
2612 bytes read in 3 ms (849.6 KiB/s)
## Executing script at 4fc00000
U-boot loaded from SD
Boot script loaded from mmc
180 bytes read in 3 ms (58.6 KiB/s)
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
12373835 bytes read in 518 ms (22.8 MiB/s)
Failed to load '/boot/uImage'
Wrong Image Format for bootm command
ERROR: can't get kernel image!
SCRIPT FAILED: continuing...
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
BootOrder not defined
EFI boot manager: Cannot load any image
BOOTP broadcast 1
BOOTP broadcast 2
DHCP client bound to address 192.168.x.yz (1901 ms)
*** ERROR: `serverip' not set
Cannot autoload with TFTPGET
missing environment variable: pxeuuid
Retrieving file: pxelinux.cfg/01-02-00-15-7f-b0-f4
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A80837
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A8083
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A808
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A80
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A8
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/default-arm-sunxi-sunxi
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/default-arm-sunxi
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/default-arm
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/default
*** ERROR: `serverip' not set
Config file not found

 

 

any idea on how to fix this ?

 

many thanks and best regards

Link to post
Share on other sites

vor 5 Stunden schrieb krachlatte:

hi guys, 

 

this morning after upgrading the uboot image to (22.02.0-trunk.0005)

 

=> boot
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
2612 bytes read in 3 ms (849.6 KiB/s)
## Executing script at 4fc00000
U-boot loaded from SD
Boot script loaded from mmc
180 bytes read in 3 ms (58.6 KiB/s)
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
No FDT memory address configured. Please configure
the FDT address via "fdt addr <address>" command.
Aborting!
12373835 bytes read in 518 ms (22.8 MiB/s)
Failed to load '/boot/uImage'
Wrong Image Format for bootm command
ERROR: can't get kernel image!
SCRIPT FAILED: continuing...
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
BootOrder not defined
EFI boot manager: Cannot load any image
BOOTP broadcast 1
BOOTP broadcast 2
DHCP client bound to address 192.168.x.yz (1901 ms)
*** ERROR: `serverip' not set
Cannot autoload with TFTPGET
missing environment variable: pxeuuid
Retrieving file: pxelinux.cfg/01-02-00-15-7f-b0-f4
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A80837
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A8083
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A808
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A80
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A8
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0A
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C0
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/C
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/default-arm-sunxi-sunxi
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/default-arm-sunxi
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/default-arm
*** ERROR: `serverip' not set
Retrieving file: pxelinux.cfg/default
*** ERROR: `serverip' not set
Config file not found

 

 

any idea on how to fix this ?

 

many thanks and best regards

 

ther was a chane in the boot.cmd file booti has changed from booti to bootm

 

bootm ${kernel_addr_r} ${ramdisk_addr_r} ${fdt_addr_r}

 

booti ${kernel_addr_r} ${ramdisk_addr_r} ${fdt_addr_r}

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

19 19