Is Odroid HC4 Focal 5.9 image ok?


Go to solution Solved by Igor,

Recommended Posts

Hi,

is there a way, how to check that image in download section is ok?

 

I have Odroid HC4 with good PSU, both old and new card, flashed by Etcher and Rufus, keyboard plugged in USB, no SATA disks at the moment.
I'm able to boot Focal 4.9 kernel (however with some errors after the boot). I've removed Petitboot with flasherase first, I've checked SHA checksum.

 

Edit: File I've downloaded is: Armbian_20.11.6_Odroidhc4_focal_current_5.9.14.img.xz

SHA: 9930f984eca2a72b3c22953ee6381c95da528b2a355dd9f429da38d1409f7b1f *Armbian_2


Any ideas what is wrong?

Thank you.

 

hc4.jpg

Edited by Dezo
Link to post
Share on other sites
  • Dezo changed the title to Is Odroid HC4 Focal 5.9 image ok?
Donate and support the project!

  • Solution
13 minutes ago, Dezo said:

is there a way, how to check that image in download section is ok?


First you need to tell us filename of that image so we can verify.

 

Also there is an archive in the bottom of the download pages - checking previous build is also one of the options. This was added on last minute:
https://github.com/armbian/build/commit/ab9faf847affd34cd8c0a1e867e93c2edbb5f8e8

Link to post
Share on other sites
2 hours ago, Igor said:

so we can verify.


Now the problem is that my only C4 is racked for CI tests and can't do much ... previous images are known to work. Try them - and it would be good to know if upgrade also gets your here.

 

It looks like this is the problem:
 

diff --git a/config/bootscripts/boot-meson64.cmd b/config/bootscripts/boot-meson64.cmd
index c191762a6..46b8b4ce7 100644
--- a/config/bootscripts/boot-meson64.cmd
+++ b/config/bootscripts/boot-meson64.cmd
@@ -2,9 +2,10 @@
 #
 # Please edit /boot/armbianEnv.txt to set supported parameters
 #
-setenv load_addr "0x34000000"
-setenv initrd_high "0xffffffff"
-setenv fdt_high "0xffffffff"
+
+setenv load_addr "0x32000000"
+setenv kernel_addr_r "0x34000000"
+setenv fdt_addr_r "0x4080000"
 setenv overlay_error "false"
 # default values
 setenv rootdev "/dev/mmcblk1p1"

 

Link to post
Share on other sites

I also got my Odroid HC4. Doing my first tests. USB seems very buggy with the Ubuntu Mate 20.04 from Odroid.
This seems better with Armbian focal legacy desktop. Tho there no sata is found, while that does work with the Odroid HC4 Mate image.
I'll try a lot more images to see if/what difference there is.
Haven't checked any mainline yet.

It does seem to have performance issue's when overclocked(2Ghz/2.1Ghz). It sometimes performs worse than with default clocks. Weird.
I'm a bit surprised about how good it is for gaming.
I like it a lot, but it did cost me a lot. Tho also bit my own fault.
I first bought it from AmeriDroid. It was stuck in transit for a +month. So I got my money back and bought another at a Belgian seller. A lot more expensive. A day after I got my HC4 from the Belgian seller the one from AmeriDroid arrived. If only I had waited a few more days I'd have saved about 40euro. Buying from Hardkernel would have been even more cheap I'd guess.
I may send it back to AmeriDroid without fees. Luckily. I really wanted a HC4, but 2 is too much :)

Link to post
Share on other sites
4 hours ago, Werner said:

Or donate it to the lab :D

If it was a cheaper board I'd do that. This is one of the most expensive I've bought. PSU is also a 15V 60W brick. Adds to the cost.
I rather save my money to buy an Odroid Go Super next month. I never wanted a handheld so much, except when the Gameboy came out maybe.
HC4 also suddenly became a gaming rig with 500GB of retro games on HDD. Too many games, I can't find the ones I want since thousands to browse thru.

Link to post
Share on other sites
2 hours ago, Igor said:

Can you try legacy image by switching to nightly and update - if SATA works now?

No luck. Focal legacy in nightly and updated/rebooted. No sata devices. Let me know if you need something more tested.
It's good to know that USB works perfectly in Armbian. So I know it's a Hardkernels Ubuntu mate problem.
 

Link to post
Share on other sites
1 minute ago, Igor said:

if you can, build from sources.

ok. Does it matter what image it is? Since I already got a working focal legacy image I can as well build a bionic or buster. I'll boot my pc for it. Haven't gotten to installing balbes image to my N2+ to build on that. 

Link to post
Share on other sites

@IgorI've just been able to build armbian focal legacy for the HC4. Still no sata devices.

I had Murphy on my side for very long. Used my pc cause I thought it would be faster. Was months ago that I used it to build an image. So my build environment was still Bionic. Installed focal in virtualbox. Build the image. When finished I was unable to mount my USB sdreader.
And suddenly Windows10 crashed. Rebooted, started the virtual focal again... and again windows crashed...
I thought, now I'm sick of this. Let's take the trusty RockPiX. I let it run in the night. I got up..., no space left on eMMC to finish the build. I then took an external ssd. Started the build. Suddenly also no space left from +200GB. It had double mounted the drive. Both mounts showed the same files. One without space, the other with space. So I rebooted... And I couldn't log into my RockPiX anymore. Cycled back to login screen after login.
So I put the ssd in my pc and installed focal directly onto it... And my bios didn't want any of it. I can only manually choose to boot my installed focal ssd.
I did finally manage to build the image and write it to sd. It only took me about 19 hours to have a working build. :D

Kernel 4.9.250-meson64. Fully updated. Latest available kernel. Also switched to nightly. Then armbian-config, armbian-firmware and armbian-zsh are updated. Nothing more.
Now building Focal mainline. I have not yet tried any mainline image on the HC4.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...