Mini m8s ii S905x NAND deleted? Help needed please.


Recommended Posts

Hello to all.

 

I need some help please.

I was experimenting between Libreelec and Coreelec images on sd for many years now and somehow i must have deleted the partitions of the NAND. So the device doesn't boot from NAND. I get a bootloop like this: GXL:BL1:9ac50e:a1974b;FEAT:ADFC318C;POC:3;RCY:0;EMMC:0;READ:0;CHK:AA;SD:0;READ:0;0.0;CHK:0;

 

The bootloader and partitions may have been deleted somehow. Booting from SD still works.

I booted Libreelec and tried installtointernal but i got:

One of BOOT, SYTEM, DATA or DTB partitions is missing. Make sure that you are using a correct device tree and a device with internal memory!

I think i have tried all simple recovery options. I tried with burn card maker and other card makers. I also tried AML burn tool with "update_MINIM8SII_rv112_megabox_20170320.img" and i get at 9% 0x30405004 UBOOT/Partition boot/Verify partition/Error result.

 

Below you can check the ssh and serial logs:

ssh log

serial log

 

My experience with Linux and embedded devices is basic. Can you help me make the NAND functional again?

 

Thanks!

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

@isidoros First please read the TV Box Club FAQ item: https://forum.armbian.com/topic/16976-status-of-armbian-on-tv-boxes-please-read-first

(short version is that TV boxes are unsupported by Armbian, amlogic bases ones even less so).

 

Second you mention coreelec and libreelce but not armbian in your post.  From what I can tell in your logs you aren't running armbian at all.  Thus you should be posting for help in a libreelec or coreelec forum as we can't support their software.

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.