Jump to content
  • 0

[Invalid] - New OrangePi 4 (not B), no image at HDMI



Hi there,

Just got OPi4 after some problem from Chineses...


- no at all output at HDMI (connected to HDMI-VGA converter and 1920x1024 VGA LCD display, works with OPi PC+),

- if Eth connected device gots (after few minutes) IP from DHCP.

- no server running on that IP (tried telnet, ssg, WWW), PING works.

uSD card with Armbian Buster for OPi4.


What to check next? Console? What speed? 115200 or 1.500.000?

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Ok, found solution:

- restarted from scratch (*.img file -> uSD),

- connected "real HDMI" (some overscan) TV, keyboard,

- gone trough initial config (root passwd, "normal" user),

- configured WiFi (had no wired Eth at my neighbour) using nmtui,

- now SSH works in both directions.


So conclusion is: the problem was / is (still no video on VGA) with cheap HDMI->VGA converter.

Link to comment
Share on other sites

Donate and support the project!

  • 0

Your issue report is not a valid bug report per the Armbian bug reporting instructions (https://www.armbian.com/bugs).  With limited resources the Armbian project is only able to spend time on issues where all the requested information has been provided and for only the boards/images/software that are supported.  Your report is invalid for one or more of the following reasons (non-exhaustive list):


  • it is for an unsupported board or image (CSC/EOS/WIP/edge)
  • it is for software that is not supported (such as userspace modules installed on top of the core operating system)
  • it has been logged in the wrong forum (for example requests for help that are not actual bug reports)
  • it lacks requested data (armbianmonitor output)
  • it could have been easily solved by a quick search and/or reading documentation


Please review what you have submitted and the bug logging instructions (https://www.armbian.com/bugs) and either add the required information or open a new topic in the correct forum (such as Common issues / peer to peer technical support or General chit chat)

Link to comment
Share on other sites

  • 0

Depending on how to interpret things:

- board does not start -> topic in wrong place and no logs via UART provided

- board does start (indicated by mentioned dhcp lease aquired) connecting via SSH should be possible. If not line above.


btw. RK is 1,5Mbaud

Link to comment
Share on other sites

  • 0

OK, got it connected to "real HDMI", see attached picture.

Looks it is starting, NMAP shows SSH port open (the only), but system refuses SSH connection (as no root password has been set?)

ssh root@
Connection reset by port 22



What should I do next? Connect to console or there is another (easier) way?


Red LED is solid, Green flashes fast 2 times, then some space, and again.

Link to comment
Share on other sites

  • 0

Logged as root using HDMI TV / usb keyboard, changed password, but stuck at new user creation stage, as there are too restrictive rules for password (used CRTL-C). Then useradd / passwd.


Now I still get "connection reset by xx.xx.xx.xx port 22.


1). How to login on device by net?,

2). How to resume initial Armbian setup process once logged?

on my other PIs I had no problem with this initial setup and got to GUI w/o problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...