10 10
tkaiser

Armbian running on Pine64 (and other A64/H5 devices)

Recommended Posts

i'm having problems with video playback after a not-so-recent (i think i did it in october) upgrade.

before that, all video would look normal, and most video would playback with only minimal framedrop.

 

now, most only display like this.
this is with mpv, and its output is something like this - looks ok to me???
but the problems are abundant with all video formats and media players (mplayer too, and i spent a good while playing with VLC's settings).

 

i tried:

 

downgrading kernel back to 3.10.105 version == downgrading packages linux*pine* to version 5.31.
it helped a little - i was able to watch a few very old & lo-res episodes.

 

then i found this: Video playing will break on sunxi legacy unless adding cma=96M to kernel boot parameter, so i undid the downgrade and added that option to /boot/boot.cmd & recompiled, after which i could see those 96M in 'dmesg|grep -i cma' (was 64M before).
but it did not help at all, the situation was just as bad as before the kernel downgrade!

 

what to do?

Share this post


Link to post
Share on other sites

Should I worry if A64 reaches 80°C ?

 

got this readout while copying files beween two USB-attached disks (OPI Win, Ubuntu legacy kernel):


Time        CPU    load %cpu %sys %usr %nice %io %irq   CPU   PMIC  C.St.
22:13:57: 1152MHz  5.86  53%  16%   7%   0%  29%   0%   79°C   69°C  0/9
22:14:02: 1104MHz  5.87  60%  15%   8%   0%  35%   0%   79°C   69°C  1/9
22:14:07: 1152MHz  6.12  54%  14%   9%   0%  28%   1%   80°C   68°C  0/9
22:14:12: 1152MHz  6.11  47%  11%   5%   0%  29%   0%   77°C   68°C  0/9

 

When it's idle, temp goes down to 56°C @ 480 MHz

 

I already equipped the A64 chip with a heatsink.

 

USB througput is nice though.

Share this post


Link to post
Share on other sites

Hi,

 

I'm using Orange Pi Win which is also based on A64

Armbian 5.38 / kernel 3.10.107-pine64 is installed

 

So, about the 1GbE : I read there's now a solution at the firmware level, but 1GbE is still not working for me.

My current work around is to set ethernet at 100Mbps with ethtool...

before:

root@orangepiwin:/home/fr3d# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: on
        Link detected: yes

=> even if the links is reported Up with 1000Mbps speed, it isn't working (get some replies for ping, but cannot be used for ssh or any other network usage...)

 

For setting the speed to 100Mbps, autoneg need to be set off first:

root@orangepiwin:/home/fr3d# ethtool -s eth0 autoneg off
root@orangepiwin:/home/fr3d# ethtool -s eth0 speed 100

control:

root@orangepiwin:/home/fr3d# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full 
                                100baseT/Half 100baseT/Full 
                                1000baseT/Half 1000baseT/Full 
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: off
        Link detected: yes

 

Hope this workaround can help...

Share this post


Link to post
Share on other sites

Hi , i have Pine64 2Gb with Armbian installed . There are a possibility to get working 1.2Ghz & 1.34Ghz speed ? I did in other image without problem but not in this . I placed the heatsink on CPU

Share this post


Link to post
Share on other sites

Hello,

Ethernet did not for me out of the box for Pine64 A64-DB-V1.1 2G board for mainline. DTS fix with "allwinner,tx-delay-ps" made it work 

 

root@pine64:~# cat /etc/armbian-release
# PLEASE DO NOT EDIT THIS FILE
BOARD=pine64
BOARD_NAME="Pine64"
BOARDFAMILY=sun50iw1
VERSION=5.83
LINUXFAMILY=sunxi64
BRANCH=next
ARCH=arm64
IMAGE_TYPE=stable
BOARD_TYPE=conf
INITRD_ARCH=arm64
KERNEL_IMAGE_TYPE=Image 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
10 10