Ralink RT5370 OPi PC


Recommended Posts

I can't get this dongle to work with 5.20.

$ lsusb
Bus 002 Device 002: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

Seems to be known one.

$ lsmod
Module                  Size  Used by
rt2800usb              13858  0 
rt2800lib              42835  1 rt2800usb
rt2x00usb               8227  1 rt2800usb
rt2x00lib              34544  3 rt2x00usb,rt2800lib,rt2800usb
mac80211              363732  3 rt2x00lib,rt2x00usb,rt2800lib
mali                  185786  5 
ump                    30408  1 mali
mali_drm                2728  0 
drm                   178585  1 mali_drm

Nothing wrong here? I guess so, wpa_supplicant is properly configured (ssid & psk), appropriate entry in /etc/network/interfaces but I still get

wlan0     Link encap:Ethernet  HWaddr 24:3c:20:0d:7a:46  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2932 (2.8 KiB)  TX bytes:2820 (2.7 KiB)

So the interface is up but not configured.

 

/etc/network/interfaces:

# Wireless adapter #1
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

/etc/wpa_supplicant/wpa_supplicant.conf:

ap_scan=1
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
	ssid="myssid"
	psk=keyhash
	key_mgmt=WPA-PSK
}

syslog is flooded with messages like:

Sep 29 10:07:59 localhost NetworkManager[602]: <error> [1475136479.267512] [supplicant-manager/nm-supplicant-interface.c:856] interface_add_cb(): (wlan0): error adding interface: wpa_supplicant couldn't grab this interface.
Sep 29 10:07:59 localhost NetworkManager[602]: <info> (wlan0): supplicant interface state: starting -> down
Sep 29 10:07:59 localhost wpa_supplicant[783]: ctrl_iface exists and seems to be in use - cannot override it
Sep 29 10:07:59 localhost wpa_supplicant[783]: Delete '/run/wpa_supplicant/wlan0' manually if it is not used anymore
Sep 29 10:07:59 localhost wpa_supplicant[783]: Failed to initialize control interface '/run/wpa_supplicant'.#012You may have another wpa_supplicant process already running or the file was#012left by an unclean termination of wpa_supplicant in which case you will need#012to manually remove this file before starting wpa_supplicant again.

I must be missing something obvious, any hints?

 

EDIT: it's 5.20.

Link to post
Share on other sites
Donate and support the project!

Tried to install firmware-ralink but:

$ sudo apt install firmware-ralink
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  firmware-ralink
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 22,2 kB of archives.
After this operation, 103 kB of additional disk space will be used.
Get:1 http://httpredir.debian.org/debian/ jessie/non-free firmware-ralink all 0.43 [22,2 kB]
Fetched 22,2 kB in 0s (31,0 kB/s)         
Selecting previously unselected package firmware-ralink.
(Reading database ... 155356 files and directories currently installed.)
Preparing to unpack .../firmware-ralink_0.43_all.deb ...
Unpacking firmware-ralink (0.43) ...
dpkg: error processing archive /var/cache/apt/archives/firmware-ralink_0.43_all.deb (--unpack):
 trying to overwrite '/lib/firmware/rt3290.bin', which is also in package armbian-firmware 5.20
Errors were encountered while processing:
 /var/cache/apt/archives/firmware-ralink_0.43_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Link to post
Share on other sites

Dongle works almost oob on fresh 5.20 install so this must be related to my broken instance.

The same happened to me, when i upgrade to 5.20 from older version. I had firmware-ralink_0.43_all.deb installed on older version and it conflict with armbian-firmware 5.20 during upgrade, so i think i uninstalled debian package and installed armbian-firmware 5.20 again. But after that my dongle stop working no mater if i force install firmware-ralink_0.43_all.deb again. I forgot about this, because i tried this on self-built Armbian Xenial and thought distribution cause troubles. On fresh 5.20 it worked to me too.

Link to post
Share on other sites

Back on this again. This is what I have in dmesg. If I'm reading this correctly, interface connects to AP and authenticates succesfully. Yet still it does not seem available?

[    9.088127] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   10.939428] wlan0: authenticate with 04:8d:38:c3:5a:24
[   10.985502] wlan0: send auth to 04:8d:38:c3:5a:24 (try 1/3)
[   10.987038] wlan0: authenticated
[   11.020072] wlan0: associate with 04:8d:38:c3:5a:24 (try 1/3)
[   11.023916] wlan0: RX AssocResp from 04:8d:38:c3:5a:24 (capab=0x411 status=0 aid=4)
[   11.057886] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   11.058163] wlan0: associated
[   12.770284] PHY: gmac0-0:00 - Link is Up - 100/Full
[   18.830038] eth0: no IPv6 routers present
[   21.730038] wlan0: no IPv6 routers present
[   31.873128] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

And

$ iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:"destroyer9001"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 04:8D:38:C3:5A:24   
          Bit Rate=30 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=69/70  Signal level=-41 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:253   Missed beacon:0

WAT?!

Link to post
Share on other sites
Guest
This topic is now closed to further replies.