71 71
balbes150

ARMBIAN for Amlogic S905 and S905X (ver 5.44 =<)

Recommended Posts

Thanks, i will compile it under my Mini M8S with Armbian_5.21_Amlogic-s905x_Debian_jessie_3.14.29_desktop_20161017.img.xz

i hope i can download it from Yadi.sk , my internet connection is not so good to download from Yadi.sk

 

When assembling the images, the system generates deb packages with kernel headers and other. Their size is not large. If you want, I can upload them to the website. And you will be able to easily download them to install into an existing system. But I warn you that I this option is not checked and how it works I do not know. Not the fact that it will, but there is a risk that when you update it can overwrite u-boot and have to restore it. You can try to remove the packages from u-boot, do they not fire when you update the kernel and check the update scripts of the kernel (where the generated initrd, etc.).

Share this post


Link to post
Share on other sites

So there is no OpenGL ES support?

Now used frambufer. To assemble the modules mali - not difficult (it's planned for next versions).

 

By the way, checked at - sound on Tronsmart Telos S905 works out of the box. Gigabit wired network, also climbed out of the box. In filemanager immediately available to all home network resources in a couple of clicks of the mouse opened the necessary resources and launched the audio. Sound works. Video is a slide show. It's okay, because no special additional patches and drivers mali I yet did not put. As miniPC is working fine. For me the main thing now works off and on with the remote buttons, no need to pull the power cord. Now i can do a debug install to the internal memory.

Share this post


Link to post
Share on other sites

When assembling the images, the system generates deb packages with kernel headers and other. Their size is not large. If you want, I can upload them to the website. And you will be able to easily download them to install into an existing system. But I warn you that I this option is not checked and how it works I do not know. Not the fact that it will, but there is a risk that when you update it can overwrite u-boot and have to restore it. You can try to remove the packages from u-boot, do they not fire when you update the kernel and check the update scripts of the kernel (where the generated initrd, etc.).

Thanks for the reply, please upload kernel headers because i have previous Armbian, i will try to make it work.

 

i have knowledge to Un Brick my Mini M8S, so i will take the risk.

Share this post


Link to post
Share on other sites
(edited)

Thanks for the reply, please upload kernel headers because i have previous Armbian, i will try to make it work.

 

i have knowledge to Un Brick my Mini M8S, so i will take the risk.

Upload

 

https://yadi.sk/d/DXftuWpXx4zNt

 

 

 

@balbes150

I successfully boot from your image on S912.

http://forum.armbian.com/index.php/topic/2138-armbian-for-amlogic-s912/?p=17682

 

I'd like to enable OpenGL ES support and H/W decoding on S912.

Can you describe how to assemble the modules mali?

 

And Do you have plan to build any method to boot internal android?

LibreElec can boot internal android on power button menu.

 

If You used booldroot , you can try to compile the kernel and modules with support for mali (to go to booldroot folder and then give the make command menucobfig, mark the desired option and collect). Or download the source code and once in the system S912 to assemble and install. For use restarting the internal firmware, you can use the finalize script s912_autoscript (add check) and an extra script (on the desktop that will install any variable in u-boot, or create a file dummy in BOOT FAT). An example script can be found here.

 

https://github.com/150balbes/LibreELEC.tv/blob/Amlogic-S905-kszaq/projects/S905/install/s905_autoscript.src

 

https://github.com/150balbes/LibreELEC.tv/blob/Amlogic-S905-kszaq/projects/S905/filesystem/usr/sbin/rebootfromnand

 

 

To S905X

 

As it turned out, during the actual test, S905X works fine run from a USB flash drive. Ie S905X system can be used with SD card and USB flash drive.

Edited by balbes150

Share this post


Link to post
Share on other sites

Upload

 

https://yadi.sk/d/DXftuWpXx4zNt

 

 

 

 

If You used booldroot , you can try to compile the kernel and modules with support for mali (to go to booldroot folder and then give the make command menucobfig, mark the desired option and collect). Or download the source code and once in the system S912 to assemble and install. For use restarting the internal firmware, you can use the finalize script s912_autoscript (add check) and an extra script (on the desktop that will install any variable in u-boot, or create a file dummy in BOOT FAT). An example script can be found here.

 

https://github.com/150balbes/LibreELEC.tv/blob/Amlogic-S905-kszaq/projects/S905/install/s905_autoscript.src

 

https://github.com/150balbes/LibreELEC.tv/blob/Amlogic-S905-kszaq/projects/S905/filesystem/usr/sbin/rebootfromnand

 

 

To S905X

 

As it turned out, during the actual test, S905X works fine run from a USB flash drive. Ie S905X system can be used with SD card and USB flash drive.

Lots of tainted messages during boot on mini m8s. And lan isnt wotking.

Share this post


Link to post
Share on other sites

Lots of tainted messages during boot on mini m8s. And lan isnt wotking.

Do you have Mini M8S with S905 ( not S905x ) ?

If you have it, i want to ask about sound card and wifi, it work or not?

Share this post


Link to post
Share on other sites

Do you have Mini M8S with S905 ( not S905x ) ?

If you have it, i want to ask about sound card and wifi, it work or not?

AS i looked where is no 8723bs driver. Sound not tested, but kernel sees m8 sound device.

Share this post


Link to post
Share on other sites

Lots of tainted messages during boot on mini m8s. And lan isnt wotking.

 

What is the chip in the TV box S905 or S905X ? What media - SD card or USB flash drive ? If a large number of messages about write error\reading is usually associated with a bad map (a lot of badly readable sectors, not a steady reading).

Share this post


Link to post
Share on other sites

AS i looked where is no 8723bs driver. Sound not tested, but kernel sees m8 sound device.

 

Thanks for the info.

Fyi, If you want to compile wifi driver, you can get it from kernel source libreelec ( linux-bca261f.tar.gz )

Share this post


Link to post
Share on other sites

I'm a little bit lost with the installations process.

 

I have a S905X device that boots fine from USB using LibreELEC.

 

I'm trying to do the same with ARMBian using Armbian_5.21_Amlogic-s905x_Debian_jessie_3.14.29_20161018.img

 

After

sudo dd bs=1M if=Armbian_5.21_Amlogic-s905x_Debian_jessie_3.14.29_20161018.img of=/dev/sdb
I have plugged the USB on the USB1 port, but not boot. I can't see and message, just the android boot.
 
I miss some step?
 

Share this post


Link to post
Share on other sites

 

I'm a little bit lost with the installations process.

 

I have a S905X device that boots fine from USB using LibreELEC.

 

I'm trying to do the same with ARMBian using Armbian_5.21_Amlogic-s905x_Debian_jessie_3.14.29_20161018.img

 

After

sudo dd bs=1M if=Armbian_5.21_Amlogic-s905x_Debian_jessie_3.14.29_20161018.img of=/dev/sdb
I have plugged the USB on the USB1 port, but not boot. I can't see and message, just the android boot.
 
I miss some step?

 

 

You need to update the multiboot. Multiboot, which is used in the LE, not able to work with other systems (it is designed solely to run LE).

 

Required to update multi-boot files are already there in the composition of the images Armbian version 2.21.

Share this post


Link to post
Share on other sites

thanks... sound card is detected and vpu too... but no gpu....

and i dont see mali fbdev in boot log...

And lan isnt working too.

Share this post


Link to post
Share on other sites

Any change to install kodi on top of this image?

 

I have tested

deb http://oph.mdrjr.net/odrobian/ jessie s905

But the repo is very old and kodi not boot, some isue with mali-fbdev:arm64

 

And

deb http://httpredir.debian.org/debian jessie-backports main contrib non-free

 

But use XORG and I can't get hardware acceleration.

 

Also

 

deb http://deb.odroid.in/c2/ xenial main

But has version issues

root@amlogic-s905x:/# apt-get install kodi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 kodi : Depends: kodi-bin (>= 16.1+hk2ubuntu7) but it is not going to be installed
        Depends: kodi-bin (< 16.1+hk2ubuntu7.1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any other repository with a working copy of KODI?

Share this post


Link to post
Share on other sites
(edited)

Uploaded the new images Armbian (20161021). In these images added support for launch images stored on USB drives, on the platform S905.

 

 

 

Deb packages with the kernel and other elements, you can take here.

 

https://yadi.sk/d/DXftuWpXx4zNt

Edited by balbes150

Share this post


Link to post
Share on other sites

@balbes150

I tested Armbian (20161021) today.

Debian is OK.

Ubuntu showed broken screen after reboot.

During the initial setup, Screen was OK.

 

Firefox still doesn't start.

Is there any browser I can use? 

Share this post


Link to post
Share on other sites

I've found firefox arm64 had problem.

So I enabled armhf arch and install 32bit firefox which works fine.

 

apt-get remove firefox-esr
dpkg --add-architecture armhf
apt-get update
apt-get install -y firefox-esr:armhf
 
It's hard to find OPENGL ES enable method.

Share this post


Link to post
Share on other sites

I checked the behavior of the latest image of Ubuntu. Yes, there is such a problem. The cause is not yet found. Found another oddity in Debian. When you first launch the desktop, the color scheme normal in the terminal normally displays the text. After reloading, for not obvious reasons, flies the colors. I have the feeling that ceases to be perceived a given parameter 24 in the script start and system\kernel stubbornly uses 32.  There is speculation - changed the graphics-related packages in the network reach.

Share this post


Link to post
Share on other sites

Still trying to get a working version of KODi

 

I¡m using the frame buffer version from 

http://forum.odroid.com/viewtopic.php?t=19433

 

But I can't fix this error

12:59:15 T:548117147648  NOTICE: InitWindowSystem: Using EGL Implementation: amlogic
12:59:15 T:548117147648   ERROR: EGL error in InitDisplay: 3003
12:59:15 T:548117147648   ERROR: InitWindowSystem: Could not create display
12:59:15 T:548117147648   FATAL: CApplication::Create: Unable to init windowing system

Any idea?

Share this post


Link to post
Share on other sites

Still trying to get a working version of KODi

 

I¡m using the frame buffer version from 

http://forum.odroid.com/viewtopic.php?t=19433

 

But I can't fix this error

12:59:15 T:548117147648  NOTICE: InitWindowSystem: Using EGL Implementation: amlogic
12:59:15 T:548117147648   ERROR: EGL error in InitDisplay: 3003
12:59:15 T:548117147648   ERROR: InitWindowSystem: Could not create display
12:59:15 T:548117147648   FATAL: CApplication::Create: Unable to init windowing system

Any idea?

ERROR: EGL error in InitDisplay: 3003

This is different abi from kernel and user space mali drivers. It means that kernel driver is different version from user space egl driver.

Share this post


Link to post
Share on other sites

ERROR: EGL error in InitDisplay: 3003

This is different abi from kernel and user space mali drivers. It means that kernel driver is different version from user space egl driver.

 

So it's and error of mali-fbdev or other package?

ii  mali-fbdev                         20160319-r5p1-1            arm64        Mali-Fbdev Drivers r5p1 for s905 based products
.I have updated it.
 
ii  mali-fbdev                         20161003-r6p1-ee42997-15   arm64        Mali Binaries for ODROID-C2 FBDev Version

The error is gone from the kodi log, but still no image...

 

last line in the log is

 

14:15:38 T:548208361472  NOTICE: InitWindowSystem: Using EGL Implementation: amlogic

So I'm not sure if I have fixed something

 

Share this post


Link to post
Share on other sites

 

So it's and error of mali-fbdev or other package?

ii  mali-fbdev                         20160319-r5p1-1            arm64        Mali-Fbdev Drivers r5p1 for s905 based products
.I have updated it.
 
ii  mali-fbdev                         20161003-r6p1-ee42997-15   arm64        Mali Binaries for ODROID-C2 FBDev Version

The error is gone from the kodi log, but still no image...

 

last line in the log is

 

14:15:38 T:548208361472  NOTICE: InitWindowSystem: Using EGL Implementation: amlogic

So I'm not sure if I have fixed something

 

 

No more errors in log? What about core dump? I suspect that hardkernel has blob only for odroid device, that could be the problem. Is your kernel compiled with ump support?

Share this post


Link to post
Share on other sites

No more errors in log? What about core dump? I suspect that hardkernel has blob only for odroid device, that could be the problem. Is your kernel compiled with ump support?

 

I haven't compiled the kernel. Is the kernel provided in the image of 18 Oct.

 

Linux amlogic-s905x 3.14.29 #19 SMP PREEMPT Tue Oct 18 09:19:28 MSK 2016 aarch64 GNU/Linux
 

 

See ful log (with debug enabled) at

http://pastebin.com/tSdJgTKC

 

The folowing errors also happend on LibreELEC, that works fine and I'm using as reference

 

01:00:22 T:548371845120   ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
01:00:23 T:548371845120   ERROR: AML: no rw on /sys/class/ppmgr/ppmgr_3d_mode

On ARMBian I have

 

18:47:03 T:547837812736   ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
18:47:04 T:547837812736   ERROR: DBus: Error org.freedesktop.DBus.Error.AccessDenied - Permission denied
18:47:04 T:547837812736   ERROR: Previous line repeats 3 times.
18:47:04 T:547837812736   ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.PolicyKit1 was not provided by any .service files
18:47:04 T:547837812736   ERROR: PulseAudio: Failed to connect context
18:47:04 T:547837812736   ERROR: AML: no rw on /sys/class/ppmgr/ppmgr_3d_mode

But no FATAL error, Kodi.bin just exit with "segmentation fault"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
71 71