Jump to content
  • 0

When booting from USB key on computer with armbian already installed, the system starts from the computer


bletvaska

Question

hello

 

i am new user of armbian and i really like it. so i am experimenting with it a little. yesterday i successfully installed armbian on one of my old laptops in the lab (Armbian Bullseye with XFCE desktop with kernel 5.15.y released on feb 27, 2023), so currently it boots from internal hard drive. today i wanted to try another image, so i wanted to do the same thing:

 

1. boot from USB key

2. download the new image on USB key

3. run

xzcat armbian.img.xz | dd of=/dev/sda status=progress

4. reboot laptop (to new system)

 

but the step 1 failed - instead of booting the system from USB key (yes - i selected the USB key on laptop start), system started from the laptop's hard drive.

 

i think, this is not expected behavior. or am i missing something and it is really a feature? 🙂

 

anyway - thanks for the project. it gives my old laptops new life ;)

 

mirek

Edited by bletvaska
forgot to mention the image, which i installed
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
2 minutes ago, bletvaska said:

yesterday i successfully installed armbian on one of my old laptops in the lab, so currently it boots from internal hard drive


What was the install procedure?

 

3 minutes ago, bletvaska said:

system started from the laptop's hard drive.

 

Strange.

 

Perhaps there was something wrong with burning to USB? Use some other USB key? Usually its something stupid ;) 

Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

  • 0

the installation procedure on USB key was (probably) with Etcher (i usually use it for this). and installation procedure on laptop was as mentioned:

 

xzcat armbian.img.xz | dd of=/dev/sda status=progress

 

i thought, that the USB key can be possibly wrong, but i am currently using it again to install different armbian image on another laptop. and it works fine - it recognized the setup from USB key.

Link to comment
Share on other sites

  • 0

small update. i've just installed armbian jammy with xfce from rolling releases from ci pipeline, which was released on mar 7, 2023. i installed the system same way as before without any issues. and the booting on that laptop from usb key also works as it should.

 

i was thinking about and rembered, that yesterday i was playing with the tools and tried for the installation tool armbian-install. currently there is only support for installing on sd/emmc, but i tried. i don't have deep understanding about linux boot sequence, but i thought, if there is exact uuid of the root disk, it will start booting from the laptop instead of usb key then (but it's strange, that on the disk without that disk, is booting from usb key normally). to check this, i tried to do the same procedure on the second laptop with newly installed armbian jammy. so i ran armbian-install, rebooted the computer and tried to boot from usb key. and the system was loaded from usb key as it should. when i tried to boot on laptop with armbian bullseye, the system again started from laptop.

 

so i don't know, where is the problem 😞

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...