1 1
twinclouds

Is there a tested/reliable wifi implementatin on OPi PC?

Recommended Posts

I have tried a few different suggestions that I have seen online to implement wifi on Orange PC with a wifi dongle.  However, none them can work reliably.  OrangePi zero works but wifi speed is very slow (about 1-2Mbps).  I recently tried using Raspberry Pi with wifi dongles.  It is almost plug and play and very reliable.  I hope there is a way to do the same on OPi.  If anybody know one, please let me know.  I will be happy to try it out and report back.

Share this post


Link to post
Share on other sites

I did some tests with mainline kernel (sun8i DEV) the other day.

Those four were properly recognised out of the box - wlan0 devices went up, but I did not test for performance.

0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

 

Share this post


Link to post
Share on other sites

@rodolfo

In your link, you are using two different subnet, i.e., ...2.x and ...3.x for eth0 and wlan0.  What I want to do is to have both on the same subnet.  They don't have to work at the same time but if I have the RJ45 connected, I want to use the ethernet.  On the other hand, if the dongle plugged in but not the RJ45, I want it connected through wlan0.  Will your setup work?

@martinayotte For what I wanted to do as stated above, will your setup work?  If it does, what is your setup procedure?

Share this post


Link to post
Share on other sites
12 minutes ago, twinclouds said:

If it does, what is your setup procedure?

My setup isn't something special : Mainline builds and still using old fashion /etc/network/interface.

Share this post


Link to post
Share on other sites

I have setup my OPi one according to @rodolfo's instructions but with both eth0 and wlan0 on the same subnet.  If I plug in both ethernet cable and wifi dongle in, I can connect through either one by ssh, but if I pull out the ethernet cable, I cannot connect through the wifi address any more.  If I only plug in ethernet cable, I can connect through its ip address.  However, if I only plug in the wifi dongle, I can see both addresses but ssh to either address has no connection.  Is there anyway to fix that?

Share this post


Link to post
Share on other sites

@twinclouds

Using the same subnet will most likely cause routing problems. You could use network-manager ( nmtui ) - check documentation - to setup your type of use case. 

Share this post


Link to post
Share on other sites

The issues of having both on the same network and then disconnecting one of them are well know ...

BTW, I don't see any use cases where both wlan0 and eth0 are on the same network would be needed, this is also true with any PCs.

 

Share this post


Link to post
Share on other sites

@rodolfo, @martinayottee:

Thank you both for your reply.  I don't really need both to connect at the same time but try to have the option open.  For example, normally, I will use ethernet.  However, I might want to connect through wifi when move to another area with no ethernet connection.

I have tried network-manager but it does not work too well either.  I can try once more.  However, Raspberry Pi seems being able to do what I wanted.  I hope Orange Pi PC can do the same thing too.

Share this post


Link to post
Share on other sites

This is not an Armbian issue,  but a routing issue where packets are dispatched to one of 2 same routes rules and network system ususally send it to the first interface found, but if this one is been shutdowned, it won't goes out anymore.

If it works on Raspberry, which I doubt (as I said, even with PCs this can occur), you can look at the "allow-hotplug" and other params to figure out why the disconnected route is still present in route rules.

 

Share this post


Link to post
Share on other sites

@martinayottee I tried network-manager.  It appears working for some of the dongles and not the others.  I will to do more testing.

Raspberry Pi works but I am not sure how do they handle it and it looks strange.  In the interfaces file, the iface states are manual, not static or hdcp.  If one need to change them to static, it has to be done in /etc/dhcpcd.conf file rather than in interfaces file.  Do you have any idea what are they doing?

Share this post


Link to post
Share on other sites

I did some tests on my RPi, although I didn't got issues reproduced except some latencies, what I see after unplugging eth0 and been connected to wlan0 is a bit strange, a route rule for default gateway is still there, which can explain latencies :

 

root@raspberrypi:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.111.111.251  0.0.0.0         UG    0      0        0 eth0
default         10.111.111.251  0.0.0.0         UG    303    0        0 wlan0
10.111.111.0    *               255.255.255.0   U     303    0        0 wlan0

 

Share this post


Link to post
Share on other sites

Network-Manager seems working fine on OPi-PC with wifi dongle for my purpose.  However, some of the dongles worked but the others did not, even if they use the same chipset (RTL8188CUs).  Not sure why.

Share this post


Link to post
Share on other sites

El cheapo dongles are a mixed bag. You get what you pay for. Vendor info is largely missing or plain bull. Some work, some do not. Stick with the ones that work.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1