1 1
tpc010

[SOLVED] A33 Tablet unrecognized/unsupported machine ID (r1 = 0x00001029)

Recommended Posts

UPDATE: Today I build it again and now it's working, I think someone has change something. Thank you :-)

 

OLD:

 

I created an new board, based on the lime-a33.conf with BOOTCONFIG="q8_a33_tablet_1024x600_defconfig" and build a Debian Stretch Image with mainline Kernel 4.13 / 4.14. The SD Card is booting with a nice screen output but only to Kernel Boot, then the screen freezes.

 

The Serial connection is only in the SD Adapter and I cant use it if I'm booting from it, or is there a possibility ??

 

I was checking devuan.org and this Image is booting the Tablet, with Kernel 4.1x.

 

So I want to debug the Armbian Kernel with serial output and I used fastboot for it, I'm booting into fastboot with "adb reboot bootloader" and then I'm sending the bootimage with fastboot ( first I created a image with mkimage with and without dtb file)

 

fastboot -c "console=ttyS0,115200" boot uImage

But I get this error from armbian Kernel

 

Starting kernel ...
 
Uncompressing Linux... done, booting the kernel.
 Error: unrecognized/unsupported machine ID (r1 = 0x00001029).
 Available machine support:
 ID (hex)    NAME
ffffffff    Generic DT based system
ffffffff    Allwinner sun9i Family
ffffffff    Allwinner sun8i Family
ffffffff    Allwinner sun7i (A20) Family
ffffffff    Allwinner sun6i (A31) Family
ffffffff    Allwinner sun4i/sun5i Families
 Please check your kernel config and/or bootloader.

Full Log is attached.

 

I checked a lot of things, but I can't find a solution to solve this problem, the devuan.org Kernel is booting this way, until it can't find the SD Card.

 

Thanks for your Help

log1.txt

Edited by tpc010

Share this post


Link to post
Share on other sites
On 9/15/2018 at 10:19 PM, markbirss said:

@tpc010 What specific tablet you are using ? Are you able to boot a Armbian build image directly from sdcard now?

Hi Markbirss, I checked it again with current build and it's working with module "g_serial" add to boards/lime-a33.conf

 

config/boards/a33-q8-tablet2.conf

# A33 quad core 1Gb SoC
BOARD_NAME="q8 A33"
BOARDFAMILY="sun8i"

# depending of board and resolution use a defconfig file from sources/u-boot/v2018.05/configs
BOOTCONFIG="q8_a33_tablet_1024x600_defconfig"
#MODULES="hci_uart gpio_sunxi rfcomm hidp bonding spi_sun7i 8021q a20_tp"
MODULES="hci_uart gpio_sunxi rfcomm hidp bonding spi_sun7i 8021q a20_tp g_serial gslx680 gc0312 gc2145 rtl8150"
MODULES_NEXT="hci_uart gpio_sunxi rfcomm hidp bonding spi_sun7i 8021q a20_tp g_serial gslx680 gc0312 gc2145 rtl8150"
OVERLAY_PREFIX="sun8i-a33"
#
KERNEL_TARGET="next"
CLI_TARGET="stretch:next"
DESKTOP_TARGET=""
#
RECOMMENDED="Debian_stretch_next:75"
~/armbian/cache/sources/u-boot/v2018.05/configs$ ls -1 *[Aa]33*
A33-OLinuXino_defconfig
q88_a33_tablet_1024x600_defconfig
q8_a33_tablet_1024x600_defconfig
q8_a33_tablet_800x480_defconfig
Sinlinx_SinA33_defconfig

 

I had to disable the pwm_bl module, otherwise the screen will go black while boot.

echo blacklist pwm_bl>/etc/modprobe.d/pwm.conf

I checked it with some Allwinner A33 Tablets from eBay or Amazon, the touch isn't working at the moment, but I hope I have time to check it in the future.

 

Share this post


Link to post
Share on other sites

@tpc010 unfortunately my A33 tablet, does not start at all from sdcard no matter what A33 image or u-boot i try.

 

fel-storage does not work for me either, so im stuck

 

NeonNiQ NQT-7W tablet from South Africa, running Android 5.1

 

7inch 1024x600, 512mb ram, 8Gb storage 

a33.jpg

Share this post


Link to post
Share on other sites
On 9/25/2018 at 6:12 PM, tpc010 said:

I checked it with some Allwinner A33 Tablets from eBay or Amazon, the touch isn't working at the moment, but I hope I have time to check it in the future.

which one from ebay would work (without touch)?

Share this post


Link to post
Share on other sites
10 hours ago, guidol said:

which one from ebay would work (without touch)?

Tablets like this, I bought it at ebay with broken Touch for testing, also a broken 10,1" Tablet, this was also working for testing, and an A88S from alldaymall.

 

Wifi is also working, but this can change from tablet to tablet.

 

Yuntab Q88H - 7 Zoll Tablet PC,Android 4.4, Quad Core, HD 1024x600, Dual-Kamera, Bluetooth, Wi-Fi, 8GB

https://www.amazon.de/dp/B01IJRDGGK

IMG_2581.thumb.jpg.68e5e0bf5383e2114233b8a57898766b.jpg

IMG_2582.jpg

IMG_2579.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1