3 3
sgjava

C2 mainline networking issues

Recommended Posts

It seems the networking in Armbian 5.59 is messed up. It creates a eth0 adapter (disabled) and Wired network 1 adapter. You can delete these in nmtui, but they always return. I had the same issue with NanoPi Duo using mainline Stable. I can get it to work a bit using armbian-config, removing all interfaces and configuring IP, but it gets screwed up again. I cannot trust to run 5.59 headless because I have no way to get into the SBC without hooking video back up.

Share this post


Link to post
Share on other sites

C2 network is known to make troubles. I hope with each related patch that comes around that it will fix issues ... the last one claimed network troubles were fixed. I didn't notice them which doesn't mean anything.

 

In general, it depends on which version do you use - Debian or Ubuntu, armbian-config is not very polished yet so it could make some troubles ... network (address) settings should be in users domain. We try to keep it simple and the same on all.

 

If you have troubles, try to disable "advanced" NetworkManager networking and use ifupdown.

Share this post


Link to post
Share on other sites

@Igor I fixed this by using armbian-config, clearing interfaces and using /etc/network/interfaces. Now I can reboot with a static address. With NanoPi Duo I had to remove netplan and use ifupdown for eth0, but the xradio wifi stuff seems to be missing from the kernel (modules, etc.). But in essence they exhibited the same issue with eth0.

Share this post


Link to post
Share on other sites

I am experiencing the similar network issues. My C2 didn't get an IPv4 address via DHCP only an IPv6 address. I have to use my router to figure out that IPv6 and connect to it. With the hints from Igor I got IPv4 also working:

systemctl disable NetworkManager

Add add the following to `/etc/network/interfaces`:

auto eth0
iface eth0 inet dhcp
iface eth0 inet6 auto
    privext 0

`privext 0` is optional. It disables the IPv6 privacy extension for server use. I had a lot of trouble with that too before I disabled NetworkManager.

And of course:

reboot

I hope this will be fixed soon.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
3 3