0
BananaGonzo

Can't remote access BananaPi with SSH

Recommended Posts

Hi guys,

today i wanted to access my BPi with armbian installed remote with SSH.  Terminal says: port 22: Connection refused. I'm able to ping the BPi. At least last week I was able to access the BPi with remote SSH.

When i connect it via HDMI i can see the boot process until it says loading kernel - then the screen turns all black and nothing happens anymore.

If I try to access some installed webservices, the browser says it can't connect.

 

What can I do?

Share this post


Link to post
Share on other sites

Hi martinayotte,

 

thank you very much for your answer. I do have a FTDI USB dongle and  a Atmel USPasp - what can i do with this? Do you have a Youtube Link for me?

 

How do I test the SD card for corruption?

 

Thanks in advance.

 

[€]: Or an Arduino if you want.

Edited by BananaGonzo

Share this post


Link to post
Share on other sites
1 hour ago, BananaGonzo said:

FTDI USB dongle and  a Atmel USPasp

USPasp is useless but FTDI USB is OK : simply attach GND/TX/RX to BananaPi and open PuTTY at 115200 board, and powerup the BPi, you should see booting log until login prompt ...

1 hour ago, BananaGonzo said:

Youtube Link

I don't have any, but there are maybe some already ...

1 hour ago, BananaGonzo said:

SD card for corruption

if you are able to reach login prompt, log as root and do a "fsck.ext4 /dev/mmcblk0p1"

 

Share this post


Link to post
Share on other sites
18 hours ago, martinayotte said:

This is what appears right at the beginning of fresh boot ?

It is almost sure that your SDCard is corrupted ...

Try another one with fresh image.

Right.

Ok, maybe.

I installed the freshest Armbian Bionic mainline kernel 4.14.y on a fresh formatted SD - same screen in the console as shown above. Is it just me?

16 hours ago, helper-dialog said:

Can't remote access BananaPi in short = crab, crabs walk sideways, you have to walk forward for it to work

What do you mean?

Share this post


Link to post
Share on other sites
23 minutes ago, Igor said:

 

If there was some corruption or unclean first run, do this:
https://www.cyberciti.biz/faq/howto-regenerate-openssh-host-keys/

Thank you Igor - it seems that the service is not running on startup even there is an entry at /etc/init.d :-(

I even tried to set up a cronjob (@reboot).

 

Doesn't work :-(

 

This is what its look like after reboot (connected via serial):

 

root@bpii:~# /etc/init.d/ssh status
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
root@bpii:~# 

 

 

Ok, seems that when I'm connected via serial it is in emergency mode - I have to shut it down completely (shutdown -h now) disconnect power and FTDI, and connect power again.

 

Now it works...:thumbup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0