Le Potato i2c bus


Recommended Posts

If I do i2cdetect -y 0 I don't see the device id I expect to 0x10 but I do see 0x30 and 0x50 which I shouldn't because there should only be one device at 0x10.  I only see one i2c bus at /dev/i2c-0.  

 

Is that the i2c bus using header pins 3 and 5 which is where my device is attached?

 

If not how would I enable the bus on pins 3 and 5?

Link to post
Share on other sites
Donate and support the project!

http://ix.io/1wtZ
 

BTW i2cdetect -l says

i2c-0    i2c           DesignWare HDMI                     I2C adapter

 

My best guess is that /dev/i2c-0 is picking up an i2c channel on the hdmi interface and not the one on header pins 3 and 5.  The docs say you can enable onboard i2c/spi via the armbian_config System->Hardware menu but I don't have the menu option when I run it from the Applications menu.
 

Link to post
Share on other sites

Thanks, worked great.  I now see bus /dev/i2c-0 and /dev/i2c-1 and my device id shows up on /dev/i2c-0

 

i2cdetect -l

i2c-1    i2c           DesignWare HDMI                     I2C adapter
i2c-0    i2c           Meson I2C adapter                   I2C adapter
 

Looking forward to the future update with the overlays and eMMC, I have what I need to try and port the Pi-Top device support over now.

Link to post
Share on other sites

Hi,

 

I'm having same issue.  

 

i2cdetect -l shows me only:

i2c-0    i2c           DesignWare HDMI                     I2C adapter

 

And no device detected at bus /dev/i2c-1. It should be typically detected at 0x60. I've connected the sensor at pin 3 and 5.  And I'm running 4.19.55+ kernel. Any idea how to solve this? Thanks!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...