1 1
eddywebs

Startup Message/Script stopped working

Recommended Posts

Hi all  I am using the Armbian 5.32 OMV image, recently the startup message stopped working after a hard reboot. Any ideas where the startup script exists (the one which displays Welcome to Armbian and all the vital stats) or how to troubleshoot such issue ?

 

The amrbianmonitor logs is available at >> http://sprunge.us/QLfq9F

 

Thank you !

Share this post


Link to post
Share on other sites

The scripts should be in /etc/updated-mot.d ... perhaps already one reboot solve this? Otherwise check motd service status. That one is responsible for this.

Share this post


Link to post
Share on other sites
2 hours ago, Igor said:

The scripts should be in /etc/updated-mot.d ... perhaps already one reboot solve this? Otherwise check motd service status. That one is responsible for this.

 

You are right, when I did  sudo systemctl status motd  it returned

● motd.service
   Loaded: masked (/dev/null)
   Active: inactive (dead)

Motd fails to start upon sudo systemctl enable motd, with the following message

 

Synchronizing state for motd.service with sysvinit using update-rc.d...
Executing /usr/sbin/update-rc.d motd defaults
Executing /usr/sbin/update-rc.d motd enable
update-rc.d: warning: enable action will have no effect on runlevel 1
Failed to execute operation: No such file or directory

Any Ideas why it would do so ? . Subsequent restarts have not fixed the problem :(

Share this post


Link to post
Share on other sites
9 hours ago, eddywebs said:

Any Ideas why it would do so ? . Subsequent restarts have not fixed the problem


I am not familiar with motd service in details - you will have to look on your own - at least we identify the source of the problem. This usually takes much more time than the actual fixing.

 

We only replace stock welcome message with ours but the motd service is stock Debian / Ubuntu. You have to check motd manual, reinstall package, check around for generic motd troubles. They are unrelated to Armbian as well as OMV, which drastically changes Armbian to suit their needs.

Share this post


Link to post
Share on other sites

I suffered from the same problem and want to document the solution I found lately.

 

The problem doesn't seem to be related to the motd.service at all. The output looks exactly the same on a working system.

Instead I took a look at my sshd_config in /etc/ssh/ because we dealt with ssh-logins and I remembered that during a apt upgrade I had to decide if to switch to a new version of sshd_config or to stay with my old.

 

However, it turns out that the welcome message depends on the UsePAM parameter in sshd_config.

If it is set to 'no' you won't receive the fancy welcome message. Simply turning it to 'yes' did the trick for me and I now receive the welcome message again with every ssh-login.

 

Summary:

Make sure that this is in your /etc/ssh/sshd_config:

[...]

UsePAM yes

[...]

 

Hope this helps some other folks.

Share this post


Link to post
Share on other sites

@eddywebs Did you change you startup-messages-scripts?

A while ago - when I added my package-info lines in the script I did miss a '-sign

and after that I got no output.

After I did correct the syntax the messages did come back.

You could try to start the message scripts manually to see if any single script do produce a output.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1