Jump to content

mo123

  • Posts

    22
  • Joined

  • Last visited

 Content Type 

Forums

Member Map

Store

Crowdfunding

Applications

Everything posted by mo123

  1. mo123

    Odroid M1

    @rpardiniCan you build an Odroid M1 focal 22.05 legacy kernel Ubuntu Server image perhaps?
  2. Hi Anyone perhaps know how to install librga2, librockchip-mpp1 on Armbian_22.05.0-trunk_Station-p2_focal_legacy_4.19.219 Ubuntu Server image? Is there a way to build Armbian Ubuntu Server Focal 20.04 4.19 image, even if selected in the menu it builds 22.05 instead?
  3. Yes, seems bt is working on P1. It seems it uses a USB driver and not uart so works out of the box For P1, can you check the wifi driver? It seems it builds the 5.13.4 driver for 5.15/5.16 kernels but should change to the master branch which has a fix otherwise wifi authentication fails after you type a wifi password. https://github.com/150balbes/build/blob/armbian-tv/lib/compilation-prepare.sh#L660-L661 I tried LE too(from your Yandex link) but it doesn't show a wifi connection on P1 even after adding this master RTL8723DU branch package, so must be something else, perhaps the kernel config file or something changed in LE?
  4. Anyone know how to completely disable console output for ttyS2 on RK3328? Are there also getty services using it by default? When I go to /dev there are only files for ttyS0, ttyS1 & ttyS3. I need to have console completely disabled for ttyS2 since I need to use bluetooth over ttyS2. Bluetooth chip is a RTL8723DS that is sdio + uart. When Armbian for RK3328 is build, it shows this message. How to stop it from enabling ttyS2? o.k. ] Enabling serial console [ ttyS2 ]
  5. I just got bluetooth working but on the Station P1 for Bullseye 5.15 It uses RTL8723DU bluetooth. It uses serial0 while the Station M1 uses serial2 for bluetooth. Only thing I can think of is that the serial2 is in use somewhere by Armbian and doesn't get released for bluetooth or there might be a small bug in the kernel driver for RTL8723DS bluetooth that work differently than RTL8723BS, RTL8723DU. It's very difficult to find the exact cause but there is hope.
  6. We are a little closer. Managed to add the driver to 5.17 kernel. The bluetooth icon shows but then have a problem loading the firmware files. Also going to test the 4.4 kernel and compare with working Ubuntu image.
  7. How do you build Armbian for RK3399, RockPi4 with edge 5.15/16 kernel instead of current that is 5.10? The GUI only shows legacy and current to select.
  8. They are working on it. It might just be as simple as adding the following to https://github.com/torvalds/linux/blob/master/arch/arm64/boot/dts/rockchip/rk3328-roc-pc.dts#L97 +&uart2 { +status = "okay"; + + bluetooth { + compatible = "realtek,rtl8723ds-bt"; + device-wake-gpios = <&gpio1 RK_PD0 GPIO_ACTIVE_HIGH>; /* PL5 */ + host-wake-gpios = <&gpio1 RK_PD2 GPIO_ACTIVE_HIGH>; /* PL6 */ + }; +}; then add such a patch to Armbian kernel patches and recompile Armbian. But the Android 4.4 kernel has some other settings also for bluetooth which I don't know how it works with the 5.17 kernel. What is the result of: rfkill list lsmod | grep -i blue or dmesg | grep -i blue lsmod (Not sure if the commands work) What files do you see here and in the subfolders? /lib/firmware Are there rtl8723d*- files?
  9. I'll ask the manufacture next week if they can also check the mainline kernel. I know LibreELEC had a problem with them using Realtek wifi/bt, so they had to remove it to get official LE support. Not sure if bt changes were added back later. @balbes150 Here is 4.4 kernel dts with working bluetooth on StationOS https://pastebin.com/1FBB9Jiu Mainline dts https://github.com/torvalds/linux/blob/master/arch/arm64/boot/dts/rockchip/rk3328-roc-pc.dts Maybe uart2 bluetooth things are missing in dts used by mainline kernel?
  10. It should use these 2 bluetooth firmware files, but it looks like it is already part of Armbian. https://github.com/armbian/firmware/pull/24/files Wifi/bt kernel drivers https://github.com/lwfinger/rtl8723ds Perhaps the mainline kernel dts or config file don't have bt?
  11. @balbes150Do you perhaps know how to fix the bluetooth issue Chris4arm is experiencing?
  12. Those 2 images are very old. Try newer images from here. https://users.armbian.com/balbes150/station-m1/ With the 4.4 legacy kernel images, everything should work or the 5.16 kernel ones. You are still using kernel 5.10 that might not have drivers for all the components or the drivers might have small bugs.
  13. The Station P1/M1 already has Armbian support but for the Station P2/M2 you will have to wait a couple of weeks until these new devices are more readily available and Armbian developers also get them. Rockchip is also still busy submitting drivers for the RK3566/RK3568 to the mainline kernel. There should be more info here later. https://wiki.t-firefly.com/en/ROC-RK3568-PC/started.html https://www.stationpc.com/ The current OS installed I think is Android 11 with a custom launcher and apps.
  14. You have to wait until Armbian adds support for RK3566/RK3568 processors, only RK3328 & RK3399 are supported at the moment since the new processors are still very new and no one has them except a few people. They are very different from RK3399 ones used in devices like the Station P1, so won't boot. Station P2 will get mainline Linux support so in future it should work with most Linux ARM OS's. Yes, Armbian boots automatically from micro-sd card on Rockchip devices.
  15. Hi Anyone know where the RTL8723DU wifi driver is in the kernel, the kernel config changes needed & system binaries to make the wifi/bt work on the 5.x kernel for ROC-RK3399-PC-PLUS, Station P1?
  16. I have 2 Android 7 images booting on the UT3(S). I will upload the dts files based on 4.4.112 kernels, maybe it will help us to get the device working better with Linux support? The dts files are in hex format not decimal format since I don't have the original source code and extracted it from Android. I have the Android 5.1 kernel source code too but it's based on an old 3.10 kernel, not sure if that will help. I also have an RK3288 Android 8 SDK but there is no dts for ut3 to compile a kernel or working Android firmware. The SDK is also a tablet SDK and have no 'box' support but should technically be able to work since the Tinkerboard also uses a tablet Nougat SDK. The closest dts file I find is the rk3288-firefly-reloaded.dts one in the Rockchip-linux kernel source on Github and in the Android SDK. Perhaps it or the RK3288 Q8 dts file can help to make a 4.4.x and mainline Armbian or LibreELEC image for the UT3(S) that works better and maybe also help with a new Android OS(if I can get it booting). I also have a second UT3 that I bricked by flashing RK3368 or Linux firmware to the internal emmc by accident. It still had Android KitKat on and didn't support booting from a micro-sd card. The bootloader or emmc is most like corrupt and no flash tools can detect or flash it anymore. There isn't perhaps a way in Linux to repair it or must I write it off? Al my attention was on RK3328 & RK3399 devices, so I didn't spend more time on RK3288, but maybe now I can.
  17. Check if this patch is missing from the mainline kernel perhaps, it's responsible for the headphone jack. https://github.com/radxa/kernel/commit/cc4fef39f29bda97ba1d9129d897e77d08ccf096
  18. Anyone that still have a working rk3288-ugoos-ut3s.dts file for a 4.4 kernel or can make one compatible up to the latest RK 4.4.167 kernel one? It seems all the Omegamoon sources are dead that were used for an old LE build. I want to try to use it to build a working LibreELEC image using a new 4.4.167 kernel. I have an Android 4.4.112 kernel dts for the UT3S that boots Nougat, can post it if it will help someone. If I build LE for Miqi RK3288, it boots on the UT3S but gets stuck on the LE splash screen. So the Miqi dts could be a starting point but need changes from a UT3S dts file, I think the rk3288-firefly-reload.dts already in the 4.4.167 kernel might also be a good starting point, it would only lack fan support and some other things perhaps. Perhaps if LE boots, it wouldn't be too difficult to get an Armbian image going too. I think all the Ugoos Linux images used a 3.10 kernel, not 4.4 that is available now,.
  19. @balbes150 Can you make a Rk3328-tv_Ubuntu_bionic_default_desktop image that uses a 4.4.167 kernel like the default Armbian Rock64 image with working media script also included? It seems the media script was made for this kernel and nightly Armbian images and 4.4.154 kernel is used in your images. I tried again Armbian_5.71_Rk3328-tv_Ubuntu_bionic_default_4.4.154_desktop_20190115.img.xz But before the media script install the desktop was running about 5 times faster and no tearing and slowness when moving windows. Browser video playback still 3 times slower with the script installed then before. I looked and armsoc driver is used after the script is installed. I also changed etc/x11/* file to use glamor driver but then all windows of apps just have outlines and the inside of windows are just blank. Apps also constantly close by itself like the browsers. I changed default dtb from MX10 to mvr9 also.
  20. Where do you turn off window compositor? I tried Armbian_5.71_Rk3328-tv_Ubuntu_bionic_default_4.4.154_desktop_20190115.img.xz(https://yadi.sk/d/DSO6euzB3ahemo/ARMBIAN/5.71/Armbian_5.71_Rk3328-tv_Ubuntu_bionic_default_4.4.154_desktop_20190115.img.xz) on MVR9 and installed the media script but Moving windows around still have a lot of tearing and corruption and is not smooth. MPV Player can't seem to detect external storage drives, but will use Gstreamer instead then. Using Chromium browser 32-bit optimised for streaming, eg. Youtube loads very slowly with tearing and videos in a window or fullscreen is not watchable. How do you run Kodi correctly, is there simple instructions to create a new shortcut with 'kodi-gbm-wrapper'? It says it must kill the desktop to run then it boots to a command prompt to login. On a clean install, the sound doesn't work, you must change the HDMI sound in the volume manager first, maybe just a small bug. Is the script perhaps incompatible with the kernel used in this Armbian desktop image or something I'm doing wrong? Thanks
×
×
  • Create New...