1 1
JBraun

Kernel not boot with u-boot

Recommended Posts

On my cubietruck I have tried the Armbian_5.75_Cubietruck_Debian_stretch_next_4.19.20. For me it looks that u-boot loads the files, but the kernel will/can not start. Attached the output from the console.

Rarly I get some additional output on the console like "Uncompressing Linux... done, booting the kernel." but nothing happens, or some wild output from wrong instructions which leads to a reset.

I have also tried "Armbian_5.59_Cubietruck_Ubuntu_xenial_default_3.4.113_desktop" to exclude some mainline / legacy kernel issues. But no luck.

With some older versions (e.g. 5.20) I have no luck also.

From my feeling there is a basic thing, may be:

  • timing (RAM, SD-card)
  • RTC / empty batterie
  • problem with the NAND in the background / or the bootloader from there interferes
  • missing some requirements

 

After reading dozens of topics from the forum and spending a lot of hours for a search in the web, a have no idea how to go further to solve this issue.

Any hints what I can check / do? 

 

What works:

I am able to boot an old armbian (legacy kernel) from NAND. There , I can mount the SD-card and read and write.

I am able to boot an linaro (older) from SD-card without problems. I have seen that the clock is not up to date. The time started an bootup.

 

How I have tested:

To the cubietruck I have only connected SD-card, HDMI, network, power supply and UART0 console with putty.

I have burned image with win32imager (version 1.0) and verified.

I have used different SD-cards (brands, sizes, classes).

I have used different power supplies on the power connector => same result.

 

Regards,

Joerg

printenv.txt

u-boot_log.txt

Board: Cubietruck

Share this post


Link to post
Share on other sites
1 hour ago, JBraun said:

UART0 console with putty.

Make sure that "verbosity=7" and "console=serial" in /boot/armbianEnv.txt, and using "putty" on serial-debug, it should provide more information where it is stuck after "starting kernel".

Share this post


Link to post
Share on other sites

Hello martinayotte,

 

thanks for the fast reply.

I modified the file /boot/armbianEnv.txt with verbosity=7 and console=serial as suggested.

I used putty on an other device. This is connected to the UART0 on cubietruck (4 pin header close to the USB ports). I think, that this is the serial-debug. Right?

 

No luck. The kernel is not starting. The output is still the same. See attachment.

armbianEnv.txt

log_from_putty_with_verbosity=7_console=serial.txt

Share this post


Link to post
Share on other sites
14 minutes ago, JBraun said:

The output is still the same.

That is strange ... I'm running out of ideas ...

Since I don't own a cubietruck : any body else who own a cubietruck have tried that image ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1