The Armbian status for Banana Pi M1 Plus


luoyi
 Share

1 1

Recommended Posts

I've tried the current armbian release legacy & vanilla with my bpi m1+ board. and it looks like it's still have some distance away from an idea linux enviroment .

 

The legacy version

 

  • I've apt-get update and upgrade after login into the system, so all the software in the system is on their latest version.
  • on default configuration, the wifi is not usable. I've to uncomment the ap6211 line in the /etc/modules file. after uncomment and restart, the wifi is usable and stable (very cool !). I've tried to transport 100G+ data through wifi interface, doesn't have any trouble with it.
  • I can see card0 and card1 in the /proc/asound/ sub directory. and aplay -l can list 2 sound card. when I use card0 to play music file, the sun7i integrated audio  codec driver works very well, I can plug my earphone into the 3.5mm headset jack on the board and hear the sound. But when I choose card1 to play , although the /proc/asound/card1/pcm0p/sub0/hw_params shows the correct value (so that tell me that the alsa driver layer working correctly at least), but I can't hear any sound through my PCM5102 DAC which connected to the M1 Plus board . and I've tried to use a logic analyzer to observe the i2s signal on the pin35/36/40. it doesn't show  the right signal graph. so I guess the driver doesn't work corretly and the i2s core in the A20 chipset is not working at all.
  • it looks like in the vanilla version, the m1plus dts file is different from the pipro dts file. but in the legacy version, the m1plus's script.bin file is just the same as the pipro's. does this correct ?

The Vallina version

 

  • I've modified the boot.scr file to make kernel use the sun7i-bananapi-m1plus.dtb file
  • wifi is not usable. brcmfmac driver always tell me -110 error.
  • there are no usable i2s driver in the current mainline driver

and my question is:

 

  • with legacy version, what can I try to make the i2s audio driver work right ? fex file or some any other magic configuration file?
  • with vallina version, what can I try to make the wifi driver work right ?

at last, very thanks for this great distribution, it's really a mess to collect so many fragment information through different github repo . ( u-boot/kernel/dts/driver and so on ) . I think it looks like A20 is the mainline support chipset in the sunxi community. hope we can provide better support for it.

Link to post
Share on other sites

Donate and support the project!

it looks like in the vanilla version, the m1plus dts file is different from the pipro dts file. but in the legacy version, the m1plus's script.bin file is just the same as the pipro's. does this correct ?

 

Not any more, I imported a dedicated fex file for M1+ a while ago since some differences do exist. But since it's a SinoVoip product and they really don't get the idea why documenting hardware features correctly should matter I would assume that there are still some errors present. I tried to correct a few of the known ones (all user contributed from forums discussions since SinoVoip doesn't care as usual) and here we are: https://github.com/igorpecovnik/lib/commit/b25abe478b1512b4221076886b4c465cf12510ec#diff-2245023265ae4cf87d02c8b6ba991139

 

You might notice that I enabled I2S in the fex file with the 2nd commit and now it looks like this: https://github.com/igorpecovnik/lib/blob/master/config/fex/bananapim1plus.fex#L948-L958

 

But since I've not the hardware [1] I can not say whether the pin mappings are correct or not. Please report back after using this fex file (translate it with fex2bin please).

 

[1] I tried to order an M1+ a few months ago from their European distributor but the typical 'SinoVoip experience' applies to these guys too. They told me Banana Pi Pro would've been discontinued (not true, I didn't ask for the Pro but M1+ instead and they don't even sell this board since it's LeMaker's), then they tried to sell me the M2 instead (no thanks) and so on. 

Link to post
Share on other sites

luoyi@bananapipro:~$ md5sum bananapim1plus.fex  bananapim1plus.bin
6bb90c1abddcaf9421c9ffad9be3b01f  bananapim1plus.fex
0d6b2fbabcd3006d0577111b45b2ee71  bananapim1plus.bin
 

luoyi@bananapipro:~$ ls -al /boot/script.bin
lrwxrwxrwx 1 root root 28 Apr 28 03:46 /boot/script.bin -> /boot/bin/bananapim1plus.bin
 

the kernel refuse to boot. error log is :

 

http://pastebin.com/raw/z3xFWdiC

 

BTW: I can donate some bp1 m1+ to the armbian community for better support on it. you can PM me your address . and I'll try to send a international mailbox.

Link to post
Share on other sites

Last time when I had a banana day, we had to solve non working SATA, which is far more problematic and all I could do was to notice that wifi is not working in mainline. I made few logical steps but failed. Probably my concentration was already too much down.

 

Those configurations needs close examination and should be fixed ... or we could simply(?) obtain truly working versions.

 

I do have this board, also donated from forum user. Thanks for offering.

 

Since you opened this problem, let's try to find solution starting from here. We already drop the idea to hack board config to have all bananas ... or oranges under one conf / image. It just brings additional confusion and problems.

Link to post
Share on other sites

every good  linux distribution will always have their own way of testing and verify the main function working well with every release. so maybe we can build a steady testing farm for that purpose.

 

and different people focus on different subject. my main focus about banana pi M1+ is :

 

  • wifi
  • OpenELEC integrate with cedrus or cedarx
  • proper i2s driver for hifi purpose
  • IR receiver 

obviously, I want to use banana pi for entertainments purpose. and maybe the SATA function is more important to some one who focus on home-NAS or storage purpose.

 

Last time when I had a banana day, we had to solve non working SATA, which is far more problematic and all I could do was to notice that wifi is not working in mainline. I made few logical steps but failed. Probably my concentration was already too much down.

 

Those configurations needs close examination and should be fixed ... or we could simply(?) obtain truly working versions.

 

I do have this board, also donated from forum user. Thanks for offering.

 

Since you opened this problem, let's try to find solution starting from here. We already drop the idea to hack board config to have all bananas ... or oranges under one conf / image. It just brings additional confusion and problems.

Link to post
Share on other sites

Hello,

I'm a recent owner of a BPI-M1+ that will be used as home server and wifi router.

So far the Armbian distribution (vanilla kernel) is great, thanks for the hard work!

 

I've spent several hours trying to make the wifi work (changing power supplies, etc.), until I stumbled upon this thread, that confirms my experience. brcmfmac keeps logging errors.

How can I assist you to get this issue fixed?

 

Thanks!

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

1 1