Nanopc T4 - reflash eMMC?


1 1

Recommended Posts

Flashed Armbian Buster to eMMc and now want to flash to Armbian Bionic.  

I know there's instructions using a usbC in the friendlyarm wiki but this just isn't working out... I used the Windows method / tool to erase the eMMC as it says which seemed to work but it still boots from the eMMC :/

Are there any better instructions any where?

Link to post
Share on other sites

Donate and support the project!

Yeh - for the life of me I couldn't get that to work... It sure woud be nice and simple if it did!

I could get it into loader mode by pressing recovery button + power to start but the boot button didn't seem to do anything whatever I tried and it just booted from eMMC.


Will have another go...

Link to post
Share on other sites

I could never get a reflash armbian to armbian working regardless of method and I tried them all.

Although a bit cumbersome, the method that does work for me 100% is loading a SC with the eflasher friendly desktop image (this brings up a gui offering a restore option)

Once installed I’m then able to flash armbian everytime

Sent from my iPad using Tapatalk

Link to post
Share on other sites

@JnrJedi Could you please break this down into steps for me with a bit more explanation.


Do you mean that if you load an FriendlyArm eflasher-friendly desktop image onto an SD then boot, the OS on the eMMC doesn't automatically load and you get a GUI running from the SD instead? Then you install FriendlyDesktop - but then how do you install Armbian after that?

Link to post
Share on other sites

Re. using the Boot button - if you have to press power and boot buttons together, you only have a short time before pressing the power button for too long just shuts board down. Do you 1. Press and hold Boot, 2. Press and hold Power just until power light comes on then release, 3. Release Boot same time as Power, 5 secs later, after booting from SD finishes - or when?

I tried lots of ways and no good - and read of others not being able to get this to work...

Link to post
Share on other sites

Thanks - the GUI just came with a normal boot - didn't have to press recovery button. 

So, I had armbian buster flashed to eMMC > installed friendlydesktop > booted armbian bionic image from SD > reflashed eMMC. Armbian bionic now loading from eMMC.


Re. boot button, I got armbian bionic on an SD to load using it (with armbian buster still on eMMC), but you can't reflash the eMMC this way as the option isn't there in armbian config.

Link to post
Share on other sites

I tried the recovery button in order to install OS on NanoPi M4v2 as follow:

1) Flash microSD card with eflash image
2) Insert microSD in board and plug the eMMC module

3) Power on the board

4) Install OS on eMMC

5) Shutdown board and eject microSD

6) Keep pressed recovery button while press power button for 2 seconds

7) Release recovery button 

8) eMMC has booted fine to OS


Thanks to this forum for the TIP

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


1 1